Zoneminder install DVD 1.24.x (3/7/2011)

Support and queries relating to third party Live CDs and DVD, VM images and other packaged distributions
cadman97
Posts: 2
Joined: Fri Feb 13, 2009 7:08 am

Post by cadman97 » Fri Feb 13, 2009 5:30 pm

ok, that is what my problem is, I was actually installing it to try it out that way when I got your response. Will let you know how it goes.

newvisionantenna
Posts: 381
Joined: Sat Jan 17, 2009 7:49 pm
Location: Germany
Contact:

Post by newvisionantenna » Fri Feb 13, 2009 5:37 pm

I was hoping my upload went ok, so I'm sure it's just running it live is the problem. If you want, go back to that online demo and use test/test to login and you can play with the cam settings and try and setup your remote cam. The account is still limited in that you can only mess with setting up the one camera, but at least you and others can try out your camera.

cyrulution
Posts: 52
Joined: Sat Jul 28, 2007 12:27 pm
Location: Kinzweiler, Germany and Beith, Scotland
Contact:

Post by cyrulution » Sat Feb 14, 2009 12:09 pm

I just installed the dvd I downloaded this night and I can't get the channels above (0) in my video card running. I got two so named "pico" cards ("options bttv card=77,77").

/dev/video0 (0) is working fine
/dev/dideo1 (0) is working fine
/dev/video0 (1) no chance
/dev/video0 (2) no chance
/dev/video1 (1) no chance and so on

The cards were working fine with ZM 1.22.3 and Ubuntu 8.04
Is this an issue of ZM 1.24 or caused by the dvd?
Serenity is not freedom from storm; it's peace within the storm

newvisionantenna
Posts: 381
Joined: Sat Jan 17, 2009 7:49 pm
Location: Germany
Contact:

Post by newvisionantenna » Sat Feb 14, 2009 12:36 pm

I would love to offer help, but at the moment I have no capture cards to work with. All options and perl modules were compiled even in the free dvd link. Since you are getting video out of some channels and not others it would atleast seem the 8.04 is seeing the card. Maybe with some tweaking and help from other users of this card you could get it all working.

Since I have really nothing to do today, send me a pm and we could try and get this worked out. I'm looking over some info on pico cards and zoneminder. I'm sure if Cordel or some of those other guys that use these cards could step in and get this fixed up in no time.

cyrulution
Posts: 52
Joined: Sat Jul 28, 2007 12:27 pm
Location: Kinzweiler, Germany and Beith, Scotland
Contact:

Post by cyrulution » Sat Feb 14, 2009 7:41 pm

I tried everything I could imagine, no chance to get the channels working. So I gave up, installed the original ubuntu 8.04 cd and zm 1.23.3 again.

And after configuring the necessary settings: there were all channels again. Without any problems.

So it must be an 1.24 dvd problem: with card=77 only one of 4 channels is working.
Serenity is not freedom from storm; it's peace within the storm

newvisionantenna
Posts: 381
Joined: Sat Jan 17, 2009 7:49 pm
Location: Germany
Contact:

Post by newvisionantenna » Sat Feb 14, 2009 8:22 pm

I highly doubt it's the DVD, but thanks for trying anyway. I'm helping someone right now with a pvr-150 that is having an issue and I'm not sure if this is a clue or not, but /dev is showing video0, video1, video24, video32. I would assume you need to make sure you are selecting the correct device.

cyrulution
Posts: 52
Joined: Sat Jul 28, 2007 12:27 pm
Location: Kinzweiler, Germany and Beith, Scotland
Contact:

Post by cyrulution » Sat Feb 14, 2009 9:32 pm

I think it's not the dvd, but an 1.24 issue. I configured the monitors exactly the same in ZM 1.24 and in ZM 1.23:
card A /dev/video0 (0) ... (3) and
card B /dev/video1 (0) ... (3)
The channels (0) are both working in 1.24 but not the channels (1) (2) and (3).
I configured the bttv settings in /etc/modprobe.d the same as well.
Last edited by cyrulution on Sat Feb 14, 2009 10:06 pm, edited 1 time in total.
Serenity is not freedom from storm; it's peace within the storm

newvisionantenna
Posts: 381
Joined: Sat Jan 17, 2009 7:49 pm
Location: Germany
Contact:

Post by newvisionantenna » Sat Feb 14, 2009 9:48 pm

Wow, just learned a ton more about capture cards in the last hour. Was trying to help someone with a pvr 150. I finally figured out his card is not using the bttv driver, instead the ivtv driver.

After looking at this post I figure I better put something in the FAQ about all the work going into setting up various capture cards.

http://www.zoneminder.com/forums/viewtopic.php?t=6963

c0mputerking
Posts: 190
Joined: Tue Sep 16, 2008 5:22 am
Contact:

Post by c0mputerking » Sun Feb 15, 2009 11:10 am

added the stuff to /etc/sysctr.conf that was mentioned but i am getting these shared memory errors did i miss something in the FAQ?

WAR [Shared data not initialised by capture daemon, some query functions may not be available or produce invalid results]
Feb 15 04:09:38 c0mputerking-desktop zms[12458]: WAR [Unable tostore frame as shared memory invalid]

newvisionantenna
Posts: 381
Joined: Sat Jan 17, 2009 7:49 pm
Location: Germany
Contact:

Post by newvisionantenna » Sun Feb 15, 2009 11:28 am

The options I set on my demo server allowed me to get greater then 320x240. Reading and looking at all the problems people have with getting Shared memory setup to suit there needs I really need to get a control panel to enter the entries on the fly. I had it setup but I want to get a better understanding of the formula that works it all out. I've also tried this new mmap option but so far the older approach seems to work better for me.

Just Pm me or post here exactly what your trying to setup and we can get this figured out. If it's some sort of IP camera we could also try it online with my server. I'm trying to build a list of devices that work out of the box with my DVD and also any details that enables off the wall devices.

In the meantime, this is for anyone, if you have success in using the DVD please just post back in some kind of logical format the version your using(free one or the donation one), your server specs and the type of equipment that worked for you. This will really help out others and also help me to add in all kinds of support.

c0mputerking
Posts: 190
Joined: Tue Sep 16, 2008 5:22 am
Contact:

Post by c0mputerking » Sun Feb 15, 2009 11:23 pm

Not sure what you mean about exactly what i am trying to setup just want to get 1.24.0 DVD to run my cameras I have a bunch most are from Curtis at bluecherry and work fine under 1.23.3. Also i am using the pv-149 120FPS also from bluecherry

here are a list of some cameras
airlink101 p/t ip based
kt&c something really expensive with a heater and external manual focus
but the one camera that is hooked to zm 1.24 and is not working is a cheap made in china jobby 1/4 sony 6mm lens that is all is states.

newvisionantenna
Posts: 381
Joined: Sat Jan 17, 2009 7:49 pm
Location: Germany
Contact:

Post by newvisionantenna » Mon Feb 16, 2009 12:10 pm

In a couple posts up you talked about shared memory and some error logs. I didn't know what type of equipment you were trying to install. I've been helping a couple people setup capture cards, one was a pinnacle and the other a generic bt878 type card. It's proving rather hard to get the second one setup, the first one was plug and play.

theone
Posts: 7
Joined: Fri Aug 01, 2008 11:58 am
Location: U.K.

dvd install

Post by theone » Mon Feb 16, 2009 6:12 pm

hi, just info really, installed on a 1.6GHz atom with 2 gig ram, runs well with no hiccups, easy to configure. the pci card is a bt878 and tomorrow i should recieve a VideoMate C200 Capture Stick (usb) wish me luck on that one !!
keep up the good work,,,,,
theone.

cyrulution
Posts: 52
Joined: Sat Jul 28, 2007 12:27 pm
Location: Kinzweiler, Germany and Beith, Scotland
Contact:

Re: dvd install

Post by cyrulution » Mon Feb 16, 2009 6:53 pm

theone wrote: tomorrow i should recieve a VideoMate C200 Capture Stick (usb) wish me luck on that one !!
I wish you a lot of luck. Please tell us if and how this stick works. I thought of ordering one before, but I did not dare ...
Serenity is not freedom from storm; it's peace within the storm

newvisionantenna
Posts: 381
Joined: Sat Jan 17, 2009 7:49 pm
Location: Germany
Contact:

Post by newvisionantenna » Tue Feb 17, 2009 2:23 pm

Too much free time today, built a live cd if anyone wants it. It's a completely stripped down xUbuntu 8.10 disk with the latest SVN version of Zoneminder and patches for ffmpeg. You should be able to change user name and password now for ACTI camera's according to the patch fix.

I don't plan on supporting this disk as it's "bleeding" edge, or at least I think that's what you guys call it.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests