problem initiating Zoneminder in OpenSuse

Support and queries relating to all previous versions of ZoneMinder
User avatar
nkw
Posts: 13
Joined: Fri Aug 03, 2007 7:25 am

Post by nkw » Sat Aug 04, 2007 11:08 pm

Hi.
My ide cable went down knocking out my controller.
Reinstalled the operating system just in case this was a cause of my faults.
The installation of zm went o.k. this time.
First command gives me various error codes, most of which result in;
[Shared memory not initialised by capture daemon]
Second command lists;
[error] [client 127.0.0.1] File does not exist: /srv/www/htdocs/favicon.ico
My search for these errors came to a dead end...

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Sun Aug 05, 2007 10:59 am

hi,

for your first problem you should have a look at the FAQs (What does a 'Can't shmget: Invalid argument' error in my logs mean?). i guess the max shared memory size is not big enough. you can try to increase it. edit your /etc/sysctl.conf file and add for example:

Code: Select all

kernel.shmall = 134217728
kernel.shmmax = 134217728
save changes and run "sysctl -p" and restart zoneminder ("rczm restart"). for more informations look at the FAQ section in the wiki.

the second one (error] [client 127.0.0.1] File does not exist: /srv/www/htdocs/favicon.ico) can be ignored. when you point your browser to the document root, the browser tries to load the favicon (its the small icon in the address bar beyond the url). in your case, no file reside in the document root.

hope this helps

User avatar
nkw
Posts: 13
Joined: Fri Aug 03, 2007 7:25 am

Post by nkw » Sun Aug 05, 2007 8:43 pm

Hi,
It would not let me change the max shared memory. However, I reduced the monitors to one, and whilst viewing I individually tried each camera connector.
The shared memory error has now gone.
There is now a new error:
ERR [Failed to get camera source: Invalid argument]...

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests