problem initiating Zoneminder in OpenSuse

Support and queries relating to all previous versions of ZoneMinder
User avatar
nkw
Posts: 13
Joined: Fri Aug 03, 2007 7:25 am

problem initiating Zoneminder in OpenSuse

Post by nkw » Fri Aug 03, 2007 8:13 am

Just installed Zoneminder (Opensuse 10.2), using Yast. The install completed successfully. I opened root consol and followed the instructions. When I type in zm_database_init, a message displays “no lockfile found”, then alerts me that daemon failed. This is my first time with Linux, so please be gentle…

User avatar
cordel
Posts: 5210
Joined: Fri Mar 05, 2004 4:47 pm
Location: /USA/Washington/Seattle
Contact:

Post by cordel » Fri Aug 03, 2007 8:21 am

You will have to contact the packager, since we do not package for suse, I have no way to know what they have done and we do not provide a database init program. I would suggest installing from source or if you can figure out what they have done from the code, try manually installing the database. They should have contact info somewhere in that package so that you can get help. I can't remember off the top off my head if it's anyone that frequents the forum.

User avatar
nkw
Posts: 13
Joined: Fri Aug 03, 2007 7:25 am

Post by nkw » Fri Aug 03, 2007 11:51 am

Hi, Thanks for your reply. Installing the database manually is too advanced for a first time user of Linux. Maybe there is a preferred OS, with garreneied results...

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Fri Aug 03, 2007 11:53 am

Hi,

it seems that you already run zm_databaes_init. maybe you did not answer all questions with "yes", so lets do it again :)

first thing you could do is run zm_database_init and when "no lockfile found, proceed anyway? [y/N]: " is display answer with "y". and then follow the instructions in the wiki.

when this not works, then try to run zmpkg start and post the output here.

hope this helps

User avatar
nkw
Posts: 13
Joined: Fri Aug 03, 2007 7:25 am

Post by nkw » Fri Aug 03, 2007 12:27 pm

Hi,

My apology, the message "no lockfile found" appears after I typed "rczm start", and not where I previously mentioned.
I answered all with "y". It still failed.
How do I run zmpkg? I typed this into the root console-nada! , bear in mind before yesterday I never used Linux.

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Fri Aug 03, 2007 12:44 pm

Hi,

:oops: the command is "zmpkg.pl start". this will start zoneminder without my start wrapper. this will give a more detailed error message.

User avatar
nkw
Posts: 13
Joined: Fri Aug 03, 2007 7:25 am

Post by nkw » Fri Aug 03, 2007 12:54 pm

Nothing happens...

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Fri Aug 03, 2007 1:13 pm

thats good. zoneminder is running now :)

then there might be a bug in my script ...

pls run zmpkg.pl stop an then:
"sh -x /etc/init.d/zm start" and post the output here. maybe then i can find the failure and solve it.

Have a lot of Fun

User avatar
nkw
Posts: 13
Joined: Fri Aug 03, 2007 7:25 am

Post by nkw » Fri Aug 03, 2007 1:18 pm

linux-rine:~ # zmpkg.pl start
linux-rine:~ # zmpkg.pl stop
linux-rine:~ # sh -x /etc/init.d/zm start
+ ZM_BIN=/usr/bin/zmpkg.pl
+ ZM_PATH=/srv/www/htdocs/zm
+ test -x /usr/bin/zmpkg.pl
+ . /etc/rc.status
++ LC_ALL=POSIX
++ export LC_ALL
++ test -z '' -o -z ''
+++ exec
+++ stty size
+++ read L C
+++ echo LINES=24 COLUMNS=80
++ eval LINES=24 COLUMNS=80
+++ LINES=24
+++ COLUMNS=80
++ test 24 -eq 0
++ test 80 -eq 0
++ export LINES COLUMNS
++ case ":$PATH:" in
++ test -t 1 -a xterm '!=' raw -a xterm '!=' dumb
++ stty size
+++ echo -en '\033'
++ esc=$'\E'
++ extd=''
++ warn=''
++ done=''
++ attn=''
+++ echo -en '\017'
++ norm=''
+++ echo -en '\015 '
++ stat=' '
++ rc_done=' done'
++ rc_running=' running'
++ rc_failed=' failed'
++ rc_missed=' missing'
++ rc_skipped=' skipped'
++ rc_dead=' dead'
++ rc_unused=' unused'
++ rc_unknown=' failed''
++ rc_reset=''p='
++ rc_save=''
++ rc_restor'='
++ _rc_service=/etc/init.d/zm
++ _rc_status=0
++ _rc_status_all=0
++ _rc_todo=start
++ test start = status
++ test -n start
+ rc_reset
+ _rc_status=0
+ _rc_status_all=0
+ rc_check
+ _rc_status_ret=0
+ test 0 -eq 0
+ test 0 -eq 0
+ return
+ return 0
+ case "$1" in
+ locked=0
+ test -f /srv/www/htdocs/zm/lock
+ echo -n 'Starting ZoneMinder Daemon '
Starting ZoneMinder Daemon + (( 0 != 1 ))
+ eval startproc -t 5 -f /usr/bin/zmpkg.pl start
+ rc_status -v
+ rc_check
+ _rc_status_ret=0
+ test 0 -eq 0
+ test 0 -eq 0
+ return
+ test 0 -gt 7
+ _rc_status_ret=0
+ case "$_rc_todo" in
+ local i
+ for i in '"$@"'
+ case "$i" in
+ local vrt=
+ local out=1
+ local opt=en
+ test -n ''
+ opt=e
+ case "$_rc_status" in
+ vrt=' done'
+ echo -e '' done
done
+ _rc_status=0
+ return 0
+ rc_exit
+ exit 0
linux-rine:~ #

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Fri Aug 03, 2007 1:43 pm

hmm, all seems to be fine :/

then run "rczm start" "rczm status" and post the outputs pls.

User avatar
nkw
Posts: 13
Joined: Fri Aug 03, 2007 7:25 am

Post by nkw » Fri Aug 03, 2007 1:47 pm

linux-rine:~ # rczm start
Starting ZoneMinder Daemon failed
linux-rine:~ # rczm status
Checking for service ZoneMinder running
linux-rine:~ #

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Fri Aug 03, 2007 2:08 pm

ok also seems to be fine.

i don't know were the problem was, but alls seems to function now.

the start fails because zoneminder is already running.

as a final test you can run "rczm stop" to stop zoneminder then "rczm status" (must now be unused) then "rczm start" and "rczm status" (now running).

when no problems occur then all is fine \o/

you can acces zoneminder via http://localhost/zm with a browser from the same pc or from a an other computer than localhost via http://<hostip>/zm. before you can acces zm from an other box than localhost you have to open the port 80 in the firewall settings. to do so go to yast -> users and security -> firewall. select allowed services and choose "http-server" and click add.

to start zoneminder on boot type "chkconfig zm on"

hope this helps.

User avatar
nkw
Posts: 13
Joined: Fri Aug 03, 2007 7:25 am

Post by nkw » Fri Aug 03, 2007 3:00 pm

Thanks for the help!
I guess when I tried to use the access link before, zm may not of been running.
Only problem know is the lack of active camera action.The montage link with which to view the cameras is missing. I know the camera and card is active as I rebooted my system into xp-pro and proved the camera is on and working.
Below is what I have displaying in my browser, after setting up 8 cameras which should cover all inputs into one of two connectors I have:

Fri 3rd Aug, 3:44pm ZoneMinder Console - Running - v1.22.3 Load: 1.97 / Disk: 49%
8 Monitors
Configured for low bandwidth
Options
Id Name Function Source Events Hour Day Week Month Archive Zones Order Mark
1. New None /dev/video (1) 0 0 0 0 0 0 1
2. New None /dev/video (2) 0 0 0 0 0 0 1
3. New None /dev/video (3) 0 0 0 0 0 0 1
4. New None /dev/video (4) 0 0 0 0 0 0 1
5. New None /dev/video (5) 0 0 0 0 0 0 1
6. New None /dev/video (6) 0 0 0 0 0 0 1
7. New None /dev/video (7) 0 0 0 0 0 0 1
8. New None /dev/video (8) 0 0 0 0 0 0 1

0 0 0 0 0 0 8

User avatar
nkw
Posts: 13
Joined: Fri Aug 03, 2007 7:25 am

Post by nkw » Fri Aug 03, 2007 5:14 pm

Ignore that last message as I found how access the montage.
However when I pull up the display there is no image within any of the windows.
Any suggestions...

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Fri Aug 03, 2007 7:03 pm

this could have many reasons.

you should check the system log files. first check /var/log/messages (use this command: "tail -f /var/log/messages" as root) there you might see some error messages which will help to analyse your problem. maybe you then can find a solution for your problem in the FAQ section. when you cannot find any errors in /var/log/messages you should look at the apache2 error logfile in /var/log/apache2/error_log.

hope this helps.

Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests