it driove me nuts - now I'm happy again

Support and queries relating to all previous versions of ZoneMinder
Post Reply
Posts: 9
Joined: Wed Mar 07, 2007 2:47 pm

it driove me nuts - now I'm happy again

Post by babba » Sun Jun 03, 2007 1:46 pm

Hello you Linux guru's out there - I need your help.

some months ago I installed zoneminder on Ubuntu 6.10 following the insructions on the ZM-Wiki.
Everything worked great and I started already to adjust the zones to get alarms when any cats (or other animals) got close to my Koi-Pond.

Well - I know: Never touch a running system - but I did it anyway and upgraded Ubuntu to 7.04 and Zoneminder stopped working. I played around for many weekends - but no success until now.

I removed the 'old' build from the system and deleted everything which smelled like ZM and tried my luck with the ZM deb package.

Already during installation I've got following error message

Starting ZoneMinder: sudo: /usr/local/bin/ command not found

After doing some investigation I found, that the installer put all the files into /usr/bin/ - no wonder that it caused problems. Also the zmpkg.log shows complaints about the missing file in /usr/local/bin/

I can open up the ZM-Console but Zoneminder status is 'Stopped' and there is no way to start it. Also the Source device /dev/video0 is shown in RED color.
I can watch the camera output via XawTV without any problem.

Has anyone a hint for a Linux-Beginner? It is so frustrating not making any progress :cry:


from Wiesbaden/Germany
Last edited by babba on Wed Jun 13, 2007 9:50 pm, edited 1 time in total.

User avatar
Posts: 5210
Joined: Fri Mar 05, 2004 4:47 pm
Location: /USA/Washington/Seattle

Post by cordel » Sun Jun 03, 2007 6:28 pm

Might check your bin path in your zm.conf and make sure it is /usr/bin and not /usr/local/bin.

Posts: 59
Joined: Wed Nov 22, 2006 11:26 am
Location: Bucks, UK

Post by jamescollings » Mon Jun 04, 2007 7:59 am

Also... what release of Zoneminder were you running before and are you running a different version now?

I migrated from a LiveCD running 1.22.2 to an Ubunto Fiesty running 1.22.3 (new hardware). It was late at night, and I thought I'd just restore my settings from a backup.... bad move! The 1.22.2 database must be significantly different from the 1.22.3 database (in terms of the device and zone settings).

I had to delete the MySQL database and re-create the zones and device settings manually.

Posts: 1
Joined: Mon Jun 04, 2007 10:12 am

Post by babba_new » Mon Jun 04, 2007 11:08 am

Sorry folks - I could not reply earlier - got yesterday banned from the forum - no idea why :roll:

@cordel - I checked this already yesterday and the bin path in my zm.conf is correctly set to /usr/bin

@jamescollings - my first installation on Ubuntu 6.10 was zoneminder 1.22.3 - following the instructions from the Wiki. Maybe I should have a look to the MySQL database?


Dieter form Wiesbaden/Germany

User avatar
Posts: 5210
Joined: Fri Mar 05, 2004 4:47 pm
Location: /USA/Washington/Seattle

Post by cordel » Mon Jun 04, 2007 7:12 pm

You have not been banned. Your message was caught in the spam trap. You should stick with your original user name. I'll get the messages approved/posted when this happens as I did with this last msg and the one you mentioned before it.

Check the PM in your original babba account.

Posts: 9
Joined: Wed Mar 07, 2007 2:47 pm

Post by babba » Wed Jun 13, 2007 9:21 pm

Hello community - I am back.
To be honest - I actually gave up and decided to do a full re-installation of Ubuntu 7.04 on my experimental Linux system and after completion I followed the instruction from the wiki to install the ZM 1.22.3 package.

And guess what: IT WORKED !!!!

After establishing the 2 critical zones along my small pond using one of the pre settings, I noticed too many false alarms due to large area light changes on my patio (even under the marquee) caused by clauds. So I started to experiment with one preclusive zone - just a small rectangluar bar covering about 2 meters of uncritical area. This really brought the breakthrough and the false alarms went almost to zero.

Meanwhile I already captured a cat at 4:00am (just) watching my koi's.

Now a question to the ZM-Guru's here: What would be the easiest way to enable/disable ZM by another System - I am running an home automation system (IP-Symcon) on a Windows OS and this system is aware when the patio door is opened and people are moving around. Such events should not be detected and I am wondering how to achieve this. Would it be possible to send control strings like ... &disable=1
from another application on the same LAN? If the answer is YES - how do I figure out the commands and how can I check the current status?

Any hint how to control ZM from other systems on the net is very much appreciated.

If aove problem is solved - the next step is to activate a water gun whenever a cat (or whatever) is entering the given zones.

Regards babba

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests