Upgraded to Debian 4.0/Etch - ZM not working.

Support and queries relating to all previous versions of ZoneMinder
Post Reply
sgn
Posts: 68
Joined: Mon Oct 25, 2004 2:36 pm

Upgraded to Debian 4.0/Etch - ZM not working.

Post by sgn » Fri Apr 27, 2007 11:19 am

I upgraded to Debian 4.0 yesterday, after which I have unable to log in to the ZoneMinder console. Was working smoothly on Sarge, but now whenever I try to log in, I'm just returned to the login screen as if my details were wrong.

I set "debug=true" in index.php, to try and found a reason, and I'm getting the following error:

Code: Select all

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /var/www/zm.php:28) in /var/www/zm.php on line 15
Sure, I've upgraded to php5 as part of the upgrade, but why doesn't it work? Same scripts were working before, even tried to recompile ZM.

HD space is beeing used like before, so I guess the box IS recording, but I'm unable to view the data :).
Last edited by sgn on Fri Apr 27, 2007 6:50 pm, edited 2 times in total.

majik-br
Posts: 17
Joined: Mon Sep 19, 2005 12:46 pm
Location: Sao Paulo, Brazil

Post by majik-br » Fri Apr 27, 2007 5:45 pm

same thing here ...

My ZM 1.22.3 system was installed & working with auth=on ... when upgraded to Debian 4.0, it started correctly but when I try to login, it displays the same login page (as if I had input wrong user/pass).

Temporary workaround is to disable authentication (go to config database on MySQL - either by hand or through phpMyAdmin) and set auth to 0.

this way I found out everything is indeed working, only authentication isn't.

hope somebody has the time & knowledge to figure out what's going on! :wink:

ps: tried to compile it again from scratch, compiled ok (no errors), but no change - auth still doesn't work

sgn
Posts: 68
Joined: Mon Oct 25, 2004 2:36 pm

Post by sgn » Fri Apr 27, 2007 6:48 pm

Confirmed. Even tried completely reinstalling the entire sheit... I'm sure the team will find out why, though...

Works like it is right now, but I don't like everyone being able to view/change configs...

majik-br
Posts: 17
Joined: Mon Sep 19, 2005 12:46 pm
Location: Sao Paulo, Brazil

Post by majik-br » Fri Apr 27, 2007 10:29 pm

Still not a fix, but a more secure workaround is to password protect the /var/www/zm folder using htaccess (enable it on /etc/apache/httpd.conf, then use htpasswd to generate the pass).

sgn
Posts: 68
Joined: Mon Oct 25, 2004 2:36 pm

Post by sgn » Sun Apr 29, 2007 10:24 pm

Well, yeah, thats the first thing I did. Problem is, I don't want certain users to be able to access settings and/or edit events...

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Mon Apr 30, 2007 10:29 am

majik-br wrote:same thing here ...

My ZM 1.22.3 system was installed & working with auth=on ... when upgraded to Debian 4.0, it started correctly but when I try to login, it displays the same login page (as if I had input wrong user/pass).

Temporary workaround is to disable authentication (go to config database on MySQL - either by hand or through phpMyAdmin) and set auth to 0.

this way I found out everything is indeed working, only authentication isn't.

hope somebody has the time & knowledge to figure out what's going on! :wink:

ps: tried to compile it again from scratch, compiled ok (no errors), but no change - auth still doesn't work
hi

you can try to set a new admin password via phpmyadmin:
select zm database and user table.
select the line with the username admin and choose edit.
enter a new password and choose "PASSWORD" as function.


the password function of mysql has changed in the past maybe thats the problem here.

hope this helps

Monex

majik-br
Posts: 17
Joined: Mon Sep 19, 2005 12:46 pm
Location: Sao Paulo, Brazil

Post by majik-br » Wed May 02, 2007 11:42 am

monex wrote: hi

you can try to set a new admin password via phpmyadmin:
select zm database and user table.
select the line with the username admin and choose edit.
enter a new password and choose "PASSWORD" as function.


the password function of mysql has changed in the past maybe thats the problem here.

hope this helps
Monex
yeah - you were right! this solved my problem ...

thanks!

sgn
Posts: 68
Joined: Mon Oct 25, 2004 2:36 pm

Post by sgn » Mon May 07, 2007 7:36 pm

Worked for me too, but the hash has more characters, which "algo" is used by the "Password" function?

Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests