Page 1 of 3

connecting to console remotely from internet...

Posted: Wed Feb 21, 2007 9:23 pm
by Solaris
Hi all,
After much reading, numerous experimentation, and long hours - I have my livecd 1.22.2 installed on hd and a bluecherry card running great on a 60 watt 12 volt duron mod in an old packbell case. I can access console from within network,{} everything seems to be fine, but my friend cant get login over internet. My question isnt in any of the posts that I could find, and so I'm gonna take a shot at maybe somebody helping me, thats smarter than I am... My question is basically - Can I access zm console with correct IP from within the network? Or is access from within network only possible with local address? I found I had to enable remote cams in - ZM_OPT_REMOTE_CAMERAS to see cams from other computer - but it stops there and my friend cant get anything. Is it possible I have to open a port? even opening port 80 tcp did not work. I'm sure its an easy fix, but its beyond my limited linux capability.

update:well it seems it can connect to console if i first connect locally?

Thanks agin for a wonderful program, and all the helpful posts that got me this far...Solaris

Posted: Thu Feb 22, 2007 10:26 am
by cordel
If you dont have a public IP on that machine (ie using nat from a router in front of the machine) you need to forward the proper port (80).

port 443

Posted: Thu Feb 22, 2007 3:26 pm
by Barbado
I knew about port 80 (http) but what about Apache's requirement for port 443?


so it is port 80 to forward...

Posted: Thu Feb 22, 2007 7:44 pm
by Solaris
OK, so if I open port 80 for the computer running zoneminder, {}then when my friend goes to he should get the console? or is the correct address going to be

I also went to james site and there isnt a clickable link for zm4ms... which I was hoping would be a better altenative to that nasty new IE7, that my friend could use.

thanks again for all your help, and for all the great work everyone is doing on this wonderful application

PS port 443? huh? wheres that from? and where is this in the manual?

Posted: Fri Feb 23, 2007 1:36 pm
by monex

port 443 is https (TLS/SSL).

you can use apache with ssl for a secure connection to zoneminder webinterface.

Have a lot of fun


Posted: Fri Feb 23, 2007 8:14 pm
by cordel
Port 80 is what the browsers use by defualt so there is no need to use
  • http://<your publicIP>:80/zm
    http://<yourPublicIP>/zm does the same thing.
You forward port 80 fromwhat ever device has your public IP to the IP of your ZM machine. There is nothing to be done in ZM, or apache to make this work. The only other thing is if you have a firewall on in the zm box you would need to open port 80:tcp and if you want SSL 443:tcp.

So port 80 DOES need to be forwarded to access from internet

Posted: Fri Feb 23, 2007 9:05 pm
by Solaris
Ok -
So I think I get it - port 80 has to be opened/forwarded in my router setup to access the console remotely and the reason it works on local network is because it's on this side of my router....

If port 80 is NOT opened/forwarded with address of zm machine I will only get local access, and not be able to connect remotely from the internet in a different location.

Please correct me if I am wrong...

Thanks again to all those who have helped, this is an awesome application with unlimited possibilities - :D

Posted: Sat Feb 24, 2007 2:00 am
by cordel
You got it 8)

still no remote connection...

Posted: Mon Feb 26, 2007 3:22 am
by Solaris
Well hello again,
I still have no remote login, even tho the console and all functions work fine so far from local network. I forwarded port 80/tcp and even 443/tcp in my router setup, -I even went as far as dmz'ing my local zm box and still no remote login!

I can easily and quickly access my cams from the local network, but after trial and error and some phone time with friends - NO CONNECTION outside the network. I wouldn't think that being a Zoneminder LiveCD hard drive install, that a firewall would be on by default. If it were I wouldn't think I could access login from other machine on same network would I?

Everything seems to work great otherwise, and modect captures well too.
It will also email me video of motion detected but no matter what I do , I can't seem to connect remotely to the console login. I even changed to un-authenticated mode but it made no difference.

I would really like to get this going remotely. I now have 3 people wanting installations. 2 at businesses and 1 at my folks house. Their neighborhood seems to be under seige lately by vandals. The folks and the neighbors have had some bad stuff happen that worries everybody.

I have 1.22.2 livecd installed on a 10.2 gb drive, 1gb RAM, 950 mhz AMD Duron running on an M2 auto power supply - {30-75 watts} my house is solar/wind with 12 volt battery and AC inverter, etc.

I'm starting to run out of ideas and I'm open to any suggestions that may work - Thanks again, Solaris

static ip

Posted: Mon Feb 26, 2007 10:57 am
by Barbado
is your ZM server configured with a static ip address?
if not, it should be.


Posted: Mon Feb 26, 2007 7:36 pm
by Solaris
Barbado, did you mean at setup its configured for static?
Or did you mean that my external IP needs to be static - as it is thru my internet router? I can forward ports for internet gaming, I know how to set that up in my router, and a few years back my ISP setup my address to be the same at all times just so I could host gaming from here, and tell my friends which IP to connect

I have the "zm box" running on default setup - I tried the static setup after rebooting and I cant even connect from xp machine sitting next to it thru the local network that I was able to connect with before using ""default".

I'm not sure where to go from here, I'd give out my IP address for others to test it- but I do not feel comfortable doing that as there are too many risks involved in posting it to everyone on the net...

Once again - my zm box is thru my local NR401 network everywhere router, I forward port 80 tcp to {zm box} and my external IP is - It should work!

I'd be willing to bet it's a simple fix - but it is obviously over my head...

Thanks again for everyones help - sure would like to figure this out...Solaris

Posted: Mon Feb 26, 2007 8:10 pm
by Barbado
I mean every time your zm box goes up, it must work with exactly the same number.

you know you can only forward a defined port (say port TCP 80) to one machine at a time. Check which ports you are forwarding for games.

by the way, did you restarted your router after those changes?


Posted: Tue Feb 27, 2007 4:01 am
by Solaris
Barbado - yes I know about the dedicated IP for the zm box, since I set it up it will only work with the original local IP, even when I moved it to another switch in a different room.

Forwarding ports for [games] sometimes involves up to 6 seperate ports {and entries} in the router setup.

The router setup has an APPLY button , that after clicked on says succesful or not and I have never had to "restart" my router before for them to be working ok...

I can even use DMZ which places my zm box "outside" of my router and that didnt help either... which is really strange....

Danged if I can figure this out - Like I said before -it is most likely a simple setting or maybe it will NEVER work remotely on this machine...

Thanks again for your help and everyone elses- Solaris {pulling out what little hair is left, hehe}

I am still open to suggestions...

Posted: Thu Mar 01, 2007 7:53 am
by Solaris
Hi all,
Well I see the new LiveCD 1.22.3 is out - so I am downloading that and plan to redo my install and see if that helps my remote connection to console issue.

I am still open to any suggestions and/or ideas regarding this problem.

Maybe I will get lucky and it will work with the updated version...

Many thanks to the original creator of ZM, rdmelin for his LiveCD work and also others for their efforts with this great software.

--> the original "garage tool burgler" has no idea what he started...

Kudos to all the linux gurus out there keeping Zm ever-evolving... Solaris

Installed 1.22.3 from LiveCD - still no luck...

Posted: Sun Mar 04, 2007 4:11 am
by Solaris
Hi again,
Well the new version 1.22.3 is nice - it has some new features and seems to work great except, -->still no remote connection to console!

I have had 5 seperate ppl with 5 different kinds of connections in 4 different states attempt to get the login window, and nothing has worked.

I do not understand what I am doing wrong - I have read the manual several times to see what I am missing and cannot find anything that would cause this. I am not the smartest when it comes to linux and all I can figure is that I am just not going to be able to get this to work.

Perhaps my install is screwy - or the machine is screwy and it just will not work with my setup, as it is. I can try another machine and see if it works from that one, but I doubt there will be any difference.

I do not know if there would be any mention of this in the logs - as I do not understand how to access them anyways.

I do see that a few hundred ppl have looked at this and I am suprised nobody has any ideas... obviously it works fine for everybody else who can access it remotely.

Its been fun trying to get it to work - but I have run out of steam and will probably just end up using it locally without remote access or not at all.

Thanks again, good luck to everyone else... Solaris