New to linux and Zoneminder

Support and queries relating to all previous versions of ZoneMinder
Post Reply
Posts: 2
Joined: Thu Apr 20, 2006 12:38 am

New to linux and Zoneminder

Post by outrun » Thu Apr 20, 2006 12:52 am

Being new to Linux I'm likely treading on thin ice on this but how would I go about setting up this program? I've installed Fedora Core 3 and tried the RPM files and tried just installing the program by reading the help file but I think I'm missing the boat.

I installed what I think are all the dependancies for the RPMs (basically, I installed whatever each RPM required) but I can't figure out what to do next. I don't even have a clue where the files are located. I've found nothing to tell me where they are.

After that trial, I downloaded the 1.22 install and tried step by step from the instructions but after the .configure step...make does nothing. I also tried this on a Core 4 passed the make but at themysql step all I get is an error.

Being a devoted windows user I guess I'm too used to dling a setup file and having the program work. Not since DOS have I had to do so much no end. Linux will never be as popular as windows if this is the case(senses flame war) :)

Anyone wanna help with a real step by step manual on this program? OS install to a running program... From what I've seen it looks good and feature-packed. I'd like to try it out.

User avatar
Posts: 5210
Joined: Fri Mar 05, 2004 4:47 pm
Location: /USA/Washington/Seattle

Post by cordel » Thu Apr 20, 2006 3:56 am

For the most part, everything is laid out in the readme. You just have to make sure that you have the compiler and several dependancies installed.
The Dependencies are listed under the Hint & Tips topic.

The easy way would be to DL either the LiveCD by Ross, or I have a FC3 installer cd up on the torrent. See the downloads section.

The next method would be to setup my yum repo on a FC3 machine. Once the repo is setup all you have to do is have an internet connection and from the console type yum install zm and it should take care of all your packages. You will find most info under the Contribs topic and some scatered though out the forums.


Posts: 2
Joined: Thu Apr 20, 2006 12:38 am

Post by outrun » Thu Apr 20, 2006 11:37 am

Thanks for the reply.

I fully expected a link to a Linux for Dummies book. Hmm might help.

I'll try those suggestions. Thanks

Posts: 5111
Joined: Wed Jun 08, 2005 8:07 pm
Location: Midlands UK

Post by jameswilson » Thu Apr 20, 2006 12:29 pm

I personally would download the live cd as you just put it in your machine. And then install it to the harddrive. I would also build or use a sepeate machine dont mess with you main machine as you will need this if you have any issues with the live cd!


PS the live cd has step by step instructions that come up when it boots
James Wilson

Disclaimer: The above is pure theory and may work on a good day with the wind behind it. etc etc.

Posts: 3
Joined: Sun Apr 23, 2006 10:36 am
Location: UK

Post by BillyHunt » Sun Apr 23, 2006 10:46 am

You got further than me :D
I keep lurking round here wanting to give it a go as it looks great but think I'll be totally out of my depth.
I've tried out a few Linux distros for desktop use, so I've got an idea what I'd be letting myself in for :?
I'm going to purchase a small HD so as not to totally screw up my current set up and give it a go.
Some time!
I'd be interested in how you get on keep us informed

Posts: 255
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Post by mrd » Wed Apr 26, 2006 1:10 am

Sounds like I'm in the same boat as you guys. I'm pretty experienced in UNIX, but I've nearly killed myself trying to get Motion to work and just recently stumbled upon ZoneMinder. I'm excited to give it a try and may contribute some day but I need a few basic questions answered first.

1. Do I need to install video4linux on a new CORE 3 or 4 system first or is it in the distro already?

2. Do I need to install the drivers for my Osprey 210 capture card or will V4L/ZoneMinder take care of it? I had them installed on a CORE 3 at one point but the make file had many errors on a CORE 4 system.

3. Do I need to install ffmpeg separately?

4. will the YUM install or the RPM install take care of all of this?

Thanks for any info,

Posts: 5
Joined: Sun Jan 22, 2006 4:39 pm

Post by sawireless2000 » Wed Apr 26, 2006 7:23 am

Here is my attempt at drafting a wiki. Your install question should
be answered by it.

==Zoneminder build notes==

*Install ffmpeg and ffmpeg-devel.
./configure --with-mysql=/usr/local/mysql
--with-lame=/home/src/lame-3.96.1/libmp3lame --with-webdir=/home/sites/
--with-libarch=lib --enable-debug=yes
$ ./configure --with-webdir=/var/www/htdocs/ZM
--with-cgidir=/var/www/cgi-bin --sysconfdir=/etc
What is "--sysconfdir=/etc" directory ?
./configure --with-webdir=/var/www/html/zm
--with-cgidir=/var/www/cgi-bin ZM_DB_PASS=<password>

With a new install create and populate mysql databases.
mysql mysql < db/zm_create.sql
mysql mysql
grant select,insert,update,delete on <database name>.* to
'<database user>'@localhost identified by '<database password>';
mysqladmin reload
Check zone.conf or zm.conf. Check that there are no bogus vesions of this file lying around. "nobody" doesn't have shell access, choose a different Apache alias like "httpd". The zmdc.log logs any errors.

*Building for Suse10 ... light=suse

*Fedora4 notes
Set web user and group correctly and set the log dir to a writeable location.
With FC4 there are two things that must be done to get ZM running,
1) is in the /etc/ dir created a file with 775 perm called zm.conf and add the line '/usr/local/lib' to it and
type 'ldconfig' once it is added, also with a fresh install of FC4 make sure SE linux is disabled if you are not using it. Check your log path in options under the paths tab. This will tell you were the log are going to be put. Second make sure the path exists. Third create the log files if they do not exist and make sure that they have the correct permissions. If zm can
not open and write the log files, it will not start.

*OpenSSl and openssl-devel
You should have these packages installed: openssl,openssl-devel,php-mysql
To check if you have them, do rpm -qa | grep openssl

==Apache ==
*permission problem
sudo -u apache /etc/rc.d/rc.zoneminder start
now.. zmc and zma is running on user apache

*su issue

*http webserver must allows cgi execution

==BIOS issues==
Turn off ACPI in the bios. ACPI is a power management configuration
on the motherboard that interferes with the datacapture cards.

==Brightness control==
Brightness control script ... brightness

==contribs directory==
contribs directory has user based files added to zoneminder


==CAPTURE card issues==
Single chip with 4cameras can lead to image flipping.
LInux commands lspci ,dmesg
BT878 card with 1 cip/4 ins - Provideo PV143

==Database Mysql==
Create a new database.
database repair ... base+mysql
Mysql corrupted via bad BIOS. I pulled the battery for 5 minutes and slapped it back in. I booted, then started zoneminder. It didn't lock up! I went into the interface and found several lines of 'incorrect key file for table: 'E'Try to repair it' before the regular interface began. I stopped zoneminder and went into mysql - sure enough, the events and frames tables both had errors. I repaired them and restarted zoneminder successfully. The system is now running; I'm going to let it be and see if it dies as it did before.

*My personal recommendation is to try converting your database over to INNODB tables. Researching the web I found this to be faster for larger tables (as events grow) and much more reliable.

==Gentoo== ... ght=gentoo ... ght=gentoo ... ntoo+start

*Install ffmpeg for Fedora with
yum -i ffmpeg
yum -i ffmpeg-devel

*Install ffmpeg and ffmpeg-devel on Fedore4 ... 4036727f7b
rpm -ivh
yum install ffmpeg ffmpeg-devel
Place the devel stuff in /usr/include/ffmpeg
Now configure, make, make install ... 4036727f7b
*After getting ffmpeg from CVS, do:
./configure , make, make install, make installlibs

==Firefox, colorzilla extensions==

==Kodicom capture card== ... t=kmc4400r
*KMC-8800 8-chip bt878 capture card

*modprobe.conf file ... c&start=15
Edit your /etc/modprobe.conf file and add this line: options bttv card=77
"options bttv card =77" is a DEFAULT setting to get a card working.
All screens must be same resolution.

*bttv settings ... 4036727f7b

*I'm using FC4 and had a similiar problem with a quickcam 4000.
I guess you are using the default module supplied with centos. I think, not sure about this though, that it is missing some
capabilities. So I installed the pwc module ( and these crashes stopped.

==Zoneminder perl package

==Message logs==

*Shared memory setting must be high.

frank@wdshss:/etc> cat sysctl.conf
# Disable response to broadcasts.
# You don't want yourself becoming a Smurf amplifier.
net.ipv4.icmp_echo_ignore_broadcasts = 1
# enable route verification on all interfaces
net.ipv4.conf.all.rp_filter = 1
# enable ipV6 forwarding
#net.ipv6.conf.all.forwarding = 1
kernel.shmall = 134217728
kernel.shmmax = 134217728

==Mocord, Record, Modect==

mod = 133 or something like that for Kodicom

==Manual== ... c125113490

==MMS gateway and API software==


==Remote camera source== ... 4036727f7b

==Streaming ==
*rtp and raw streaming

"disable farm out wrtiting of imagess" if frame capture errors appear in log.

==Timelapsed video==

==Truck detection links== ... tersection

*All things are possible and the example someone posted a while back of detecting trucks and buses, but not cars, passing over a distant intersection is probably appropriate for you. What I would suggest you need are quite high pixel differences (indicating difference from the background) and pretty small counts of changed pixels or blob sizes. You might find it useful to turn on diagnostic images initially (and only for a while as they slow everything down a lot) which will output what ZM
thinks the differences etc are are in the images.

==Update database after installing from RPM's==
The command you enetered above only freshens it. --version= <?>

==Ubuntu install==
GUI package that installs Mplayer etc.

==Water marked== ... =watermark ... =watermark

==xawtv ==
what from xawtv -hwscan?
xawtv -device /dev/video? :lol:

User avatar
Site Admin
Posts: 5220
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK

Post by zoneminder » Wed Apr 26, 2006 11:03 am

Wow, impressive! If it's ok with you I will post that somewhere more prominent :D

Posts: 5
Joined: Sun Jan 22, 2006 4:39 pm

Post by sawireless2000 » Wed Apr 26, 2006 5:44 pm

Phil it would be great if you could setup a wiki. I had to troll a whole week through all the posts to get some sort of grip on installing Zoneminder. I think that for example the install instructions on ffmpeg has now been asked more then 20 times.

User avatar
Site Admin
Posts: 5220
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK

Post by zoneminder » Thu Apr 27, 2006 9:01 am

Being a bit of an old fart Wikis have sort of passed me by. If anyone would like to post where to fidn the phpbb equivalent for Wikis I will put one up.

Posts: 255
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Post by mrd » Sat Apr 29, 2006 2:30 am

Ok... I know I'm killing you guys, but the instructions look like they might actually help me. I just need to know what to do with all of the "OR" options? I don't know how to decided which one to do?


Posts: 64
Joined: Wed Mar 29, 2006 5:12 am

Post by MILxDOT » Sat Apr 29, 2006 4:05 am

I spent some time documenting a detailed installation on CentOS 4.3 x86_64 which is basically RedHat Enterprise Linux. Take at look at it in the Hints section of the Forum. I wrote the howto so that my boss could do a new install if need be. Should get you what you need.

Posts: 255
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Post by mrd » Sat Apr 29, 2006 10:54 pm

I'll have a look...


Post Reply

Who is online

Users browsing this forum: No registered users and 22 guests