SUSE 10 - Starting ZM with init script prob

Support and queries relating to all previous versions of ZoneMinder
mickecarlsson
Posts: 8
Joined: Sat Feb 25, 2006 7:14 pm

Post by mickecarlsson » Tue Apr 04, 2006 6:20 pm

Hmm... something is not right here,

Look in /etc/init.d/rc3.d and rc5.d for Sxxzm where xx is a number.
If it is not the last number do a mv Sxxzm S99zm
And then restart your computer.

Note that if you run SuSEConfig it will revert back the setting. You can add:
# Required-Start: apache2 mysql
to the /etc/init.d/zm script in the beginning to tell SuSEConfig that mysql and apache should be started before zm.

You can also edit the mysql start script and add zm to the Required-Stop: line.

It seems that something is not started before zm and by moving it to the last startup item will hopefully cure it.

Mikael

User avatar
cordel
Posts: 5210
Joined: Fri Mar 05, 2004 4:47 pm
Location: /USA/Washington/Seattle
Contact:

Post by cordel » Thu Apr 06, 2006 7:32 pm

It might be easiest to go through all your logs and see if something sticks out. Look into these logs:
zmdc.log
zmpkg.log
messages or syslog (distro dependant)
dmesg

I think there might be another zm*.log you should look at but I forget which one. ZM Is fairly good at letting you know what the problem is the exception is 1.22.0 has a few things that don't report spacifics in dealing with the pid file and if the directory for the zm.sock file don't exist, but neither of those are your problem. It's just a matter of finding the corrisponding log for your issue.

Regards,
Corey

Ana
Posts: 9
Joined: Thu Mar 30, 2006 5:52 pm

Post by Ana » Fri Apr 07, 2006 6:20 am

Woohoo! Yippee! ZM is running at startup. :D

My problem was looking more and more like an intractable user error, so I reinstalled SUSE and ZM. Problem solved. Card was detected and configured during OS installation. Selected Card Type > Other Vendors > "Kodicom 4400R (master)" or "Kodicom 4400R (slave)" for corresponding chip and gbuffers increased to 16 under Expert Settings.

After the reinstall, I discovered the likely source of the problem. My better half originally installed and setup the card ... and I would never want to say anything disparaging about him because he is, after all, my better half, but I think he may have introduced an error when modifying modprobe.conf.local and adding:
alias char-major-81 bttv
options bttv gbuffers=16 card=133,132,133,133 tuner=4,4,4,4

I think the problem is in the line:
alias char-major-81 bttv

When I check modprobe.conf, it lists:
alias char-major-81 videodev

I didn't catch it until I was sifting through the backup files, retracing our steps.

Thanks for all your assistance. I'm learning a lot through this process.

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests