Blue video feeds with timestamp. (fixed)

Support and queries relating to all previous versions of ZoneMinder
Post Reply
sde
Posts: 12
Joined: Fri Jan 27, 2006 9:48 am

Blue video feeds with timestamp. (fixed)

Post by sde » Sat Jan 28, 2006 5:25 am

I feel I am so close, but this is rough. It seems as if my card is just outputting blue. I know 100% for sure the camera works because I hooked it up to the TV.

I'm on FC4, I don' t and I'm using a 4 port card. /dev/video0 (0-3). I only have channel 0 enabled, but I've tested all channels and all video inputs with the same results.

Video Blue with a timestamp in the upper left. This is with JPG or an mpeg stream.

I've checked the logs and nothing looks irregular since before the last successful install. var/log/messages seems fine too.

Monitor settings are:
**********************
/dev/video0
0
1
rgb24
320
240
Normal
**************************

Both monitor and source on the main page are orange, so at least this seems ok.

i turned debug on, but all the logs are jsut like this:

Code: Select all

01/27/06 21:01:53.637710 zmu[4716].INF-zm_debug.c/304 [New Debug Level = 0, New Debug Log = /tmp/zm_debug.log.04716]
here is the card on my scanpci -v

Code: Select all

pci bus 0x0002 cardnum 0x0a function 0x00: vendor 0x109e device 0x036e
 Brooktree Corporation Bt878 Video Capture
 CardVendor 0x03ff card 0x0102 (Card unknown)
  STATUS    0x0290  COMMAND 0x0106
  CLASS     0x04 0x00 0x00  REVISION 0x11
  BIST      0x00  HEADER 0x80  LATENCY 0x20  CACHE 0x00
  BASE0     0xf47fe008  addr 0xf47fe000  MEM PREFETCHABLE
  MAX_LAT   0x28  MIN_GNT 0x10  INT_PIN 0x01  INT_LINE 0x0b
here is a zmu output.

Code: Select all

# /usr/local/bin/zmu -d /dev/video0 -q -v
Video Capabilities
  Name: BT878 video ( *** UNKNOWN/GENER
  Type: 171
    Can capture
    Can tune
    Overlay onto frame buffer
    Can clip
    Scalable
  Video Channels: 4
  Audio Channels: 1
  Maximum Width: 768
  Maximum Height: 480
  Minimum Width: 48
  Minimum Height: 32
Window Attributes
  X Offset: 0
  Y Offset: 0
  Width: 320
  Height: 240
Picture Attributes
  Palette: 4 - 24bit RGB
  Colour Depth: 24
  Brightness: 32768
  Hue: 32768
  Colour :32768
  Contrast: 32768
  Whiteness: 0
Channel 0 Attributes
  Name: Television
  Channel: 0
  Flags: 3
    Channel has a tuner
    Channel has audio
  Type: 1 - TV
  Format: 1 - NTSC
Channel 1 Attributes
  Name: Composite1
  Channel: 1
  Flags: 2
    Channel has audio
  Type: 2 - Camera
  Format: 1 - NTSC
Channel 2 Attributes
  Name: S-Video
  Channel: 2
  Flags: 2
    Channel has audio
  Type: 2 - Camera
  Format: 1 - NTSC
Channel 3 Attributes
  Name: Composite3
  Channel: 3
  Flags: 2
    Channel has audio
  Type: 2 - Camera
  Format: 1 - NTSC
any ideas where i can look next?
Last edited by sde on Sun Jan 29, 2006 8:18 am, edited 1 time in total.

User avatar
cordel
Posts: 5210
Joined: Fri Mar 05, 2004 4:47 pm
Location: /USA/Washington/Seattle
Contact:

Re: Blue video feeds with timestamp.

Post by cordel » Sat Jan 28, 2006 7:30 am

sde wrote: here is the card on my scanpci -v

Code: Select all

pci bus 0x0002 cardnum 0x0a function 0x00: vendor 0x109e device 0x036e
 Brooktree Corporation Bt878 Video Capture
[color=red] CardVendor 0x03ff card 0x0102 (Card unknown)[/color]
  STATUS    0x0290  COMMAND 0x0106
  CLASS     0x04 0x00 0x00  REVISION 0x11
  BIST      0x00  HEADER 0x80  LATENCY 0x20  CACHE 0x00
  BASE0     0xf47fe008  addr 0xf47fe000  MEM PREFETCHABLE
  MAX_LAT   0x28  MIN_GNT 0x10  INT_PIN 0x01  INT_LINE 0x0b
Did you insmod the card (did you add anything to modprobe.conf)?
What drivers did the kernel load (take snip from dmesg)?
What card do you have?

Regards,
Corey

sde
Posts: 12
Joined: Fri Jan 27, 2006 9:48 am

Re: Blue video feeds with timestamp.

Post by sde » Sat Jan 28, 2006 9:00 am

i did not use insmod. my linux/hardware knowledge is weak to say the least. i did see posts about modifying modprobe.conf and i did add card=77.

dmesg contains these lines if this is what you're looking for:

Code: Select all

bttv0: using: GrandTec Multi Capture Card (Bt878) [card=77,insmod option]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
bttv0: using tuner=-1
is there a way to refresh changes you have made in modprobe.conf? i just know to do it by restarting the box.

the card is: grandtec xguard 4 port

User avatar
cordel
Posts: 5210
Joined: Fri Mar 05, 2004 4:47 pm
Location: /USA/Washington/Seattle
Contact:

Post by cordel » Sat Jan 28, 2006 9:35 am

Adding a card type in modprobe is a insmod.
77 my not be the correct card. By the way that was exactly what I was looking for :wink:
Try removing the insmod and reboot. The newer kernels should autodetect that card.
If that does not work try card=103
I got the card number from list /usr/share/doc/kernel-doc-2.6.12/Documentation/video4linux/CARDLIST.bttv

Regards,
Corey

sde
Posts: 12
Joined: Fri Jan 27, 2006 9:48 am

Post by sde » Sat Jan 28, 2006 9:50 am

by default, the OS added this to modprobe.conf:

Code: Select all

alias char-major-81 bttv
demsg related lines:

Code: Select all

Linux video capture interface: v1.00
bttv: driver version 0.9.16 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
ACPI: PCI Interrupt Link [LNKG] enabled at IRQ 11
ACPI: PCI Interrupt 0000:02:0a.0[A] -> Link [LNKG] -> GSI 11 (level, low) -> IRQ 11
bttv0: Bt878 (rev 17) at 0000:02:0a.0, irq: 11, latency: 32, mmio: 0xf47fe000
bttv0: subsystem: 03ff:0102 (UNKNOWN)
please mail id, board name and the correct card= insmod option to kraxel()bytesex()org
bttv0: using:  *** UNKNOWN/GENERIC ***  [card=0,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
bttv0: using tuner=-1
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: i2c: checking for TDA9887 @ 0x86... not found
bttv0: registered device video0
bttv0: registered device vbi0
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
i'm gonna add 103 now and reboot to try again.

sde
Posts: 12
Joined: Fri Jan 27, 2006 9:48 am

Post by sde » Sat Jan 28, 2006 9:58 am

you, sir, are awsome! i thank you very much. :)

2am here, i can finally get some rest.

User avatar
cordel
Posts: 5210
Joined: Fri Mar 05, 2004 4:47 pm
Location: /USA/Washington/Seattle
Contact:

Post by cordel » Sat Jan 28, 2006 10:04 am

sde wrote:by default, the OS added this to modprobe.conf:

Code: Select all

alias char-major-81 bttv
That should be the only line in your modprobe.conf for your bttv unless you have to force the card type.
options bttv card=103 tuner=4
should only be there if it don't detect the correct card type on it's own. You should remove the options bttv line all together leaving alias char-major-81 then if that don't work, then do

Code: Select all

alias char-major-81
options bttv card=103 tuner=4
Regards,
Corey

sde
Posts: 12
Joined: Fri Jan 27, 2006 9:48 am

Post by sde » Sat Jan 28, 2006 10:08 am

yes, it definately doesn't work if i don't define the card option.

it looks like it automatically sets tuner=4 because all i set was options bttv card=103

and this is the dmesg:

Code: Select all

bttv0: Bt878 (rev 17) at 0000:02:0a.0, irq: 11, latency: 32, mmio: 0xf47fe000
bttv0: subsystem: 03ff:0102 (UNKNOWN)
please mail id, board name and the correct card= insmod option to kraxel()bytesex
() org
bttv0: using: Grand X-Guard / Trust 814PCI [card=103,insmod option]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
bttv0: using tuner=4
bttv0: i2c: checking for TDA9887 @ 0x86... not found
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 .. ok
bt878: AUDIO driver version 0.0.0 loaded
tuner is set.

thanks a lot!

mrd
Posts: 255
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Post by mrd » Wed May 10, 2006 5:48 pm

I'm having a very similar problem. My video is very pixelated and blue.

Here is some info...

I'm seeing some odd things in the dmesg output...

RELEVANT LINES ONLY:

Linux video capture interface: v1.00
bttv: driver version 0.9.14 loaded
bttv: using 4 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
PCI: Found IRQ 9 for device 0000:00:0f.0
PCI: Sharing IRQ 9 with 0000:00:0f.1
bttv0: Bt878 (rev 17) at 0000:00:0f.0, irq: 9, latency: 128, mmio: 0xf9ffe000
bttv0: detected: Osprey-200 [card=88], PCI subsystem ID is 0070:ff01
bttv0: using: GrandTec Multi Capture Card (Bt878) [card=77,insmod option]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
bttv0: using tuner=-1
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 .. ok
bttv0: PLL can sleep, using XTAL (28636363).

It appears that it is trying to use an Osprey 200 card but I added "options bttv card=77" to my /etc/modprobe.conf so I'm not sure what it's really doing now. The card is actually an Osprey 210 and the number according the v4l2 docs is supposed to be 89.

lspci:
[user user]$ lspci|grep 878
00:0f.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
00:0f.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)


[user user]$ xawtv -hwscan
This is xawtv-3.93, running on Linux/i686 (2.6.7-2.tmb.6mdk)
looking for available devices
port 61-61 [ -xvport 61 ]
type : Xvideo, video overlay
name : video4linux

port 62-62
type : Xvideo, image scaler
name : Matrox G-Series Backend Scaler

/dev/video0: OK [ -device /dev/video0 ]
type : v4l2
name : BT878 video (GrandTec Multi Cap
flags: overlay capture tuner

Can you help?

Thanks,
MRD

mrd
Posts: 255
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Post by mrd » Wed May 10, 2006 5:59 pm

Editing /etc/modprobe.conf with "options bttv card=89" does not change video problem. The output to the above commands is correct with the changes made though.

Thanks,
MRD

solti
Posts: 4
Joined: Wed Jan 30, 2008 12:03 am

Post by solti » Fri Apr 18, 2008 8:50 am

hi, try to use /etc/modprobe.d/bttv instead of modprobe.conf......
so you have to write "option bttv card=77" to the /etc/modprobe.d/bttv

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests