Page 1 of 1

I need help with zmcontrol script [SOLVED]

Posted: Sat Aug 30, 2008 7:24 am
by Normando
Hello all

I have read and search all wiki and forums, make various tests and I can't work the script zmcontrol

I have defines a monitor with an IP camera, and added the correct configurations for PTZ control (module, address, etc etc). I can access the video and see the camera, but I can't control. To avoid mistakes from my php installation, I run directly, through a browser the commands to camera, and run ok. Like:
and the camera run ok.

I run the script from command line to see if work, but no. The script give me an error of timeout and connection refused. Is there a way to test if the script actually output the command? I use Wireshark to see, but nothing happens, no http output nor get http command.

I also have verify the perl modules the script use and install all of them (load - Getopt-Long - data-dumper, etc)

Please, can you giveme some light to this issue?


Posted: Sat Aug 30, 2008 7:44 am
by cordel
You can use the zm control script from the command line>

Code: Select all --id <monitorID> --command=<command>
Where command is up, down, left, upleft, etc...

Posted: Sat Aug 30, 2008 2:58 pm
by Normando
Hello Cordel and thank for your fast reply.

Excuse me if I can't write correctly in english.

I know how to use the script through command line. My dude is how to verify if the command really outpt from my server to the camera.

If I not missunderstand, when I lunch a control command through zmcontrol script, this command is traduce in the LAN as the script module is configurates, example:


I want to know how to debug in real time or view why the command not output from my server.

I hope you can understand my bad english.

Thank you very much.

Posted: Sun Aug 31, 2008 7:28 pm
by Normando
Finally I found a bug in the Axis V2 script.

Any chance of you documenting the bug you found

Posted: Mon Dec 08, 2008 8:53 am
by nivlek
Hello Normando,
Normando wrote:Finally I found a bug in the Axis V2 script.
Any chance of you documenting the bug you found and what you did to fix it ?


Posted: Mon Dec 08, 2008 4:12 pm
by Normando