Zonminder suddenly stopped recording.

Support and queries relating to all previous versions of ZoneMinder
Post Reply
godsyn
Posts: 10
Joined: Sat Aug 16, 2008 6:27 am

Zonminder suddenly stopped recording.

Post by godsyn » Thu Aug 21, 2008 1:51 pm

ZoneMinder Running - v1.23.3
I have recorded past events without issue. Recently, it has stopped.

Code: Select all

.../www/events$ ls -lah
total 12K
drwxr-xr-x 3 www-data www-data 4.0K 2008-08-17 11:10 .
drwxr-xr-x 5 www-data www-data 4.0K 2008-08-15 01:08 ..
drwxr-xr-x 3 www-data www-data 4.0K 2008-08-20 21:55 1
lrwxrwxrwx 1 www-data www-data    1 2008-08-13 13:13 Garage -> 1
Repeated in apache2's error.log is:

Code: Select all

[Wed Aug 20 23:23:24 2008] [warn] [client 192.168.1.1] Timeout waiting for output from CGI script /usr/lib/cgi-bin/nph-zms, referer: http://cam.godsyn.com/index.php?view=watchfeed&mode=&mid=1&scale=100&control=
[Wed Aug 20 23:23:24 2008] [warn] [client 192.168.1.1] Timeout waiting for output from CGI script /usr/lib/cgi-bin/nph-zms, referer: http://cam.godsyn.com/index.php?view=watchfeed&mode=&mid=1&scale=100&control=
[Wed Aug 20 23:23:24 2008] [warn] [client 192.168.1.1] Timeout waiting for output from CGI script /usr/lib/cgi-bin/nph-zms, referer: http://cam.godsyn.com/index.php?view=watchfeed&mode=&mid=1&scale=100&control=
Where should I go from here? (i can see the stream. When I force event, nothing records)

jameswilson
Posts: 5111
Joined: Wed Jun 08, 2005 8:07 pm
Location: Midlands UK
Contact:

Post by jameswilson » Thu Aug 21, 2008 1:57 pm

is the database ok?
James Wilson

Disclaimer: The above is pure theory and may work on a good day with the wind behind it. etc etc.
http://www.securitywarehouse.co.uk

godsyn
Posts: 10
Joined: Sat Aug 16, 2008 6:27 am

Post by godsyn » Thu Aug 21, 2008 8:40 pm

jameswilson wrote:is the database ok?

Code: Select all

CHECK TABLE `Config` , `ControlPresets` , `Controls` , `Devices` , `Events` , `Filters` , `Frames` , `Groups` , `MonitorPresets` , `Monitors` , `States` , `Stats` , `TriggersX10` , `Users` , `ZonePresets` , `Zones` 

+-------------------+-------+----------+----------+
| Table             | Op    | Msg_type | Msg_text |
+-------------------+-------+----------+----------+
| zm.Config         | check | status   | OK       |
| zm.ControlPresets | check | status   | OK       |
| zm.Controls       | check | status   | OK       |
| zm.Devices        | check | status   | OK       |
| zm.Events         | check | status   | OK       |
| zm.Filters        | check | status   | OK       |
| zm.Frames         | check | status   | OK       |
| zm.Groups         | check | status   | OK       |
| zm.MonitorPresets | check | status   | OK       |
| zm.Monitors       | check | status   | OK       |
| zm.States         | check | status   | OK       |
| zm.Stats          | check | status   | OK       |
| zm.TriggersX10    | check | status   | OK       |
| zm.Users          | check | status   | OK       |
| zm.ZonePresets    | check | status   | OK       |
| zm.Zones          | check | status   | OK       |
+-------------------+-------+----------+----------+
all is well.

godsyn
Posts: 10
Joined: Sat Aug 16, 2008 6:27 am

Post by godsyn » Thu Aug 21, 2008 8:50 pm

Disregard. deleting and re-adding the cam resolved the issue.

bad zone config, perhaps..

W.
Posts: 108
Joined: Tue Apr 10, 2007 5:06 pm
Location: Latvia

Post by W. » Fri Aug 22, 2008 7:33 am

if you dont have ZM_USE_DEEP_STORAGE enabled, you might have hit 32k file (directory) limit. Check how many events are there for your old monitor.
if common sense is so uncommon, why is it called common then?

Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests