zmaudit.pl -c' exited abnormally, exit status 9

Support and queries relating to all previous versions of ZoneMinder

Moderator: zoneminder

kevin_robson
Posts: 247
Joined: Sun Jan 16, 2005 11:26 am

zmaudit.pl -c' exited abnormally, exit status 9

Postby kevin_robson » Tue Feb 05, 2008 8:42 pm

Installed 1.23.1 on suse 10.3. Everything seems to be OK but I get the following errors in the messages log.

Feb 5 20:36:11 gandalf zmdc[5365]: INF [Starting pending process, zmaudit.pl -c]
Feb 5 20:36:11 gandalf zmdc[5365]: INF ['zmaudit.pl -c' starting at 08/02/05 20:36:11, pid = 6421]
Feb 5 20:36:11 gandalf zmdc[6421]: INF ['zmaudit.pl -c' started at 08/02/05 20:36:11]
Feb 5 20:36:11 gandalf zmdc[5365]: ERR ['zmaudit.pl -c' exited abnormally, exit status 9]

zmdc.log shows the same.
At the time of the crashes zmaudit.log shows nothing eitehr.

Anyone any idea what is causing this?
THnaks

kevin_robson
Posts: 247
Joined: Sun Jan 16, 2005 11:26 am

Postby kevin_robson » Wed Feb 06, 2008 7:04 am

Can I run zmaudit.pl from the command line to see what output get - what parameters should be passed to it?

User avatar
zoneminder
Site Admin
Posts: 5221
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK
Contact:

Postby zoneminder » Thu Feb 07, 2008 9:40 pm

Yes, you can. By default (with no parameters) it will ask you to confirm all deletes and run one pass then exit. If you want it to run as it does normally then pass in -c as a parameter.
Phil

kevin_robson
Posts: 247
Joined: Sun Jan 16, 2005 11:26 am

Postby kevin_robson » Thu Feb 07, 2008 10:35 pm

Thanks.
Running as root I get:

zmaudit.pl -c
directory (/tmp/) Redwood is still tainted at /usr/lib/perl5/5.8.8/File/Find.pm line 837.

Any ideas?

User avatar
zoneminder
Site Admin
Posts: 5221
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK
Contact:

Postby zoneminder » Thu Feb 07, 2008 10:45 pm

I don't know what the Redwood bit means. Does that ring any bells at your end?
Phil

kevin_robson
Posts: 247
Joined: Sun Jan 16, 2005 11:26 am

Postby kevin_robson » Thu Feb 07, 2008 10:57 pm

Yeah, sorry should have explained.
It is a directory in /tmp
No idea why the script would be picking it up though?

kevin_robson
Posts: 247
Joined: Sun Jan 16, 2005 11:26 am

Postby kevin_robson » Thu Feb 07, 2008 11:02 pm

OK, I think I have it sussed now.
I had 2 directories in /tmp with spaces in the name - not ideal but copied from windows :(
If I rename them so they dont have a space then zmaudit.pl ooks to run OK.
I've restarted ZM and will confirm tomorrow if OK.

If so I've not got any idea why it is looking in /tmp, or why directories with spaces in the name throw it out.

Could some extra error checking be in order??

Thanks for your help - I'll let you know if it went OK tomorrow.

kevin_robson
Posts: 247
Joined: Sun Jan 16, 2005 11:26 am

Postby kevin_robson » Fri Feb 08, 2008 6:24 am

OK, this has ran all night without causing any problems. I guess the script cannot handle filenames with spaces in them. Not a big deal as long as I know to avoid doing so. Is it just /tmp and the document root I need to avoid doing this in?

Cheers

User avatar
zoneminder
Site Admin
Posts: 5221
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK
Contact:

Postby zoneminder » Sun Feb 10, 2008 8:09 pm

I don't know about the space thing but /tmp is the default for temporary images, logs and socket files so that is why it is probably concerned about it.
Phil

infinity005
Posts: 10
Joined: Tue Nov 16, 2004 5:37 am

Postby infinity005 » Mon Jan 03, 2011 4:57 pm

Code: Select all

hostname:/tmp# zmaudit.pl -c
directory (/tmp/) aptitude-root.5137:8ybHku is still tainted at /usr/share/perl/5.10/File/Find.pm line 869.
hostname:/tmp#


Once I deleted this file (aptitude-root.5137:8ybHku), zmaudit.pl started okay.

Looks like a bug in zmaudit.pl. I'm running Deb package 1.24.2-7


Return to “ZoneMinder Previous Versions”

Who is online

Users browsing this forum: No registered users and 1 guest