Page 1 of 1

Fast forwarding not going as fast as it should.

Posted: Mon Jan 28, 2008 7:12 am
by timcraig
I upgraded my Zoneminder 1.22.3 system to 1.23.1 and have a problem with fast forwarding not going very fast.

When my same ZM system was running version 1.22.3, the fast forwarding worked fine.

After the upgrade to 1.23.1, if set the rate to 2x -4x, when viewing an event, it doesn't appear to be any faster than realtime rate 'real'. The 10x rate only seems to go about 2x. If I set the rate to 25x or 50x, the rate only goes about 3x-5x.

Fast forwarding is slow in both the new DVR viewer and the standard event viewer. When I'm in the standard event viewer, the progress bar appears to be accurate with the fast forward speed even though the video stream is not.

I looked at the logs and I don't see any error messages of any kind. I tried changing from zms to nph-zms but that did not have any effect on the fast forward speed.

I'm using Ubuntu 7.10 server. I made the 1.23.1 build with the lastest ffmpeg from the svn

Code: Select all

FFmpeg version SVN-r11637, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-libvorbis --enable-liba52 --enable-libgsm --disable-debug --enable-libmp3lame --enable-libfaad --enable-libfaac --enable-libxvid --enable-pthreads --enable-libx264 --enable-shared --enable-pp --enable-swscaler --enable-gpl
  libavutil version: 49.6.0
  libavcodec version: 51.50.0
  libavformat version: 52.6.0
  libavdevice version: 52.0.0
  built on Jan 27 2008 10:21:29, gcc: 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
FFmpeg SVN-r11637
libavutil   3212800
libavcodec  3355136
libavformat 3409408
libavdevice 3407872

Does anyone have any ideas why fast forwarding is the working as fast as it should for me?

Posted: Wed Jan 30, 2008 4:54 am
by timcraig
Actually, 50x now goes about 10x to 12x now in the DVR viewer. Still not as fast as 1.22.3, but that's fast enough for my needs.

I don't know why it was going slower before. The load, memory and CPU utilization history doesn't show any differences between then and now.

Posted: Thu Feb 07, 2008 10:05 pm
by zoneminder
Were you using it over LAN connection or upstream from DSL etc? It does depend a little on the appropriate bandwidth settings being used or it may try and force too many frames up a slow connection at once.

Posted: Fri Feb 08, 2008 7:16 pm
by timcraig
Thanks for the reply Phil,

I'm running on a 100mbs Ethernet. But I should try to run a speed test on my network to see if the speed is really 100mbs.

Posted: Thu Mar 27, 2008 8:36 pm
by timcraig
Looks like fast forward issue I'm having is related to the ZM_WEB_H_VIDEO_MAXFPS option in the bandwidth tabs.

The problem with fast forward speeds came up again. Events from monitors that record at ~ 1.6 fps where not speeding up at all when I set it to fast forward to 50x. I remembered that I recently set ZM_WEB_H_VIDEO_MAXFPS to 30 in the high bandwidth tab. I then set that option down to 5 and fast forwarding began to work at their appropriate speeds. I then changed ZM_WEB_H_VIDEO_MAXFPS to 15, the fast forwarding ran slower than it was suppose to.

So it looks like the fast forward/rewind speeds don't work like they should when you have cameras with low frame rates and the ZM_WEB_H_VIDEO_MAXFPS is set to a high value.

Description of my setup:
I'm running ZM 2.23.3 on a PV-155 with 7 cameras. The system is a Pentium4 2.8 GHz with 1 Gig of memory. My capture size is 640x480 on all cameras and I have ZM_CAPTURES_PER_FRAME set to 2. I have two cameras running at 4fps (they are using their own capture chips on the PV-155), I have 2 cameras sharing 1 capture chip running at ~2.5fps and I have 3 cameras sharing 1 capture chip running at ~1 fps. My fast forwarding tests were done with a 100mbs Ethernet connection to the ZM server (I tested the connection speed and I get about 90mbs).