[Solved]Suse 10.3 an Zoneminder

Support and queries relating to all previous versions of ZoneMinder
Post Reply
schnurzelat
Posts: 3
Joined: Mon Oct 15, 2007 12:25 pm

[Solved]Suse 10.3 an Zoneminder

Post by schnurzelat » Mon Oct 15, 2007 1:14 pm

Hello,

i've upgraded from Suse 10.2 to Suse 10.3. But after the Update the Webinterfache won't work anymore. The Services started properly, but if i try to open the Webinterface, there is a strange looking window. Even the name of the Window is incorrect: <?= ZM_WEB_TITLE_PREFIX ?> etc.

I think there is something missing in apache2, but i've no idea what missing modul cause this error. Can anyone help?

Thanks.

schnurzelat

Code: Select all

#
# Files in this directory are created at apache start time by /usr/sbin/rcapache2 
# Do not edit them!
#

# as listed in APACHE_MODULES (/etc/sysconfig/apache2)

LoadModule authz_host_module              /usr/lib/apache2-prefork/mod_authz_host.so
LoadModule actions_module                 /usr/lib/apache2-prefork/mod_actions.so
LoadModule alias_module                   /usr/lib/apache2-prefork/mod_alias.so
LoadModule auth_basic_module              /usr/lib/apache2-prefork/mod_auth_basic.so
LoadModule authz_groupfile_module         /usr/lib/apache2-prefork/mod_authz_groupfile.so
LoadModule authn_file_module              /usr/lib/apache2-prefork/mod_authn_file.so
LoadModule authz_user_module              /usr/lib/apache2-prefork/mod_authz_user.so
LoadModule autoindex_module               /usr/lib/apache2-prefork/mod_autoindex.so
LoadModule cgi_module                     /usr/lib/apache2-prefork/mod_cgi.so
LoadModule dir_module                     /usr/lib/apache2-prefork/mod_dir.so
LoadModule include_module                 /usr/lib/apache2-prefork/mod_include.so
LoadModule log_config_module              /usr/lib/apache2-prefork/mod_log_config.so
LoadModule mime_module                    /usr/lib/apache2-prefork/mod_mime.so
LoadModule negotiation_module             /usr/lib/apache2-prefork/mod_negotiation.so
LoadModule setenvif_module                /usr/lib/apache2-prefork/mod_setenvif.so
LoadModule status_module                  /usr/lib/apache2-prefork/mod_status.so
LoadModule userdir_module                 /usr/lib/apache2-prefork/mod_userdir.so
LoadModule asis_module                    /usr/lib/apache2-prefork/mod_asis.so
LoadModule imagemap_module                /usr/lib/apache2-prefork/mod_imagemap.so
LoadModule php5_module                    /usr/lib/apache2/mod_php5.so
LoadModule authz_default_module           /usr/lib/apache2-prefork/mod_authz_default.so
LoadModule ssl_module                     /usr/lib/apache2-prefork/mod_ssl.so
LoadModule proxy_module                   /usr/lib/apache2-prefork/mod_proxy.so
LoadModule proxy_http_module              /usr/lib/apache2-prefork/mod_proxy_http.so
LoadModule proxy_connect_module           /usr/lib/apache2-prefork/mod_proxy_connect.so
LoadModule apparmor_module                /usr/lib/apache2-prefork/mod_apparmor.so
Last edited by schnurzelat on Thu Oct 18, 2007 10:34 am, edited 1 time in total.

achix
Posts: 146
Joined: Tue Oct 02, 2007 9:38 am
Location: Greece

Post by achix » Mon Oct 15, 2007 3:12 pm

what do the logs of apache say?
write simple php script with one line

<?
phpinfo();
?>

and see if you can run it.

schnurzelat
Posts: 3
Joined: Mon Oct 15, 2007 12:25 pm

Post by schnurzelat » Mon Oct 15, 2007 9:05 pm

I' ve found the following line in the apache log:

Code: Select all

[client 127.0.0.1] script '/srv/www/htdocs/zm/zm_audit.php' not found or unable to stat
The File doesn't exists in the specified folder. Where can i get this file? It is not included in ZoneMinder-1.22.3.tar.gz.

I've made a file named, index.php in my webserver root directory and put the lines in it. If i call the index.php i can only see a blank page.

I'm running also phpMyAdmin and phpBB. Both works fine.

Any suggestions?

Thanks.

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Wed Oct 17, 2007 7:23 pm

i've got similar error :)

you have to enable short tags for php. some how these are diabled by default

open /etc/php5/apache2/php.ini
change

Code: Select all

short_open_tag = Off
to

Code: Select all

short_open_tag = On
this should do it.

hope this helps
Image

schnurzelat
Posts: 3
Joined: Mon Oct 15, 2007 12:25 pm

Post by schnurzelat » Thu Oct 18, 2007 10:33 am

THANKS!

That solves the problem!

greetings
schnurzelat

Post Reply

Who is online

Users browsing this forum: No registered users and 19 guests