Black Screen from IP Camera - ZM 1.21.4

Support and queries relating to all previous versions of ZoneMinder
Post Reply
Ruler
Posts: 208
Joined: Mon Nov 08, 2004 9:02 pm
Location: Bay City, MI

Black Screen from IP Camera - ZM 1.21.4

Post by Ruler »

I have a very old ZoneMinder box, running version 1.21.4 on Slackware Linux. I have attempted to update it in the past, but the video capture card which grabs video from the BNC-based security cameras does not work right in newer versions and management isn't willing to spend the money for all new cameras & running new cabling, so I'm pretty much stuck on this version. (This really isn't the worst thing in the world though, as it does everything we want it to.)

The reason I'm posting is because I recently purchased an AnpViz IPC-B850W-DS IP camera & am in the process of setting it up so that it will display with the others. I chose this one after doing a significant amount of research and learning that snapshots are available from the camera, just like the other few IP cameras we have in place. Unfortunately, I've been unable to make it work.

According to support, still pictures are available from the camera (which runs an embedded version of Linux internally) by going to http://cameraIP/cgi-bin/snapshot.cgi?stream=0 Using stream=1 is supposed to give you a different resolution, though it doesn't seem to matter. Omitting the ?stream=n parameter entirely also works. I've confirmed all this by using a web browser - it provides a single frame JPEG with 704x480 resolution and uses plain http - no SSL/TLS. These URLs are accessible by passing a username/password in the URL or by just going to the link without sending any credentials to it. Unfortunately, when I enter this resolution in the ZoneMinder source tab as the image resolution, the IP in the camera list turns red indicating a config problem.

In the past, I've seen this happen if the resolution in the source tab isn't what the camera is supplying, so I started playing with different numbers. If I enter 320x240, which is actually closer to what we want so multiple cameras can be seen on the screen at once, the IP turns orange indicating that it's working. Unfortunately, when viewing the stream in ZoneMinder, there's nothing but a black box where the image from the camera is supposed to appear. The configuration is set to monitor only, no recording.

I've tried passing credentials to the camera and just the plain URL to the snapshot page in the ZoneMinder source tab. I've used stream=0, stream=1, and eliminating the stream parameter entirely. I've tried a variety of resolutions trying to get a picture to show up, but either get the red IP or the black box. Everything else is the same to another IP camera of a different brand/model running on the same system.

Contacting the support people of the camera was my first idea, but they're just going to (correctly) point out that it works through a web browser, so the camera is operating normally. Kind of at a loss as to why ZoneMinder would be fine displaying streams from 4 other IP cameras and not this one, especially when it provides a raw JPEG over port 80 with no encryption. Any ideas of what else I can try to get this working?
This message is made up of not less than 90% recycled electrons.
Post Reply