Playback not progressing after upgrade to 1.36.12 from 1.34.x

Discussions related to the 1.36.x series of ZoneMinder
Post Reply
wavecrest1
Posts: 2
Joined: Mon Jan 24, 2022 7:24 pm

Playback not progressing after upgrade to 1.36.12 from 1.34.x

Post by wavecrest1 »

I've upgraded to v.1.36.12 from 1.34 by removing the 1.34 ppa, adding the 1.36 ppa then doing apt update; apt upgrade
Seemed to go smoothly with the exception of playback.
When I play events individually, they (individually) playback fine.
When I play back using gapless events on a chrome browser on the local machine, one or two events will playback, then it freezes until black "no more event data found" screen appears.
On chrome on a mobile, the behaviour is slightly different - It plays the first 2-3 events normally then plays the rest at lighning speed.
In gapless events mode, the event number at the top doesn't change even for the couple of events that do play.

I have checked the timezone and they all seem to be OK.

The box is a ubuntu 20-04.1

Any help appreciated!
raymonvdm
Posts: 23
Joined: Thu Jan 16, 2014 3:01 pm

Re: Playback not progressing after upgrade to 1.36.12 from 1.34.x

Post by raymonvdm »

I seem to be having simular issues, recording on some cams is working fine, some seem to have issues with recording (maybe related to a missed setting) but i will trouble shoot that later, also my cpu load has doubled since using 1.36.12

But the actual issue i`m now having is that playing of events is not working. The event is found and audio is playing but the video screen stays black using this url

Code: Select all

https://server/zm/index.php?view=event&eid=1437716&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Battr%5D=StartDateTime&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Bop%5D=%3E%3D&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Bval%5D=-1+hour&filter%5BQuery%5D%5Bterms%5D%5B1%5D%5Bcnj%5D=and&filter%5BQuery%5D%5Bterms%5D%5B1%5D%5Battr%5D=MonitorId&filter%5BQuery%5D%5Bterms%5D%5B1%5D%5Bop%5D=%3D&filter%5BQuery%5D%5Bterms%5D%5B1%5D%5Bval%5D=1&filter%5BQuery%5D%5Bsort_asc%5D=1&filter%5BQuery%5D%5Bsort_field%5D=StartDateTime&filter%5BQuery%5D%5Blimit%5D=100&sort_field=StartDateTime&sort_asc=1&page=1
However when i download the event

Code: Select all

https://server/zm/index.php?mode=mp4&eid=1437716&view=view_video&auth=4e333cd2424e7ba8aee149a71fc8cf50 
the resulting MP4 is playing fine

I have tried Chrome and Firefox both seem to have the same result. However when the camera is configured to use "Video Writer: Camera Passthrough" the playing of events is working

Code: Select all

Storage Area	Local
Save JPEGs	Disabled
Video Writer	Camera Passthrough
Optional Encoder Parameters (?)
	
# Lines beginning with # are a comment 
# For changing quality, use the crf option
# 1 is best, 51 is worst quality
#crf=23

Whether to store the audio stream when saving an event. Yes
And if i select the Codec MJPEG i have an working image, and when selecting Codec MP4 i have no video image
User avatar
iconnor
Posts: 1908
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Playback not progressing after upgrade to 1.36.12 from 1.34.x

Post by iconnor »

@ramondvdm you are encoding to h265.

After update you DO need to review your settings.

Please note that encoding generally requires setting values for the codec options. Each codec has it's own.
Post Reply