brand new install 36.12 and Bionic - timezone not set correctly

Discussions related to the 1.36.x series of ZoneMinder
Post Reply
8ace
Posts: 104
Joined: Tue May 31, 2005 3:38 pm

brand new install 36.12 and Bionic - timezone not set correctly

Post by 8ace »

Evening chaps... to avoid the errors in the log and to cover all bases:

1. I set the timezone of my computer using "timedatectl set-timezone "
2. I set the timezone in Options/System Timezone.
2. I set the timezone in /etc/php/7.2/cli/php.ini
3. I set the timezone in /etc/php/7.2/apache2/php.ini

I could be wrong but I had none of these issues with 36.11.... any idea what ridiculous thing I am doing wrong?

thanks! :D

[attachment=0]php.PNG[/attachment]
Attachments
php.PNG
php.PNG (35.04 KiB) Viewed 2101 times
dougmccrary
Posts: 545
Joined: Sat Aug 31, 2019 7:35 am

Re: brand new install 36.12 and Bionic - timezone not set correctly

Post by dougmccrary »

I don't recall the need to do all that. Just the options one is required, I think.
But what's that version 1.34.26 doing in there?
Magic919
Posts: 858
Joined: Wed Sep 18, 2013 6:56 am

Re: brand new install 36.12 and Bionic - timezone not set correctly

Post by Magic919 »

dougmccrary wrote: Tue Jan 11, 2022 8:57 am But what's that version 1.34.26 doing in there?
My 1.36.12 is exactly the same if I search the logs.
-----------------------------------------------------------------------
I'm nothing to do with ZM, ZMNinja or ZMES, I just use them.
Contribute funding to the devs here - https://opencollective.com/zoneminder
Magic919
Posts: 858
Joined: Wed Sep 18, 2013 6:56 am

Re: brand new install 36.12 and Bionic - timezone not set correctly

Post by Magic919 »

Just to add -

Code: Select all

curl https://update.zoneminder.com/version.txt
Gives - 1.34.26
-----------------------------------------------------------------------
I'm nothing to do with ZM, ZMNinja or ZMES, I just use them.
Contribute funding to the devs here - https://opencollective.com/zoneminder
mfitch
Posts: 14
Joined: Mon Feb 11, 2019 5:23 pm

Re: brand new install 36.12 and Bionic - timezone not set correctly

Post by mfitch »

Granted, I use a Docker image, but I had an issue with the time zone also. The Docker image uses Ubuntu as a base and I execute the following to fix the timezone in the container:
ENV TZ America/New_York
RUN echo $TZ>/etc/timezone && cp /usr/share/zoneinfo/${TZ} /etc/localtime; sed -i -E 's,;?date.timezone ?=.*,date.timezone = America/New_York,' /etc/php/7.4/apache2/php.ini
I expect in BASH you could do
echo America/New_York>/etc/timezone && cp /usr/share/zoneinfo/America/New_York /etc/localtime; sed -i -E 's,;?date.timezone ?=.*,date.timezone = America/New_York,' /etc/php/7.4/apache2/php.ini
Of course, if you're not on the America/New_York time zone this will need to be modified. Check the /usr/share/zoneinfo/ directory for the appropriate option.
Magic919
Posts: 858
Joined: Wed Sep 18, 2013 6:56 am

Re: brand new install 36.12 and Bionic - timezone not set correctly

Post by Magic919 »

Magic919 wrote: Tue Jan 11, 2022 10:02 am Just to add -

Code: Select all

curl https://update.zoneminder.com/version.txt
Gives - 1.34.26
Now updated.
-----------------------------------------------------------------------
I'm nothing to do with ZM, ZMNinja or ZMES, I just use them.
Contribute funding to the devs here - https://opencollective.com/zoneminder
Post Reply