RTSP in 1.36 ?

Discussions related to the 1.36.x series of ZoneMinder
sergmx
Posts: 20
Joined: Thu Jun 17, 2021 3:48 am

RTSP in 1.36 ?

Post by sergmx » Thu Jun 17, 2021 4:06 am

(Sorry bad my engl)

I read that in 1.36 they added : zm_rtsp_server
it's not quite clear how to use this.

I am using CentOS 7.9 + all updates + zoneminder-1.34.22-1.el7.x86_64.rpm (from RPM Fusion Free)
All my cameras work without any problems.
But after upgrading to version : zoneminder-1.36.3-1.el7.x86_64.rpm (from RPM Fusion Free),

Those cameras that worked via RTSP stopped working. The rest worked without any problems. What can I do?
Or do I have to wait for version 1.37?

---
Jun 16 15:09:04 cex3-cctv2 zmc_m3[29868]: INF [zmc_m3] [Starting Capture version 1.36.3]
Jun 16 15:09:04 cex3-cctv2 zmc_m3[29868]: ERR [zmc_m3] [Response parse failure in 'rver: Rtsp Server/3.0#015#012#015#012']
Jun 16 15:09:04 cex3-cctv2 zmc_m3[29868]: FAT [zmc_m3] [Unable to get session identifier from response 'RTSP/1.0 200 OK#015#012CSeq:
3#015']
Jun 16 15:09:06 cex3-cctv2 zmdc[29636]: ERR ['zmc -m 4' exited abnormally, exit status 255]
Jun 16 15:09:07 cex3-cctv2 zmdc[29636]: INF [Starting pending process, zmc -m 4]
Jun 16 15:09:07 cex3-cctv2 zmdc[29636]: INF ['zmc -m 4' starting at 21/06/16 15:09:07, pid = 29875]
Jun 16 15:09:07 cex3-cctv2 zmdc[29875]: INF ['zmc -m 4' started at 21/06/16 15:09:07]
Jun 16 15:09:07 cex3-cctv2 zmc_m4[29875]: INF [zmc_m4] [Starting Capture version 1.36.3]
Jun 16 15:09:07 cex3-cctv2 zmc_m4[29875]: ERR [zmc_m4] [Response parse failure in 'erver: Rtsp Server/3.0#015#012#015#012']
Jun 16 15:09:07 cex3-cctv2 zmc_m4[29875]: FAT [zmc_m4] [Unable to get session identifier from response 'RTSP/1.0 200 OK#015#012CSeq:
3#015#012']

---
Thanks.

sergmx
Posts: 20
Joined: Thu Jun 17, 2021 3:48 am

Re: RTSP in 1.36 ?

Post by sergmx » Fri Jun 18, 2021 5:18 am

The inscription was a little earlier, if it helps ...

---
Jun 16 15:09:01 cex3-cctv2 zmc_m4[29861]: INF [zmc_m4] [Starting Capture version 1.36.3]
Jun 16 15:09:01 cex3-cctv2 zmc_m4[29861]: ERR [zmc_m4] [Response parse failure in 'erver: Rtsp Server/3.0#015#012#015#012']
Jun 16 15:09:01 cex3-cctv2 zmc_m4[29861]: FAT [zmc_m4] [Unable to get session identifier from response 'RTSP/1.0 200 OK#015#012CSeq:
3#015#012']
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [No RTSP sources]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Failed to prime capture of initial monitor]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Got signal 6 (Aborted), crashing]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Signal address is 0x30000073e9, from 0x7f229e3ef387]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 0: /usr/bin/zmc(+0xc6a8a) [0x5607ef3eda8a]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 1: /lib64/libpthread.so.0(+0xf630) [0x7f22a1bb0630]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 2: /lib64/libc.so.6(gsignal+0x37) [0x7f229e3ef387]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 3: /lib64/libc.so.6(abort+0x148) [0x7f229e3f0a78]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 4: /lib64/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerE
v+0x165) [0x7f229ecffa95]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 5: /lib64/libstdc++.so.6(+0x5ea06) [0x7f229ecfda06]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 6: /lib64/libstdc++.so.6(+0x5ea33) [0x7f229ecfda33]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 7: /lib64/libstdc++.so.6(+0x5ec53) [0x7f229ecfdc53]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 8: /lib64/libstdc++.so.6(_ZSt20__throw_system_errori+0x90) [0x7f229e
d52f30]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 9: /lib64/libstdc++.so.6(_ZNSt6thread4joinEv+0x18) [0x7f229ed540e8]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 10: /usr/bin/zmc(main+0x8eb) [0x5607ef33990b]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 11: /lib64/libc.so.6(__libc_start_main+0xf5) [0x7f229e3db555]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: ERR [undef] [Backtrace 12: /usr/bin/zmc(+0x160f8) [0x5607ef33d0f8]]
Jun 16 15:09:03 cex3-cctv2 undef[29673]: INF [undef] [Backtrace complete, please execute the following command for more information:
addr2line -e /usr/bin/zmc 0x5607ef3eda8a 0x7f22a1bb0630 0x7f229e3ef387 0x7f229e3f0a78 0x7f229ecffa95 0x7f229ecfda06 0x7f229ecfda33
0x7f229ecfdc53 0x7f229ed52f30 0x7f229ed540e8 0x5607ef33990b 0x7f229e3db555 0x5607ef33d0f8]
Jun 16 15:09:03 cex3-cctv2 zmdc[29636]: ERR ['zmc -m 3' exited abnormally, exit status 6]
Jun 16 15:09:04 cex3-cctv2 zmdc[29636]: INF [Starting pending process, zmc -m 3]
Jun 16 15:09:04 cex3-cctv2 zmdc[29636]: INF ['zmc -m 3' starting at 21/06/16 15:09:04, pid = 29868]
Jun 16 15:09:04 cex3-cctv2 zmdc[29868]: INF ['zmc -m 3' started at 21/06/16 15:09:04]
Jun 16 15:09:04 cex3-cctv2 zmc_m3[29868]: ERR [zmc_m3] [Zone 3/All for monitor Monitor-3 extends outside of image dimensions, (0,0),
(719,1279), fixing]
---

Magic919
Posts: 548
Joined: Wed Sep 18, 2013 6:56 am

Re: RTSP in 1.36 ?

Post by Magic919 » Fri Jun 18, 2021 7:10 am

Did you change any of the config for those monitors?

You don't want 1.37, it's the unstable branch. You want 1.36.4 onwards. Stay on 1.36.x

sergmx
Posts: 20
Joined: Thu Jun 17, 2021 3:48 am

Re: RTSP in 1.36 ?

Post by sergmx » Fri Jun 18, 2021 9:10 am

> Did you change any of the config for those monitors?
No

> You don't want 1.37, it's the unstable branch. You want 1.36.4 onwards. Stay on 1.36.x
Since some of my cameras (RTSP only) stopped working I had to go back to the : zoneminder-1.34.22-1.el7.x86_64.rpm

I wrote about 1.37 because I read it: viewtopic.php?f=43&t=30858
I think the new module : zm_rtsp_server - Contains errors.

Magic919
Posts: 548
Joined: Wed Sep 18, 2013 6:56 am

Re: RTSP in 1.36 ?

Post by Magic919 » Fri Jun 18, 2021 9:22 am

I think there would be a lot more people having the problem.

sergmx
Posts: 20
Joined: Thu Jun 17, 2021 3:48 am

Re: RTSP in 1.36 ?

Post by sergmx » Mon Jun 21, 2021 12:12 pm

Sorry. Maybe you can tell me what I need to change to make my cameras work?

Source : Remote
Remote protocol : RTSP
Metod : RTP/RTSP
name : user:xxx@192.168.xxx.65
port : 554
path: /cam/realmonitor?channel=1&subtype=0&tcp
color: 24
resolution: 720x1280

Magic919
Posts: 548
Joined: Wed Sep 18, 2013 6:56 am

Re: RTSP in 1.36 ?

Post by Magic919 » Mon Jun 21, 2021 12:22 pm

Change source type to ffmpeg. Method will be TCP. Move ‘name’ part into Source Path before your current ‘path’.

User avatar
bkjaya1952
Posts: 223
Joined: Sat Aug 25, 2018 3:24 pm
Location: Sri Lanka
Contact:

Re: RTSP in 1.36 ?

Post by bkjaya1952 » Mon Jun 21, 2021 6:13 pm

sergmx wrote:
Mon Jun 21, 2021 12:12 pm
Sorry. Maybe you can tell me what I need to change to make my cameras work?

Source : Remote
Remote protocol : RTSP
Metod : RTP/RTSP
name : user:xxx@192.168.xxx.65
port : 554
path: /cam/realmonitor?channel=1&subtype=0&tcp
color: 24
resolution: 720x1280
Try this

Source :Ffmpeg
Screenshot from 2021-06-21 23-37-31.png
Screenshot from 2021-06-21 23-37-31.png (13.01 KiB) Viewed 1918 times
Press ONVIF button and select the detected camera details & stream , enter the user name and password of the camera . Then save.

You can edit the resolution

sergmx
Posts: 20
Joined: Thu Jun 17, 2021 3:48 am

Re: RTSP in 1.36 ?

Post by sergmx » Tue Jun 22, 2021 4:18 am

Magic919 wrote:
Mon Jun 21, 2021 12:22 pm
Change source type to ffmpeg. Method will be TCP. Move ‘name’ part into Source Path before your current ‘path’.
I once tried ffmpeg, in the logs wrote errors, cameras often fell off and most importantly a lot of CPU load. I switched from it to RTSP and everything worked fine until version 1.36...

I read : https://wiki.zoneminder.com/Dummies_Guide
Last edited by sergmx on Tue Jun 22, 2021 4:44 am, edited 1 time in total.

sergmx
Posts: 20
Joined: Thu Jun 17, 2021 3:48 am

Re: RTSP in 1.36 ?

Post by sergmx » Tue Jun 22, 2021 4:38 am

bkjaya1952 wrote:
Mon Jun 21, 2021 6:13 pm
...
Press ONVIF button and select the detected camera details & stream , enter the user name and password of the camera . Then save.

You can edit the resolution
At one time I tried different ways to use ONVIF detector, but it did not work for me.

Then I took a third-party prog, a separate one, and got a string : /cam/realmonitor?channel=1&subtype=0&tcp

I use camer : RVi-1NCD2023(2.8-12)
I bought this camera because it was supposed to support mjpg, but I have not been able to get it from the camera.
So I have to use rtsp :(

i read : https://wiki.zoneminder.com/Dahua (analog RVI)

Magic919
Posts: 548
Joined: Wed Sep 18, 2013 6:56 am

Re: RTSP in 1.36 ?

Post by Magic919 » Tue Jun 22, 2021 12:07 pm

Mjpeg and RTSP are two completely different things. Current suggestion is ffmpeg. Otherwise stick with the old version you enjoy.

sergmx
Posts: 20
Joined: Thu Jun 17, 2021 3:48 am

Re: RTSP in 1.36 ?

Post by sergmx » Wed Jun 23, 2021 6:04 am

All of my mjpeg cameras had no problem switching to version 1.36.
But these 2 cameras can not give mjpeg (although written) and have to take from them RTSP. I repeat, when I did tests ffmpeg was very busy with the processor, etc. and so I switched to RTSP.

Here it says : https://wiki.zoneminder.com/Dummies_Guide
...
RTSP

These cameras usually use h264 compression. However ZM decodes all incoming video to jpeg files, so it's not as efficient. This requires libvlc, or ffmpeg to convert the video to jpg files.

Note: Users with 1.32+ can use H264 passthrough, which writes the h264 direct to mp4, and saves some CPU usage. zma, however still converts to JPEGs internally.
...
---------
And it all worked until version 1.36 !

sergmx
Posts: 20
Joined: Thu Jun 17, 2021 3:48 am

Re: RTSP in 1.36 ?

Post by sergmx » Thu Jun 24, 2021 3:41 am

It showed up in the test :
https://download1.rpmfusion.org/free/el ... x86_64.rpm
I decided to try it as well. It's the same :(
I got tired of struggling with this and converted all my RTSP cameras to ffmpeg, yes it works.

Now a new problem, but about it in another topic.

THANK YOU.
The issue was solved by a workaround.

adot
Posts: 10
Joined: Sat Apr 08, 2017 10:06 am

Re: RTSP in 1.36 ?

Post by adot » Wed Jul 14, 2021 4:53 pm

I am having the exact same problems with several D-Link IP-Cams (DCS-7010L & DCS-942L).
They worked perfectly well for years, but after upgrading to 1.36 they don't work anymore with RTSP giving me the same errors in log.
After re-configuring them to remote/http and changing the cams output format from h264 to mjpeg it is at least working somehow.

This workaround however has tripled the bandwidth and also I am loosing audio surveillance, thus still looking for a suitable solution with RTSP.
Thanks.

adot
Posts: 10
Joined: Sat Apr 08, 2017 10:06 am

Re: RTSP in 1.36 ?

Post by adot » Wed Jul 14, 2021 8:43 pm

I observed the following:
This problem can be solved by setting the problematic cam Source >> Deinterlacing >> Disabled

I used Deinterlacing (Four field motion adaptive - Medium) on the cameras that showed this error.
Switching this to "Disabled" and the cams will work perfectly.
Switching it back on and the cams reproducibly stop working.

I don't know why, especially as this worked in <=1.34, but this is (at least for me) a better workaround than switching to http/(m)jpg.

Hope this works for you, too.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests