Apache error

Discussions related to the 1.36.x series of ZoneMinder
Post Reply
alabamatoy
Posts: 301
Joined: Sun Jun 05, 2016 2:53 pm

Apache error

Post by alabamatoy » Mon Jun 14, 2021 10:58 am

I am seeing the following error:

Code: Select all

[13/Jun/2021:17:16:32 -0400] "GET /favicon.ico HTTP/1.1" 404 454 "https://[ServerDomain]/zm/index.php?view=console" "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0"
Apparently, somewhere in all the ZM code, something is telling the browser to look in the web root for the favicon file instead of in /graphics which is where it is explicitly supposed to be found.

Anyone else seeing this?

Magic919
Posts: 552
Joined: Wed Sep 18, 2013 6:56 am

Re: Apache error

Post by Magic919 » Mon Jun 14, 2021 3:35 pm

I’ve only ever seen them in the webroot. Is this a new thing putting them elsewhere?

alabamatoy
Posts: 301
Joined: Sun Jun 05, 2016 2:53 pm

Re: Apache error

Post by alabamatoy » Tue Jun 15, 2021 11:28 pm

Open the console, and hit "view source", look for the references, they are in graphics folder.
<link rel="icon" type="image/ico" href="graphics/favicon.ico"/>
<link rel="shortcut icon" href="graphics/favicon.ico"/>
I think the webroot has nothing but the index.php in it now.

Magic919
Posts: 552
Joined: Wed Sep 18, 2013 6:56 am

Re: Apache error

Post by Magic919 » Wed Jun 16, 2021 4:41 am

I was questioning this as you made it sound like a convention.

Post Reply

Who is online

Users browsing this forum: tsp84 and 3 guests