FPS Report Interval not followed

Discussions related to the 1.36.x series of ZoneMinder
Post Reply
Konfucius
Posts: 9
Joined: Mon Jun 07, 2021 7:35 pm

FPS Report Interval not followed

Post by Konfucius » Fri Jun 11, 2021 8:08 pm

No matter what I set my FPS Report Interval under the Misc section, it doesn't seem to affect how frequently the cameras report their FPS to the syslog. This worked in previous versions, am I missing something here?

User avatar
iconnor
Posts: 1603
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: FPS Report Interval not followed

Post by iconnor » Sat Jun 12, 2021 3:34 am

This is a known reported issue. I just havn't decided on the solution.

The issue is that we use this reporting to report the fps values to the web ui, and when a camera starts up, if you have some ridiculous interval set we need to update it a few times after starting. So until we reach the first interval length, we report at every ten frames. Which works well when the interval is <= 100. When it is set to something like 10000000 it's not bueno.

The current though is to simply remove the logging. It's available in the console for all to see. However that doesn't give historical context. So we need to split the calculation and db updating of the value from the logging.

Expect a solution in 1.36.5

PS our opinion is that a value of more than an hour is useless. So we may remove the feature entirely.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests