Upgrade from 1.34 to 1.36 borked our ZM (KDE Neon)

Discussions related to the 1.36.x series of ZoneMinder
Post Reply
cpits-security
Posts: 2
Joined: Sun Jan 16, 2022 5:50 am

Upgrade from 1.34 to 1.36 borked our ZM (KDE Neon)

Post by cpits-security »

Hello all,
Today we ran the upgrade to 1.36 and now the system refuses to upgrade the MySQL database to the relative version.
It refuses to complete the update of the database (via CLI - zmupdate.pl).

Our system has been running for months without too much issue now it will not update from 1.34 to 1.36 even after trolling through many searches.

Can someone please point us in the right direction?

TIA,
CPITS-ADMIN
Magic919
Posts: 858
Joined: Wed Sep 18, 2013 6:56 am

Re: Upgrade from 1.34 to 1.36 borked our ZM (KDE Neon)

Post by Magic919 »

Post up the error message from running the cli update command.
-----------------------------------------------------------------------
I'm nothing to do with ZM, ZMNinja or ZMES, I just use them.
Contribute funding to the devs here - https://opencollective.com/zoneminder
User avatar
iconnor
Posts: 1911
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Upgrade from 1.34 to 1.36 borked our ZM (KDE Neon)

Post by iconnor »

There are some updates that conflict with some default settings relating to binlog.

You can try doing sudo update.pl -s which tries to apply the updates as root instead of as the zmuser.
cpits-security
Posts: 2
Joined: Sun Jan 16, 2022 5:50 am

Re: Upgrade from 1.34 to 1.36 borked our ZM (KDE Neon)

Post by cpits-security »

Thank you, the database has updated using "sudo zmupdate.pl -s". Now rebooting the security system to see if it has worked.

Update:
That worked! Thank you much!
Post Reply