Can't install on Ubuntu 20.04

Discussions related to the 1.36.x series of ZoneMinder
Post Reply
junior466
Posts: 8
Joined: Sun Mar 03, 2019 7:33 pm

Can't install on Ubuntu 20.04

Post by junior466 » Tue Nov 23, 2021 2:04 am

I am following this https://wiki.zoneminder.com/Ubuntu_Serv ... der_1.34.x guide after installing lamp using:

sudo apt-get install tasksel
sudo tasksel install lamp-server

It simply gives me the following when visiting the page:

Code: Select all

ZoneMinder Error

Unable to connect to ZM db using dsn mysql:host=localhost;dbname=zm

could not find driver

ZoneMinder will retry connection in 28 seconds.
Any ideas?

dougmccrary
Posts: 389
Joined: Sat Aug 31, 2019 7:35 am

Re: Can't install on Ubuntu 20.04

Post by dougmccrary » Tue Nov 23, 2021 5:07 am

Hmm. That ordinarily works. You did sudo su before starting?
Did you install 1.34 or 1.36? IOW, did you mod the script for 1.36?

junior466
Posts: 8
Joined: Sun Mar 03, 2019 7:33 pm

Re: Can't install on Ubuntu 20.04

Post by junior466 » Tue Nov 23, 2021 11:41 pm

I did not use sudo su. I tried installing 1.34.

bbunge
Posts: 2811
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Can't install on Ubuntu 20.04

Post by bbunge » Thu Nov 25, 2021 3:20 pm

If you use MySQL there may be some issues. I recommend Mariadb. Use: sudo apt install apache2 php mariadb-server php-mysql libapache2-mod-php



Better instructions: https://wiki.zoneminder.com/Ubuntu_Serv ... der_1.36.x

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests