update to 1.34 coming from 1.29

Forum for questions and support relating to the 1.34.x releases only.
Post Reply
e-gund
Posts: 2
Joined: Thu Apr 08, 2021 11:02 am

update to 1.34 coming from 1.29

Post by e-gund » Thu Apr 08, 2021 11:08 am

I´m running Debian Buster with ZM 1.29 and would like to update to 1.34. The Wiki means i should look into the Forum for further information. But i could not find anything specialy for my update. In general, is it good idea to do a straight update to 1.34? Is there anything I should know before, something special to take care for?

Thank you.

bbunge
Posts: 2735
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: update to 1.34 coming from 1.29

Post by bbunge » Thu Apr 08, 2021 2:31 pm

Would be a good idea to take a dump (backup) of the zm database before doing the backup.

This should work for upgrade:

Edit the sources.list
sudo nano /etc/apt/sources.list

Remove any old entries to the Zoneminder packages
Add the following line to the end of the file

deb https://zmrepo.zoneminder.com/debian/release-1.34 buster/

CTRL+o then [Enter] to save

CTRL+x to exit

Install the following and retrieve the key from the repro

sudo apt install apt-transport-https gnupg

wget -O - https://zmrepo.zoneminder.com/debian/ar ... eyring.gpg | sudo apt-key add -

Important - Make sure the above "wget" process completes without error! If it does not complete you will not get the most recent Zoneminder version this procedure is written for.

sudo apt update

sudo apt upgrade

Should do it!

e-gund
Posts: 2
Joined: Thu Apr 08, 2021 11:02 am

Re: update to 1.34 coming from 1.29

Post by e-gund » Thu Apr 08, 2021 5:27 pm

i finaly got it running. But i run in some issues. For reference here is what i had to do:

I got the error

Code: Select all

Database successfully upgraded to version 1.31.18.
Upgrading DB to 1.31.19 from 1.29.0
ERROR 1419 (HY000) at line 21: You do not have the SUPER privilege and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable)
to solve this i had to

Code: Select all

mysql -u USERNAME -p
set global log_bin_trust_function_creators=1;
exit
and run the updater again with

Code: Select all

zmupdate.pl
now the updater ran thought the complete process and i could login in the webinterface. unfortunately all symbols where missing and the layout was not as it should. I found out there was a symlink missing at

Code: Select all

/usr/share/zoneminder/www/cache
pointing to

Code: Select all

/var/cache/zoneminder/cache
After creating a symlink i had to restart apache with

Code: Select all

 /etc/init.d/apache2 restart
and it worked.

thank you.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests