Ubuntu Install for 1.34.x

Forum for questions and support relating to the 1.34.x releases only.
bbunge
Posts: 2727
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu Install for 1.34.x

Post by bbunge » Sat Mar 28, 2020 7:24 pm

Start with a fresh Bionic install. I use the minimal install image also known as the Network Installer:
https://ubuntu.com/download/alternative-downloads
I use a very minimal install. When tasksel comes up choose only the OpenSSH server.
When you restart the system adding net-tools may be a good idea. From there I use putty in a WIndows PC or the terminal in Mac or Linux to finish installing Zoneminder.

First install LAMP:
sudo apt install apache2 mariadb-server php libapache2-mod-php php-mysql

When that completes secure Mariadb:
sudo mysql_secure_installation

I use the same password that I used installing Ubuntu. Easier to remember...

Use the shell script from the WIKI to install Zoneminder:
https://wiki.zoneminder.com/Ubuntu_Serv ... ell_script
Or you can run the commands from the script one line at a time.

Avoid making any other changes before you get Zoneminder working!

mrd
Posts: 255
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Re: Ubuntu Install for 1.34.x

Post by mrd » Sun Mar 29, 2020 2:37 am

That worked perfectly! Thanks for the replies and help. I'll be back as soon as I hit the next mistake I make!
MRD

Luv2ZM
Posts: 2
Joined: Wed Jun 10, 2020 2:54 am

Re: Ubuntu Install for 1.34.x

Post by Luv2ZM » Wed Jun 10, 2020 3:16 am

Sigge wrote:
Sat Jan 18, 2020 1:42 pm
On Ubuntu Server 18.04 and Zoneminder 1.32.3.

Did:
sudo add-apt-repository ppa:iconnor/zoneminder-1.34
sudo apt-get update && sudo apt-get full-upgrade
sudo add-apt-repository --remove ppa:iconnor/zoneminder-1.32

and all worked fine!

Thanks!
I ran into a problem upgrading from 1.32.3 to 1.34.16:

Versions:
Ubuntu:
Ubuntu 18.04.4 LTS

mysql:
mysql Ver 14.14 Distrib 5.7.30, for Linux (x86_64) using EditLine wrapper

Apache:
Server version: Apache/2.4.29 (Ubuntu)
Server built: 2020-03-13T12:26:16

php:
PHP 7.2.24-0ubuntu0.18.04.6 (cli) (built: May 26 2020 13:09:11) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.2.24-0ubuntu0.18.04.6, Copyright (c) 1999-2018, by Zend Technologies

apt upgrade console output snippet for ZM:

Code: Select all

Setting up zoneminder (1.34.16-bionic1) ...
Installing new version of config file /etc/apache2/conf-available/zoneminder.conf ...
Installing new version of config file /etc/logrotate.d/zoneminder ...
Installing new version of config file /etc/zm/conf.d/01-system-paths.conf ...
Detected db service is mysql.service
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)'
Creating zm db
ERROR 1045 (28000): Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)
Error creating db.
dpkg: error processing package zoneminder (--configure):
 installed zoneminder package post-installation script subprocess returned error exit status 1
ZM Run State was stopped while doing this. It would not start.

Solution was obvious when looking at the log, it said the database was still at 1.32.3 and gave the command to upgrade it:

Code: Select all

sudo zmupdate.pl
This successfully upgraded the database

Code: Select all

Database upgrade to version 1.34.16 successful.
and automatically started ZM back up.

Thanks, developers, for providing the hint in the log! :D

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests