Montage Review FPS

Forum for questions and support relating to 1.33.x development only.
Post Reply
timelyfiasco
Posts: 12
Joined: Sun Jul 30, 2017 5:22 am

Montage Review FPS

Post by timelyfiasco » Fri Dec 20, 2019 7:49 am

What is your average montage review fps? Is having 1fps normal?
I get 5fps from live view. When I switch to montage review I get around 2fps and it gets lower when I click history.
Playback from individual videos is max at 5fps.

bbunge
Posts: 2684
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Montage Review FPS

Post by bbunge » Tue Dec 24, 2019 2:37 pm

Normal is a relative term. I checked Montage on a 17 cam ZM 1.33.15. Most cams are set to 5 FPS and pretty much show close to 5 FPS on Montage. Cams in dark areas show less and one newly replaced cam show 10 FPS (I forgot to change it to 5 FPS). This is running on an i7 with 16 GB RAM and dual hard drives (one for OS and database the other for video storage). As they say your results may vary...

Happy Holidays!

dougmccrary
Posts: 60
Joined: Sat Aug 31, 2019 7:35 am

Re: Montage Review FPS

Post by dougmccrary » Sat Dec 28, 2019 3:59 am

Are you using multi-port? How many cams? What browser?

CountyLine
Posts: 63
Joined: Thu Aug 29, 2019 5:22 pm
Location: USA

Re: Montage Review FPS

Post by CountyLine » Sat Dec 28, 2019 4:41 pm

Montage Review seems slow for some reason.

On Montage Review mine fluctuates between 0.9 and 1.3 fps. On Montage, I get 5 fps. Live view is 5 fps.

Server is an i5 with 8 gig of ram and six cameras. Five 1920x1080 and one 1280x720. All cameras are set internally to 5 fps. All readings taken using Firefox on a Linux client.

I noticed that the client browser choice can make a huge difference on the load imposed on the server in Montage Review mode. I'm not sure why that is. Montage Review seems to place a higher load on the server than the other modes. I presume that is because of the way the video compression is done in Montage Review mode.

dougmccrary
Posts: 60
Joined: Sat Aug 31, 2019 7:35 am

Re: Montage Review FPS

Post by dougmccrary » Sun Dec 29, 2019 1:46 am

"I presume that is because of the way the video compression is done in Montage Review mode."

Or maybe to keep it from being too big a speed change when you're doing playback, what with (non ssd) disk access and all.

Maybe one of the developers will shed some light.... :roll:

User avatar
iconnor
Posts: 1255
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Montage Review FPS

Post by iconnor » Tue Dec 31, 2019 2:22 am

montage asks for an mjpeg stream from zms. So it just streams as fast as it can.
montage review asks for the image at such and such a time. Then it asks for the next one. The latency/turn around time to spawn zms, have it seek in the video storage, find the frame and spit it out is horrendous. Needs to be rewritten, probably with websockets and other cool tech.

dougmccrary
Posts: 60
Joined: Sat Aug 31, 2019 7:35 am

Re: Montage Review FPS

Post by dougmccrary » Tue Dec 31, 2019 7:23 am

And that's so the images stay in sync. Or rather don't get out of sync.
Thanks for the explanation, Isaac.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest