See no video in the monitor

Forum for questions and support relating to 1.33.x development only.
WernerS
Posts: 14
Joined: Tue Jul 23, 2019 6:27 am

See no video in the monitor

Post by WernerS » Thu Oct 10, 2019 5:33 pm

Hello


i have installed Zoneminder 1.33.14 on a Rapberyy Pie 4 with 4GB RAM.
I work with a 5MP PTZ Outdoor Camera. For the Test i use 650x40 pixel resolution with h264 codec.
In ther Monitor i see no video. I the Options i have h264 passthrough enabled.
I the Logfile i see these Errors but when i google i find no answer for this Issue.

2019-10-09 18:09:40.698202 zmc_m2 1751 INF Failed to capture image from monitor 2 IPD-D53Y0701 (1/1) zmc.cpp 317
2019-10-09 18:09:40.688023 zmc_m2 1751 INF Return from Capture (-1), signal loss zm_monitor.cpp 2453
2019-10-09 18:09:40.678189 zmc_m2 1751 ERR Failed to transfer from frame to image zm_ffmpeg_camera.cpp 998
2019-10-09 18:09:40.625733 zmc_m2 1751 ERR Unable to convert format 0 yuv420p to format 3038098204 (null) at frame 0 codec 3038098212 zm_ffmpeg_camera.cpp 1110
2019-10-09 18:09:40.616734 zmc_m2 1751 WAR Unable to receive frame 0: Resource temporarily unavailable. error count is 0 zm_ffmpeg_camera.cpp 958
2019-10-09 18:09:40.607680 zmc_m2 1751 ERR Unable to send packet Resource temporarily unavailable, continuing zm_ffmpeg.cpp 551
2019-10-09 18:09:40.583639 zmc_m2 1751 WAR Unable to receive frame 0: Resource temporarily unavailable. error count is 0 zm_ffmpeg_camera.cpp 958
2019-10-09 18:09:40.574787 zmc_m2 1751 ERR Unable to send packet Resource temporarily unavailable, continuing zm_ffmpeg.cpp 551
2019-10-09 18:09:40.564826 zmc_m2 1751 WAR Unable to receive frame 0: Resource temporarily unavailable. error count is 0 zm_ffmpeg_camera.cpp 958
2019-10-09 18:09:40.555762 zmc_m2 1751 ERR Unable to send packet Resource temporarily unavailable, continuing zm_ffmpeg.cpp 551
2019-10-09 18:09:40.502151 zmc_m2 1751 WAR Unable to receive frame 0: Resource temporarily unavailable. error count is 0 zm_ffmpeg_camera.cpp 958
2019-10-09 18:09:40.493098 zmc_m2 1751 ERR Unable to send packet Resource temporarily unavailable, continuing zm_ffmpeg.cpp 551
2019-10-09 18:09:40.483471 zmc_m2 1751 WAR Unable to receive frame 0: Resource temporarily unavailable. error count is 0 zm_ffmpeg_camera.cpp 958
2019-10-09 18:09:40.473213 zmc_m2 1751 ERR Unable to send packet Resource temporarily unavailable, continuing zm_ffmpeg.cpp 551
2019-10-09 18:09:40.463398 zmc_m2 1751 WAR Unable to receive frame 0: Resource temporarily unavailable. error count is 0 zm_ffmpeg_camera.cpp 958
2019-10-09 18:09:40.451955 zmc_m2 1751 ERR Unable to send packet Resource temporarily unavailable, continuing zm_ffmpeg.cpp 551
2019-10-09 18:09:40.441955 zmc_m2 1751 WAR Unable to receive frame 0: Resource temporarily unavailable. error count is 0 zm_ffmpeg_camera.cpp 958
2019-10-09 18:09:40.387660 zmc_m2 1751 ERR Unable to send packet Resource temporarily unavailable, continuing zm_ffmpeg.cpp 551
2019-10-09 18:09:40.377722 zmc_m2 1751 WAR Unable to receive frame 0: Resource temporarily unavailable. error count is 0 zm_ffmpeg_camera.cpp 958
2019-10-09 18:09:40.367903 zmc_m2 1751 ERR Unable to send packet Resource temporarily unavailable, continuing zm_ffmpeg.cpp 551
2019-10-09 18:09:38.179549 zmc_m2 1751 INF Priming capture from rtsp://user:passwort@xxx.xxx.xxx.xxx:554/1/h264minor

Who can help me?

Best Regards
Werner

bbunge
Posts: 2698
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: See no video in the monitor

Post by bbunge » Sat Oct 12, 2019 2:21 am

Check your camera resolution with VLC. Get the cam to work on VLC it will work on ZM. Just remember even the Pi4 has limited memory and hi res cams can kill the tmpfs. Also recommend Ubuntu server on the Pi. Have seen an image is available for the Pi4. Search this forum section for Pi suggestions.

Carteer
Posts: 1
Joined: Sat Oct 12, 2019 9:00 am

Re: See no video in the monitor

Post by Carteer » Mon Oct 14, 2019 11:30 am

How high of a resolution is it too high and it starts creating problems?

WernerS
Posts: 14
Joined: Tue Jul 23, 2019 6:27 am

Re: See no video in the monitor

Post by WernerS » Mon Oct 14, 2019 3:16 pm

My Raspberry 4 has 4GB RAM. df -h show 2GB RAM shm and zoneminder show 4% used shm at a resolution of 640 x 480 pixel
in VLC i get a video from 640 x 480 up to 2592 x 1944. But in zoneminder i see no video
With my old Raspberry 3B and 1 GB and Zoneminder 1.2x.xx i get a video in the monitor

WernerS
Posts: 14
Joined: Tue Jul 23, 2019 6:27 am

Re: See no video in the monitor

Post by WernerS » Wed Oct 16, 2019 3:04 pm

no one has any idea? What should i do now?

rockedge
Posts: 1154
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: See no video in the monitor

Post by rockedge » Thu Oct 17, 2019 6:33 pm

can you open the camera stream in VLC with the URL you are using for the camera in zoneminder?
Try to open the stream in VLC and in Tools you can get the codec information, there you will see the true resolution that the camera is streaming.

Lets see if we can get a stream at all in VLC and then go from there.

WernerS
Posts: 14
Joined: Tue Jul 23, 2019 6:27 am

Re: See no video in the monitor

Post by WernerS » Fri Oct 18, 2019 3:48 pm

Yes in VLC i can see both Streams. There is a major (big resolution) and a minor (slow resolution)
For testimng i use the minor
In Zoneminder 1.30.4 on a Raspberry 3B the camera works.

In the Picture is the Codec Data of VLC.
18-10-2019 17-47-20.jpg
18-10-2019 17-47-20.jpg (38.67 KiB) Viewed 2909 times

rockedge
Posts: 1154
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: See no video in the monitor

Post by rockedge » Fri Oct 18, 2019 4:23 pm

Guten Tag WernerS,

In zoneminder it is extremely important that the camera resolution is exact or you will not see a stream

make sure the values match between what VLC is reporting and what is defined in the monitor setup in ZM.

also can you try to use the Libvlc instead of ffmpeg in the Source Type....I just had a problem with no streams with ffmpeg but worked fine with Libvlc. Just to test it out could you try it out? I had this behavior in the very latest zoneminder-master 1.33.14.

Erik

WernerS
Posts: 14
Joined: Tue Jul 23, 2019 6:27 am

Re: See no video in the monitor

Post by WernerS » Sat Oct 19, 2019 7:40 am

Hello Erik

in zoneminder i have the exact resolution of the Stream

I try testing libvlc, but it also dont work

Best Reagrds
Werner

rockedge
Posts: 1154
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: See no video in the monitor

Post by rockedge » Sat Oct 19, 2019 6:22 pm

Hallo Werner,

can you reach the /cgi-bin with a URL in a browser? For example http://localhost/zm/cgi-bin or http://localhost/cgi-bin

checking if the correct Apache configuration is enabled to define the correct path to the /cgi-bin

can you try in a terminal:

Code: Select all

zmc --m 2
are there errors? Can you see any image when clicking on Zone configuration of monitor 2?

WernerS
Posts: 14
Joined: Tue Jul 23, 2019 6:27 am

Re: See no video in the monitor

Post by WernerS » Sun Oct 20, 2019 5:54 pm

Hello Rockedge

For example http://192.168.178.52/zm/cgi-bin i get.
Forbidden
You don't have permission to access /zm/cgi-bin/ on this server.
Apache/2.4.38 (Raspbian) Server at 192.168.178.52 Port 80

same on http://localhost/cgi-bin

for zmc --m 2, i get
no output in the terminal
same when i take sudo

Can you see any image when clicking on Zone configuration of monitor 2?
What do you mean with monitor 2?

Best Reagrds
Werner

rockedge
Posts: 1154
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: See no video in the monitor

Post by rockedge » Mon Oct 21, 2019 1:52 am

Hello Werner,

I am referring to clicking on the monitor's Zone configuration window. By clicking the digit "1" under "Zones" in the ZM web concole.
just to check if any image is being created.

Image

I never asked if you are seeing any FPS speeds or just a red dot all the time?

Erik

WernerS
Posts: 14
Joined: Tue Jul 23, 2019 6:27 am

Re: See no video in the monitor

Post by WernerS » Mon Oct 21, 2019 2:36 pm

Hello Erik

now i understand what you mean. Sorry :-)

in the zoneconfigurationwindow i have no Picture from the Camera
In the Console i see no FPS speed and have always a red point.

Yesterday i get my older Raspberry 3B with the old Version of Zonemoinder. There it works fine.

Best Reagrds
Werner

WernerS
Posts: 14
Joined: Tue Jul 23, 2019 6:27 am

Re: See no video in the monitor

Post by WernerS » Fri Oct 25, 2019 12:58 pm

No one has an idea? What shall i do now with my Raspberry Pi 4?

bodgit
Posts: 7
Joined: Sat Sep 28, 2019 12:38 pm
Location: St Lucia West Indies

Re: See no video in the monitor

Post by bodgit » Fri Oct 25, 2019 7:20 pm

I also had all sorts of problems with a raspberry pi 4, raspian and zoneminder, I have now installed ubuntu 18.04 from here https://jamesachambers.com/raspberry-pi ... nofficial/
and following this
https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way
just changing the repo to master to get 1.33.14 and have 6 cameras running without any problems 4 x Wzye V2 using RSTP and 2 x Trendnet TV751.

The Ubuntu image seems to me to be faster and more stable than raspian and zoneminder definitely runs perfectly on my raspberry pi 4/4.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests