AH01630: client denied by server configuration: /var/www/localhost/cgi-bin,

Forum for questions and support relating to 1.33.x development only.
Post Reply
undrwater
Posts: 13
Joined: Thu Apr 07, 2016 4:17 am

AH01630: client denied by server configuration: /var/www/localhost/cgi-bin,

Post by undrwater » Thu Jan 10, 2019 12:20 am

Getting apache errors as above. Problem is; the cgi-bin is not in:

Code: Select all

/var/www/localhost
I cannot find a config file where the above is listed; including apache.conf, 10_zoneminder.conf (in vhosts), or /etc/zm.conf.

I'm running Gentoo and I don't have an /etc/zm/ directory.

I'm sure it's an easy solution, but I can't find where to point apache to /usr/share/zoneminder/www

rockedge
Posts: 1061
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: AH01630: client denied by server configuration: /var/www/localhost/cgi-bin,

Post by rockedge » Thu Jan 10, 2019 3:41 pm

the /cgi-bin will not be located in the web root of zoneminder. I am unfamiliar with the Gentoo set up but I will look at it and maybe I can give you a pointer. you must find the location of the the /cgi-bin/nph-zms and /cgi-bin/zms. Then find out where the configuration files are for zoneminder. this is a start to be able to get this going for you.

undrwater
Posts: 13
Joined: Thu Apr 07, 2016 4:17 am

Re: AH01630: client denied by server configuration: /var/www/localhost/cgi-bin,

Post by undrwater » Thu Jan 10, 2019 10:01 pm

Thanks for the reply!

Both are in:

Code: Select all

/usr/libexec/zoneminder/cgi-bin
Here's 10_zoneminder.conf. Maybe there's something wrong in there?

Code: Select all

    Alias /zm/cache "/var/cache/zoneminder"
 <Directory "/var/cache/zoneminder">
        Options -Indexes +FollowSymLinks
        Require all granted
        AllowOverride None
        <IfModule mod_authz_core.c>
           # Apache 2.4
           Require all granted
        </IfModule>
        <IfModule !mod_authz_core.c>
            # Apache 2.2
            Order deny,allow
            Allow from all
        </IfModule>
    </Directory>

ScriptAlias /zm/cgi-bin/ "/usr/libexec/zoneminder/cgi-bin/"

<Directory "/usr/libexec/zoneminder/cgi-bin">
  AllowOverride All
  Options +ExecCGI
  Require all granted
</Directory>

Alias /zm "/usr/share/zoneminder/www"

<Directory "/usr/share/zoneminder/www">
  Options -Indexes +MultiViews +FollowSymLinks
  AllowOverride All
  Require all granted
</Directory>

<Directory "/usr/share/zoneminder/www/api">
       RewriteEngine on
       RewriteRule ^$ app/webroot/ [L]
       RewriteRule (.*) app/webroot/$1 [L]
       RewriteBase /zm/api
    </Directory>

    <Directory "/usr/share/zoneminder/www/api/app">
       RewriteEngine on
       RewriteRule ^$ webroot/ [L]
       RewriteRule (.*) webroot/$1 [L]
       RewriteBase /zm/api
    </Directory>

    <Directory "/usr/share/zoneminder/www/api/app/webroot">
        RewriteEngine On
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule ^ index.php [L]
        RewriteBase /zm/api
    </Directory>
And /etc/zm.conf (you'll note I added the ZM_PATH_ZMS in there):

Code: Select all

# Path to installed data directory, used mostly for finding DB upgrade scripts
ZM_PATH_DATA=/usr/share/zoneminder

# Path to ZoneMinder binaries
ZM_PATH_BIN=/usr/bin

# Path to ZoneMinder libraries (none at present, for future use)
ZM_PATH_LIB=/usr/lib64

# Path to ZoneMinder configuration (this file only at present)
ZM_PATH_CONF=/etc

# Path to ZoneMinder web files
ZM_PATH_WEB=/usr/share/zoneminder/www

# Path to ZoneMinder cgi files
ZM_PATH_CGI=/usr/libexec/zoneminder/cgi-bin

# /cgi-bin path 
ZM_PATH_ZMS=/zm/cgi-bin/nph-zms

# Username and group that web daemon (httpd/apache) runs as
ZM_WEB_USER=apache
ZM_WEB_GROUP=apache

# ZoneMinder database type: so far only mysql is supported
ZM_DB_TYPE=mysql

# ZoneMinder database hostname or ip address and optionally port or unix socket
# Acceptable formats include hostname[:port], ip_address[:port], or localhost:unix_socket
ZM_DB_HOST=localhost

# ZoneMinder database name
ZM_DB_NAME=zm

# ZoneMinder database user
ZM_DB_USER=zmuser

# ZoneMinder database password
ZM_DB_PASS=zmpass

# SSL CA certificate for ZoneMinder database
ZM_DB_SSL_CA_CERT=

# SSL client key for ZoneMinder database
ZM_DB_SSL_CLIENT_KEY=

# SSL client cert for ZoneMinder database
ZM_DB_SSL_CLIENT_CERT=

# Do NOT set ZM_SERVER_HOST if you are not using Multi-Server
# You have been warned
#
# The name specified here must have a corresponding entry
# in the Servers tab under Options
ZM_SERVER_HOST=

rockedge
Posts: 1061
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: AH01630: client denied by server configuration: /var/www/localhost/cgi-bin,

Post by rockedge » Thu Jan 10, 2019 11:57 pm

Good start!
the config files looks okay...check to make sure that cgi is enabled in Apache and that the zoneminder.conf is also enabled and has a symlink in /etc/apache2/conf-enabled
make sure all the directories for zoneminder and files like /etc/zm.conf have the correct ownership that match the Apache user name and permissions.

undrwater
Posts: 13
Joined: Thu Apr 07, 2016 4:17 am

Re: AH01630: client denied by server configuration: /var/www/localhost/cgi-bin,

Post by undrwater » Fri Jan 11, 2019 8:43 pm

OK...need to step back a bit...
the reason for looking into that error was because the cameras were not displaying on the console or montage, and the page would refresh furiously. I assumed (I know, I know...) that resolving the error would resolve the problems with camera and refresh, but it didn't.

Now the errors have stopped (which is good), but I still can't see the cameras, and the page refreshes. I CAN see the cameras on zmninja though, so api is working.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest