Setup/Configuration Issue - Live View Localhost, not on others

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
FloppyDisk
Posts: 9
Joined: Sat Feb 06, 2016 1:41 am

Setup/Configuration Issue - Live View Localhost, not on others

Post by FloppyDisk » Wed Dec 11, 2019 7:15 am

I am trying to finish configuring Zoneminder 1.32.3 on 18.04 Xubuntu, which seems to be a butchered upgrade from zoneminder 1.28 & 14.04 Xubuntu. I included more detailed notes about the INSTALLATION HISTORY further below. After I setup my 2 monitors, I needed to add a server because there wasn’t one in the Options - Servers.

Is this normal on setup to add the server or should there have been a default server when first installing Zoneminder 1.32.3?
server setup.PNG
server setup.PNG (13.46 KiB) Viewed 1001 times
It seemed like I had an issue at the end of the easy installation when the instructions said to change Options - Path: PATH_ZMS is set to /zm/cgi-bin/nph-zms
I couldn’t find that until I added a server and found it. Once I added the ‘/zm’ to the string then I had LIVE streaming in Montage Review.

I also checked in the ‘hints’ the ScriptAlias /zm/cgi-bin "/usr/lib/zoneminder/cgi-bin" in the /etc/apache2/conf-enabled/zoneminder.conf file and it looked to be correct.

The 2nd issue is I cannot see live streaming video from a different computer on my home LAN pointing to the local machine with a browser pointed to http://192.168.0.117/zm/index.php. I can see live streaming video from the local machine when using localhost/zm. I can also change options from the remote computer.
camera offline remote pc.PNG
camera offline remote pc.PNG (61.09 KiB) Viewed 1001 times
Events appears to be working - I have both cameras setup as Modect. I can select history in Montage Review and move my cursor to an event and view it. This works from a remote computer.

A WARNING? I also have this:
WAR http://192.168.0.117 is not found in the servers list /usr/share/zoneminder/www/Includes/functions.php 63. This warning came when I viewed the LOG from the remote computer. If I close the log window in the remote computer, then it goes away.

PC BASICS
My PC is an older compact HP-7800p w/ a duo core 2 at 2.33Ghz and 4 Gb Ram. The harddrive is about 2.68 TB.

CAMERA SETUP
Qty 2 hikvision cameras. I did the memory calcs in the wiki and using about .43Gb of Ram for the 2 cameras. Since I have live streaming and can see history, they seem to be setup adequately enough. I verified width/height in monitor setup to the cameras, etc.

INSTALLATION HISTORY NOTES
In March of 2016, I installed 1.28 zoneminder on 14.04 Xubuntu with 2 Hikvision cameras. I recall seeing camera video output, but not sure if the video was visible in zoneminder (I think so) and the project sat on a desk (ugh!) until December 2019. Since versions of Ubuntu and Zoneminder have changed I upgraded to 18.04 Xubuntu and then followed the easy installation of zoneminder to 1.32. I didn’t do an ‘upgrade’ and when I tried to setup zoneminder, that installation had the same ERR Invalid skin css ‘flat’ error and another warning:
4471 WAR Cannot write to content dirs('/var/cache/zoneminder/events','/var/cache/zoneminder/images'). Check that these exist and are owned by the web account user /usr/share/zoneminder/www/index.php 169

I decided that my install ‘wasn’t done right’ and wanted to wipe the install and try again so I did remove, purge, autoremove steps for Zoneminder, Apache2, and mysql.
Zoneminder viewtopic.php?t=26129
Apache https://askubuntu.com/questions/176964/ ... ng-apache2
Mysql Run service stop first. https://oofloo.com/uninstall-mysql-ubuntu/

When I did the purging and then the easy installation of zoneminder, I ran into a javascript-common issue w/ dpkg, that prevented the zoneminder from installing. I was able to solve that and zoneminder finally installed.

One thing that is confusing (seems not right) is that my password for mySQL is the same password I had when I did the 1.28 Zoneminder on Xubuntu 14.04. I thought my remove/purge steps would have started over, but I guess not.

References:
live veiw YES on localhost, NO on others
viewtopic.php?t=25749
Options - Servers
https://zoneminder.readthedocs.io/en/st ... rvers.html

ERR Disappeared??
In my LOG, I was getting an ERR Invalid skin css ‘flat’ setting to base /usr/share/zoneminder/www/index.php 107. It's not there any longer - it just went away (yah, I guess).

I tried the solution here with no success:
viewtopic.php?f=37&t=27422
The first problem is that the zmcustom.conf file referred to isn’t in the/etc/conf.d/zmcustom.conf folder but in the /etc/zm/conf.d/zmcustom.conf folder. The 2nd problem is that when I finally found the file located it was already changed to the correct path (ZM_PATH_ZMS=/cgi-bin/nph-zms). I did change it to /zm/cgi-gin/nph-zms and it didn’t seem to change anything so changing it back to /cgi-gin/nph-zms.

IncompleteString
Posts: 33
Joined: Wed May 01, 2019 11:57 pm

Re: Setup/Configuration Issue - Live View Localhost, not on others

Post by IncompleteString » Wed Dec 11, 2019 12:05 pm

The documentation for Zoneminder 1.32.3 says to use the 16.04 version of Ubuntu / Xbuntu, I know some people have gotten 18.04 to work, but I think its a use at your own risk type of thing.

Do you have a 2nd zone minder server? is that why you added another server in the servers tab? I'm pretty sure you only use the servers tab if you are doing a multi server install. If you are doing a standalone install of Zoneminder, the servers tab should be empty.

Did you remeber to do the following when installing?

Code: Select all

sudo chmod 740 /etc/zm/zm.conf
sudo chown root:www-data /etc/zm/zm.conf
sudo chown -R www-data:www-data /usr/share/zoneminder/
As for the video not displaying on another computer, check your firewall.

Code: Select all

sudo ufw stauts
if the UFW is enabled you need to allow out the correct ports for the video.

User avatar
iconnor
Posts: 1246
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Setup/Configuration Issue - Live View Localhost, not on others

Post by iconnor » Wed Dec 11, 2019 12:14 pm

You only need to setup multi-server if you have multiple servers.

When you entered a server for localhost, you told it to generate all video urls using localhost as the address, You need to change that to be the ip that you will always access the server at.

FloppyDisk
Posts: 9
Joined: Sat Feb 06, 2016 1:41 am

Re: Setup/Configuration Issue - Live View Localhost, not on others

Post by FloppyDisk » Wed Dec 11, 2019 3:44 pm

@iconner and and @IncompleteString - Thank you for the replies!

I definitely do NOT want another server and will take @incompleteString's advice that the server tab should be empty.
IncompleteString wrote:
Wed Dec 11, 2019 12:05 pm
The documentation for Zoneminder 1.32.3 says to use the 16.04 version of Ubuntu / Xbuntu, I know some people have gotten 18.04 to work, but I think its a use at your own risk type of thing.
Well shoot!! I missed that. I want EASY! I'll try to get what I have working, but not opposed to going back to 16.04.

BTW - I definitely did the change file access from this part:

Code: Select all

sudo chmod 740 /etc/zm/zm.conf
etc..
As for the video not displaying on another computer, check your firewall. Thanks for this tip - will check it.

Code: Select all

sudo ufw stauts
if the UFW is enabled you need to allow out the correct ports for the video.

Also, when I logged into the local machine late last night to shut it down, I did get the ERR Invalid skin css ‘flat’ setting to base.
log shot.PNG
log shot.PNG (58.67 KiB) Viewed 985 times
Anyway - I think this has to do w/ my server in the tab and will try to figure it out tonight.

Thanks again for the replies.
Mark

User avatar
snake
Posts: 334
Joined: Sat May 21, 2016 2:20 am

Re: Setup/Configuration Issue - Live View Localhost, not on others

Post by snake » Wed Dec 11, 2019 6:47 pm

18.04 install guides are in the wiki, and it should work. I haven't heard any talk that 18.04 is unstable.

19.10 and newer is the ones that may require some work at the moment. Some libraries are being changed, so this is a bit more at your own risk (mysql 8 is deprecating the password hash function, but you can use mariadb, and maybe one other library issue).

FloppyDisk
Posts: 9
Joined: Sat Feb 06, 2016 1:41 am

Re: Setup/Configuration Issue - Live View Localhost, not on others

Post by FloppyDisk » Fri Dec 13, 2019 2:09 am

I realized that I didn't have the ability to change the path in the options w/ 1.32.3 and found this post: viewtopic.php?t=27722 ZM 1.32.2 - cannot find Path options.

Per the post, I modified the zmcustom.conf file in /etc/zm/conf.d and added a '/zm' to the string and now I have streaming video in the montage review and individual cameras and can see video from 2 other PC's on my home LAN - SCHWEEET!!!!

Also, my css error I was getting has gone away.

Thanks again everyone for your help! Really appreciate it. I have a 18.04 Xubuntu machine running zoneminder 1.32.3. I'm not experienced enough to know if I have any other issues, but it seems to be working well at this point :-)

Thanks everyone for your help!
Mark

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest