Page 1 of 1

High CPU usage

Posted: Fri Jun 14, 2019 7:46 am
by chopsuey
Hey guys,

I had a search around but no-one seems to be having this issue, so hopefully you guys can help...

I'm running ZoneMinder 1.32.3 vis Docker
I have installed ZoneMinder through an unRAID docker, but have capped the cpu usage to 2 cores (it went to 100% on all cores and brought down my server when I had all camera's added, so now its got 1 core and 1 hyperthread)

The only way I can get the CPU usage to go down (even just a little) is to lower the FPS, which makes sense but at lower fps like 2/5/10 the image is considerably laggy, like the seconds on the screen are more like 4 seconds

Maybe I just need to get the ideal settings - also is there a way to set it to passthrough instead of converting my stream, I assume this is the bulk of the CPU usage

The stream resolution is 5MP at 2560x1920 - changing this seems to make things worse, eg changing res manually in the settings to 720p

Here is a pastebin of some of the log
https://pastebin.com/sjWyqXq0

as you can see it errors alot at 10fps but is quite good at 20fps, but still my cpu is getting destroyed
at the moment, 2x camera's at 10fps native res has 2 cores at 50%, 20fps has two cores at 100%

Settings for my setup is attached

Any idea's - I dont want my cpu to burn just so I can monitor my camera's every now and again - I have a nvr to record, but the SwannSecurity plus app is fucking aids, hence why setting up ZM

Re: High CPU usage

Posted: Fri Jun 14, 2019 4:13 pm
by snake
For general high CPU usage tweaks see
viewtopic.php?f=11&t=28292

For your setup, using Passthrough and not recording any JPEG frames will be the most efficient.

You can't set max FPS on ZM for FFMPEG, only on camera. Delete that entry, then set FPS on camera to 5 or 10.

Re: High CPU usage

Posted: Sat Jun 15, 2019 12:09 am
by chopsuey
Hey mate, thanks for the info
snake wrote:
Fri Jun 14, 2019 4:13 pm
For general high CPU usage tweaks see
viewtopic.php?f=11&t=28292

For your setup, using Passthrough and not recording any JPEG frames will be the most efficient.

You can't set max FPS on ZM for FFMPEG, only on camera. Delete that entry, then set FPS on camera to 5 or 10.
I do have a question though
How do I set the stream to be pass-through, its set to monitor so it shouldn't be recording any frames to jpeg?

from what ive read, its not possible? viewtopic.php?t=27436 - looks like this topic is also similar to my issue