Distroted video over time - RESOLVED

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
tapstah
Posts: 5
Joined: Tue Jun 04, 2019 7:42 pm

Distroted video over time - RESOLVED

Post by tapstah » Wed Jun 05, 2019 1:16 pm

Okay. I believe I have gone through all of the online docs with no luck, and I searched the forum but didn't find something precisely inline.

Zoneminder 1.32.3
os: Ubuntu 18.04.2
Camera: Hosafe H2MD4A

Screen shots included.

Having a persistent problem with just the hosafe cameras. I have other camera types that run fine, so it shouldn't be install specific, I don't think.

This camera works great, love the camera, plan on getting more but I need to sort out this issue first. When the camera has been running on mocord for longer than 15 hours it starts to get distorted, as in the image attached (see when running fine vs when not). It used to be this would happen within an hour, I changed the fps settings and the problem now takes several hours.

Any ideas where to start? Let me know if there is anything needed. Thanks in advance folks.
Screenshot_2019-06-05 ZM - Garage (2) - Feed.jpg
Screenshot_2019-06-05 ZM - Garage (2) - Feed.jpg (921.22 KiB) Viewed 597 times
Attachments
Screenshot_2019-06-05 ZM - Monitor - Garage (2)(1).png
Screenshot_2019-06-05 ZM - Monitor - Garage (2)(1).png (14.98 KiB) Viewed 597 times
Screenshot_2019-06-05 ZM - Garage (2) - Feed(1).jpg
Screenshot_2019-06-05 ZM - Garage (2) - Feed(1).jpg (380.41 KiB) Viewed 597 times
Last edited by tapstah on Mon Jun 17, 2019 1:25 pm, edited 1 time in total.

tapstah
Posts: 5
Joined: Tue Jun 04, 2019 7:42 pm

Re: Distroted video over time

Post by tapstah » Wed Jun 05, 2019 1:16 pm

more photos...
Attachments
Screenshot_2019-06-05 ZM - Monitor - Garage (2)(4).png
Screenshot_2019-06-05 ZM - Monitor - Garage (2)(4).png (10.62 KiB) Viewed 596 times
Screenshot_2019-06-05 ZM - Monitor - Garage (2)(3).png
Screenshot_2019-06-05 ZM - Monitor - Garage (2)(3).png (8.9 KiB) Viewed 596 times
Screenshot_2019-06-05 ZM - Monitor - Garage (2)(2).png
Screenshot_2019-06-05 ZM - Monitor - Garage (2)(2).png (12.74 KiB) Viewed 596 times

tapstah
Posts: 5
Joined: Tue Jun 04, 2019 7:42 pm

Re: Distroted video over time

Post by tapstah » Wed Jun 05, 2019 1:17 pm

more...
Attachments
Screenshot_2019-06-05 ZM - Monitor - Garage (2).png
Screenshot_2019-06-05 ZM - Monitor - Garage (2).png (19.89 KiB) Viewed 595 times
Screenshot_2019-06-05 ZM - Monitor - Garage (2)(5).png
Screenshot_2019-06-05 ZM - Monitor - Garage (2)(5).png (17.76 KiB) Viewed 595 times

kitkat
Posts: 60
Joined: Sun Jan 27, 2019 5:17 pm

Re: Distroted video over time

Post by kitkat » Wed Jun 05, 2019 10:53 pm

Have you tried using H.264 Passthrough as the Video Writer, instead of X.264 Encode?

tapstah
Posts: 5
Joined: Tue Jun 04, 2019 7:42 pm

Re: Distroted video over time

Post by tapstah » Thu Jun 06, 2019 12:47 pm

kitkat wrote:
Wed Jun 05, 2019 10:53 pm
Have you tried using H.264 Passthrough as the Video Writer, instead of X.264 Encode?
No, I haven't. Just switched the setting now. I'll report back how it performs!

User avatar
snake
Posts: 175
Joined: Sat May 21, 2016 2:20 am

Re: Distorted video over time

Post by snake » Thu Jun 06, 2019 7:31 pm

You shouldn't have Max FPS set on ZM for FFMPEG, generally. See the help icon next to it. Leave that blank.

If that doesn't solve it, search around these forums. Some people have had screen tearing and artifacts solved with a variety of solution such as:

Force TCP or UDP mode on camera.
Lower camera FPS (on camera not on ZM)
Increase key frame rate
Try libVLC instead of FFMPEG
Increase CAPTURES_PER_FRAME to 2 or 3
Lower resolution of camera

User avatar
iconnor
Posts: 739
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Distroted video over time

Post by iconnor » Tue Jun 11, 2019 9:51 pm

Double down on the no MaxFPS/AlarmMaxFPS. Those were needed for 1.30 but cause problems for 1.32. They starve ffmpeg for cpu.
You are already using TCP, so that's fine.
increasing key frame rate should cause it to correct faster
CAPTURES_PER_FRAME is not applicable to FFMPEG

I have seen this too on my crappy cameras, and I have resolved it, so do not despair. I think it is likely the MaxFPS/AlarmMaxFPS

There is a lot of great work in our master branch which may help. Feel free to upgrade to it. We are basically in feature freeze and just fixing bugs/updating docs before 1.34. it is safe to upgrade.

tapstah
Posts: 5
Joined: Tue Jun 04, 2019 7:42 pm

Re: Distroted video over time

Post by tapstah » Mon Jun 17, 2019 1:24 pm

All great replys. Sorry it took so long to reply - I was waiting to see if the issue was resolved. Kitkat's solution of x.264 Passthrough was the answer. I had already been tweaking with all of the other options for some time and it only made incremental improvements but the passthrough solved it. Thanks a ton!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests