Page 1 of 1

Vivotek PZ7111 Control

Posted: Wed Apr 10, 2019 1:02 am
by bertlj
I've been working on this issue for awhile. I have been running different versions of ZM for over 18 months on a couple of different VMware virtual machines. Currently on ZM 1.32.3 on Ubuntu Server 16.04 on an ESXi 6.7u2 virtual machine. I have encountered/solved lots of local problems over time... but not this one.

I have a mix of cameras, but I am not able to find a camera control *.pm that works for my 3 Vivotek PZ7111 cameras. As of this afternoon, I have tried every suggestion I could find on this forum and the wiki. That includes: AxisV2, DCS3415, Toshiba_IK_WB16A, Vivotek_ePTZ, VivotekPT3135, VivotekPT7135, VivotekPZ7131, VivotekPZ8111, VivotekSd7151, PelcoD (somewhere I read that worked), and others.

The best results I have seen on my PZ7111 so far was for absolutely nothing to happen. MOST of those profiles/control files threw errors at me with every click. The errors always took the form...

Control response was status = undefined
message = /usr/bin/ --autostop --
command=moveConDown --id=16=>

Please, what am I doing wrong? This seems simple enough in print, but I am getting nowhere VERY fast.

Thank you in advance to anyone who can move me forward on this quest.

Re: Vivotek PZ7111 Control

Posted: Wed Apr 10, 2019 6:54 pm
by rockedge
those errors being thrown means you are close to getting it going!

can you move the camera using command URL's in a browser?
Do any of the control scripts have the actual set of PTZ commands for this camera?

Re: Vivotek PZ7111 Control

Posted: Thu Apr 11, 2019 1:19 am
by bertlj
Rockedge -

Thank you for getting back! Sounds like good news.

Let me charge ahead with your suggestions so I can answer your questions.

Re: Vivotek PZ7111 Control

Posted: Thu Apr 11, 2019 3:43 am
by bertlj
Here is what I found and learned so far. Discovered a free app called Fiddler that may be of some help to me. With it I discovered the following...

I have never had much luck running the Vivotek viewer app on my Mac Pro or on Parallels/Win7. The control panel comes up, but no video. Turns out that may be enough. With the Vivotek viewer control panel and Fiddler running, I was able to capture the following information:

# Result Protocol Host URL Body Caching Content-Type Process Comments Custom
61 200 HTTP /cgi-bin/camctrl/camctrl.cgi?move=up 0 iexplore:3328
62 200 HTTP /cgi-bin/camctrl/camctrl.cgi?move=down 0 iexplore:3328
63 200 HTTP /cgi-bin/camctrl/camctrl.cgi?speedpan=-5 0 iexplore:3328
64 200 HTTP /cgi-bin/camctrl/camctrl.cgi?move=down 0 iexplore:3328
65 200 HTTP /cgi-bin/camctrl/camctrl.cgi?move=up 0 iexplore:3328
66 200 HTTP /cgi-bin/camctrl/camctrl.cgi?speedtilt=-5 0 iexplore:3328
67 200 HTTP /cgi-bin/camctrl/camctrl.cgi?move=down 0 iexplore:3328
Accept: text/html, application/xhtml+xml, */*
Accept-Language: en-US
User-Agent: Mozilla/5.0 (Windows NT 6.1; Trident/7.0; rv:11.0) like Gecko
Accept-Encoding: gzip, deflate
Connection: Keep-Alive
DNT: 1
Authorization: Basic cm9vdDpiam1hclQwMA==

...AND realized the camera was responding to the commands. So, do you think there is enough info here to be able to edit one of the *.pm scripts?

Re: Vivotek PZ7111 Control

Posted: Thu Apr 11, 2019 5:00 am
by bertlj
To further answer one of the questions asked, entering the URL below DOES move the camera:

Re: Vivotek PZ7111 Control

Posted: Fri Apr 19, 2019 3:33 pm
by security_dude
When I upgraded most of my ptz scripts broke because they made reference to relative movements not continuous movements. This zm version contains a bug and now only sends con movements regardless of what setting you check off under the cameras control section. What I had to do is edit my .pm scripts so that every movement command used con instead of rel in them. For example mine had sub moveRelUp for the up command but what I should of had was sub moveConUp. I am not sure if that is your problem but I thought I would mention it. I also took a look at the default script for you and it does look to be correct so if you use that script then you should be fine.
Another thing to check is your control setup, the control address syntax should look like this userID:password@serverIP:port The port is usually 80.
Remember in order for the changes to take affect you have to restart zm or the entire server.

Re: Vivotek PZ7111 Control

Posted: Sat Apr 20, 2019 5:01 am
by bertlj
Thanks for your input on this, however, it doesn't seem to resolve my issue. All of the example .pm files that I had tried (I tried most of them) utilized continuous rather than relative commands. I gave another try. I edited the sendCmd subroutine to adjust for my camera's command string (which looks like, but continue to receive error messages similar to this (this was move up)...

Control response was status = undefined
message = /usr/bin/ --autostop --
command=moveConUp --id=16=>

I continue my search.

Re: Vivotek PZ7111 Control

Posted: Sun Apr 21, 2019 3:48 am
by security_dude
Have you used fiddler in zm to find out what commands it is sending to the camera? You can also use IE 11 debugger by pressing f12 and seeing what shows up under the network tab when you click on a ptz direction arrow. I personally don't think you need to change the script at all since the proper syntax is already in there. What you need to make sure is that your setup in zm control tab is setup correctly. Sometimes the control address is the password and the control address is just the ip:port. For example my trendnet script is built like that since the default userID is admin it is already included in the script.