Page 1 of 1

Login denied for user "admin"

Posted: Sun Apr 07, 2019 8:07 am
by banzaay
Hi all,

I have enabled authentication and with the standard USER/PASSWORD it works fine.
When I change the password to a new one the following error appear in my log:
Login denied for user "admin"
The complete line is:
2019-04-07 10:05:39 web_php 5659 WAR Login denied for user "admin" /usr/share/zoneminder/www/includes/auth.php 58
2019-04-07 10:05:39 web_php 5659 WAR Login denied for user "admin" /usr/share/zoneminder/www/includes/auth.php 58
How can avoid this ?

Thanks

Re: Login denied for user "admin"

Posted: Sun Apr 07, 2019 5:08 pm
by rockedge
where did you enable ZM auth? how did you change the admin password?

Re: Login denied for user "admin"

Posted: Mon Apr 08, 2019 1:01 pm
by banzaay
I have done both activities from the web console.

Thanks

Re: Login denied for user "admin"

Posted: Sat Apr 13, 2019 6:08 am
by srinivas
I've been experiencing the same issue.

Re: Login denied for user "admin"

Posted: Fri Apr 19, 2019 4:03 pm
by banzaay
I have found another strange behaviour, if I try to download an export of logs from the web page I get an Internal Server Error (500).
Log_export.png
Log_export.png (19.55 KiB) Viewed 584 times

Re: Login denied for user "admin"

Posted: Fri May 17, 2019 7:06 am
by banzaay
I have restarted the server many times, but the problem still persist.
Then last night after a black out and restart of the server the problem disappear.

Strange ....

Re: Login denied for user "admin"

Posted: Mon May 20, 2019 12:32 am
by rockedge
before the blackout forced a complete restart of the system did you restart Apache at any point after the installation of zoneminder?
I am wondering if the restart of ZM might have done it.

all of this is speculation because I have no idea what operating system and version is,nor do I know what web server or PHP version you are dealing with. Basically saying that knowing more information on the specifics of your setup would help

Re: Login denied for user "admin"

Posted: Mon May 20, 2019 7:39 am
by banzaay
Hi,

I have restarted the server 5 or 6 times to install Ubuntu package upgrade.

I'm using Apache and PHP provided from the standard repository of Ubuntu 19.04.