Low FPS with H264 Camera Passthrough writer

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
andrew-yu
Posts: 16
Joined: Thu Sep 20, 2018 7:50 am

Low FPS with H264 Camera Passthrough writer

Post by andrew-yu » Tue Mar 19, 2019 5:35 am

I'm using Zoneminder 1.32.3 with Ubuntu 18.04. Connected 7 IP-cameras - one Hikvision and 6 cheap chinese cameras. All 720P and 25 FPS.

When they are connected with H264 Camera Passthrough writer, all cameras, except Hikvision, are showing low (5-8) FPS at Zoneminder. Also Recorded video has lost frames: walking person can be teleported for 1-2 meters on next frame.

With X264 writer all cameras are working ok - 20-25 FPS and no lost frames.

I like low CPU load with H264 Camera Passthrough writer, so i'm trying to fix this. Any ideas?
Last edited by andrew-yu on Thu Mar 21, 2019 11:30 am, edited 3 times in total.

BaseballSS
Posts: 16
Joined: Tue Feb 12, 2019 8:45 pm

Re: Low FPS with H264 Camera Passthrough writer

Post by BaseballSS » Tue Mar 19, 2019 7:27 am

What is the make and model of the cameras that are being problematic? Do they have microphones?

andrew-yu
Posts: 16
Joined: Thu Sep 20, 2018 7:50 am

Re: Low FPS with H264 Camera Passthrough writer

Post by andrew-yu » Tue Mar 19, 2019 9:43 am

All cams without mic.

- 4 Escam QD800
- 1 Escam QD300
- 1 oem chinese cam that looks like
Image

andrew-yu
Posts: 16
Joined: Thu Sep 20, 2018 7:50 am

Re: Low FPS with H264 Camera Passthrough writer

Post by andrew-yu » Thu Mar 21, 2019 11:22 am

I increased camera's image buffer size from 20 to 50 and removed Maximum FPS and Alarm Maximum FPS. At first look, all working ok now.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests