Unable to connect to Logs table

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
SkippyDo
Posts: 97
Joined: Mon Nov 20, 2017 6:49 pm

Unable to connect to Logs table

Post by SkippyDo » Sun Jan 27, 2019 3:19 am

This combo, Debian sid & ZM 1.32.3, is tending to be extremely frustrating/unstable. Can only run a couple of days before something causes zm to no longer be accessible.

I loose the ability to connect via internet (no web access or other), so no ability to diagnose (system is headless). I can only force a reboot via power off/on and then look for crumbs (never finding anything).

The most recent event resulted in mysql failing due to innoDB files, so I moved them out of the way and was then able to start OK. But, zoneminder will not start.

sudo systemctl status zoneminder.service produces:
Jan 26 18:31:47 mandeportal systemd[1]: Starting ZoneMinder CCTV recording and surveillance system...
Jan 26 18:31:47 mandeportal zmpkg.pl[1674]: DBD::mysql::st execute failed: Lost connection to MySQL server during query at /usr/share/perl5/ZoneMinder/Logger.pm l
Jan 26 18:31:47 mandeportal zmpkg[1674]: ERR [Can't execute log entry 'INSERT INTO Logs ( TimeKey, Component, ServerId, Pid, Level, Code, Message, File, Line ) VA
Jan 26 18:31:47 mandeportal zmpkg.pl[1674]: DBD::mysql::st execute failed: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)
Jan 26 18:31:47 mandeportal zmpkg[1674]: FAT [Can't execute: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)]
Jan 26 18:31:47 mandeportal systemd[1]: zoneminder.service: Control process exited, code=exited, status=255/EXCEPTION
Jan 26 18:31:47 mandeportal systemd[1]: zoneminder.service: Failed with result 'exit-code'.
Jan 26 18:31:47 mandeportal systemd[1]: Failed to start ZoneMinder CCTV recording and surveillance system.

MariaDB [zm]> check table Logs; produces:
ERROR 2013 (HY000): Lost connection to MySQL server during query
Can anyone point me toward some resolution?

SkippyDo
Posts: 97
Joined: Mon Nov 20, 2017 6:49 pm

Re: Unable to connect to Logs table

Post by SkippyDo » Sun Jan 27, 2019 6:03 pm

Dropping and recreating the Logs table and, for now, things seem to be working as expected.

Interesting is that removing the innoDB log file allowed zm to start, but I was only getting one of my four cameras to come up (stream) and nothing was showing in the zm logs.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests