ZM 1.32.3 Libvlc source cameras not working

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
Maximo1970
Posts: 50
Joined: Sun May 28, 2017 4:29 pm

ZM 1.32.3 Libvlc source cameras not working

Post by Maximo1970 » Sat Dec 29, 2018 9:13 am

I have just upgraded from 1.32.2 and now none of my cameras work as i use Libvlc as the source type. They all worked fine previously. Here are the debug logs i have. Any ideas?

Code: Select all

12/29/18 09:05:26.541530 zms_m1[13410].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:26.583436 zms_m1[13410].ERR-zm_monitor.cpp/538 [Got empty memory map file size 0, is the zmc process for this monitor running?]
12/29/18 09:05:26.595727 zms_m1[13410].ERR-zm_stream.cpp/48 [Unable to connect to monitor id 1 for streaming]
12/29/18 09:05:26.607629 zms_m1[13410].ERR-zms.cpp/254 [Unable to connect to zmc process for monitor 1]
12/29/18 09:05:28.151209 zms_m1[13434].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:28.679502 zms_m1[13434].WAR-zm_monitorstream.cpp/711 [no last_frame_sent.  Shouldn't happen. frame_mod was (1) frame_count (0) ]
12/29/18 09:05:38.708222 zms_m1[13434].ERR-zm_monitorstream.cpp/713 [Terminating, last frame sent time 10.208052 secs more than maximum of 10.000000]
12/29/18 09:05:41.839076 zms_m1[13481].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:42.372857 zms_m1[13481].WAR-zm_monitorstream.cpp/711 [no last_frame_sent.  Shouldn't happen. frame_mod was (1) frame_count (0) ]
12/29/18 09:05:43.348302 zms_m1[13486].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:43.888024 zms_m1[13486].WAR-zm_monitorstream.cpp/711 [no last_frame_sent.  Shouldn't happen. frame_mod was (1) frame_count (0) ]
12/29/18 09:05:40.472753 zms_m1[13476].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:41.010749 zms_m1[13476].WAR-zm_monitorstream.cpp/711 [no last_frame_sent.  Shouldn't happen. frame_mod was (1) frame_count (0) ]
12/29/18 09:05:51.642802 zms_m1[13499].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:51.716274 zms_m1[13499].ERR-zm_monitor.cpp/538 [Got empty memory map file size 0, is the zmc process for this monitor running?]
12/29/18 09:05:51.730048 zms_m1[13499].ERR-zm_stream.cpp/48 [Unable to connect to monitor id 1 for streaming]
12/29/18 09:05:51.741477 zms_m1[13499].ERR-zms.cpp/254 [Unable to connect to zmc process for monitor 1]
12/29/18 09:05:53.234682 zms_m1[13504].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:53.262812 zms_m1[13504].ERR-zm_monitor.cpp/538 [Got empty memory map file size 0, is the zmc process for this monitor running?]
12/29/18 09:05:53.276873 zms_m1[13504].ERR-zm_stream.cpp/48 [Unable to connect to monitor id 1 for streaming]
12/29/18 09:05:53.297064 zms_m1[13504].ERR-zms.cpp/254 [Unable to connect to zmc process for monitor 1]
12/29/18 09:05:54.497461 zms_m1[13510].INF-zm_user.cpp/126 [Authenticated user 'admin']
12/29/18 09:05:54.535542 zms_m1[13510].ERR-zm_monitor.cpp/538 [Got empty memory map file size 0, is the zmc process for this monitor running?]
12/29/18 09:05:54.543626 zms_m1[13510].ERR-zm_stream.cpp/48 [Unable to connect to monitor id 1 for streaming]
12/29/18 09:05:54.555608 zms_m1[13510].ERR-zms.cpp/254 [Unable to connect to zmc process for monitor 1]

Code: Select all

12/29/18 09:04:30.461876 zmc_m1[13293].INF-zmc.cpp/223 [Starting Capture version 1.32.3]
12/29/18 09:04:30.483814 zmc_m1[13293].INF-zm_libvlc_camera.cpp/160 [Priming capture from rtsp://admin@192.168.3.10:8854/live0.264]
12/29/18 09:04:45.497266 zmc_m1[13293].INF-zm_signal.cpp/40 [Got signal 15 (Terminated), exiting]
12/29/18 09:04:55.690958 zmc_m1[13354].INF-zmc.cpp/223 [Starting Capture version 1.32.3]
12/29/18 09:04:55.781977 zmc_m1[13354].INF-zm_libvlc_camera.cpp/160 [Priming capture from rtsp://admin@192.168.3.10:8854/live0.264]
12/29/18 09:05:06.592335 zmc_m1[13354].INF-zm_signal.cpp/40 [Got signal 15 (Terminated), exiting]
12/29/18 09:05:28.111119 zmc_m1[13427].INF-zmc.cpp/223 [Starting Capture version 1.32.3]
12/29/18 09:05:28.136394 zmc_m1[13427].INF-zm_libvlc_camera.cpp/160 [Priming capture from rtsp://admin@192.168.3.10:8854/live0.264]
12/29/18 09:05:38.218751 zmc_m1[13427].INF-zm_signal.cpp/40 [Got signal 15 (Terminated), exiting]
12/29/18 09:05:39.061059 zmc_m1[13456].INF-zmc.cpp/223 [Starting Capture version 1.32.3]
12/29/18 09:05:39.093974 zmc_m1[13456].INF-zm_libvlc_camera.cpp/160 [Priming capture from rtsp://admin@192.168.3.10:8854/live0.264]
12/29/18 09:05:48.971617 zmc_m1[13456].INF-zm_signal.cpp/40 [Got signal 15 (Terminated), exiting]
12/29/18 09:05:56.007957 zmc_m1[13514].INF-zmc.cpp/223 [Starting Capture version 1.32.3]
12/29/18 09:05:56.023916 zmc_m1[13514].INF-zm_libvlc_camera.cpp/160 [Priming capture from rtsp://admin@192.168.3.10:8854/live0.264]
12/29/18 09:06:10.232419 zmc_m1[13514].INF-zm_signal.cpp/40 [Got signal 15 (Terminated), exiting]

Code: Select all

12/29/18 09:05:27.012886 web_js[5364].ERR [getStreamCmdResponse stream error: Socket /var/lib/zoneminder/sock/zms-678999s.sock does not exist.  This file is created by
zms, and since it does not exist, either zms did not run, or zms exited early.  Please check your zms logs and ensure that CGI is enabled in apache and check that the P
ATH_ZMS is set correctly.  Make sure that ZM is actually recording.  If you are trying to view a live stream and the capture process (zmc) is not running then zms will
exit. Please go to http://zoneminder.readthedocs.io/en/latest/faq.html#why-can-t-i-see-streamed-images-when-i-can-see-stills-in-the-zone-window-etc for more information
. - checkStreamForErrors()] at ?view=watch line
12/29/18 09:05:39.055558 web_js[5361].ERR [getStreamCmdResponse stream error: Socket /var/lib/zoneminder/sock/zms-083484s.sock does not exist.  This file is created by
zms, and since it does not exist, either zms did not run, or zms exited early.  Please check your zms logs and ensure that CGI is enabled in apache and check that the P
ATH_ZMS is set correctly.  Make sure that ZM is actually recording.  If you are trying to view a live stream and the capture process (zmc) is not running then zms will
exit. Please go to http://zoneminder.readthedocs.io/en/latest/faq.html#why-can-t-i-see-streamed-images-when-i-can-see-stills-in-the-zone-window-etc for more information
. - checkStreamForErrors()] at ?view=watch line
12/29/18 09:05:40.643690 web_js[5364].ERR [getStreamCmdResponse stream error: Socket /var/lib/zoneminder/sock/zms-214704s.sock does not exist.  This file is created by
zms, and since it does not exist, either zms did not run, or zms exited early.  Please check your zms logs and ensure that CGI is enabled in apache and check that the P
ATH_ZMS is set correctly.  Make sure that ZM is actually recording.  If you are trying to view a live stream and the capture process (zmc) is not running then zms will
exit. Please go to http://zoneminder.readthedocs.io/en/latest/faq.html#why-can-t-i-see-streamed-images-when-i-can-see-stills-in-the-zone-window-etc for more information
. - checkStreamForErrors()] at ?view=watch line
12/29/18 09:05:41.945509 web_js[5364].ERR [getStreamCmdResponse stream error: Socket /var/lib/zoneminder/sock/zms-089801s.sock does not exist.  This file is created by
zms, and since it does not exist, either zms did not run, or zms exited early.  Please check your zms logs and ensure that CGI is enabled in apache and check that the P
ATH_ZMS is set correctly.  Make sure that ZM is actually recording.  If you are trying to view a live stream and the capture process (zmc) is not running then zms will
exit. Please go to http://zoneminder.readthedocs.io/en/latest/faq.html#why-can-t-i-see-streamed-images-when-i-can-see-stills-in-the-zone-window-etc for more information
. - checkStreamForErrors()] at ?view=watch line
12/29/18 09:05:50.242824 web_js[12045].ERR [getStreamCmdResponse stream error: Socket /var/lib/zoneminder/sock/zms-542732s.sock does not exist.  This file is created by
 zms, and since it does not exist, either zms did not run, or zms exited early.  Please check your zms logs and ensure that CGI is enabled in apache and check that the
PATH_ZMS is set correctly.  Make sure that ZM is actually recording.  If you are trying to view a live stream and the capture process (zmc) is not running then zms will
 exit. Please go to http://zoneminder.readthedocs.io/en/latest/faq.html#why-can-t-i-see-streamed-images-when-i-can-see-stills-in-the-zone-window-etc for more informatio
n. - checkStreamForErrors()] at ?view=watch line
12/29/18 09:05:52.696924 web_js[5441].ERR [getStreamCmdResponse stream error: Socket /var/lib/zoneminder/sock/zms-919783s.sock does not exist.  This file is created by
zms, and since it does not exist, either zms did not run, or zms exited early.  Please check your zms logs and ensure that CGI is enabled in apache and check that the P
ATH_ZMS is set correctly.  Make sure that ZM is actually recording.  If you are trying to view a live stream and the capture process (zmc) is not running then zms will
exit. Please go to http://zoneminder.readthedocs.io/en/latest/faq.html#why-can-t-i-see-streamed-images-when-i-can-see-stills-in-the-zone-window-etc for more information
. - checkStreamForErrors()] at ?view=watch line
12/29/18 09:05:53.340814 web_js[5568].ERR [getStreamCmdResponse stream error: Socket /var/lib/zoneminder/sock/zms-043229s.sock does not exist.  This file is created by
zms, and since it does not exist, either zms did not run, or zms exited early.  Please check your zms logs and ensure that CGI is enabled in apache and check that the P
ATH_ZMS is set correctly.  Make sure that ZM is actually recording.  If you are trying to view a live stream and the capture process (zmc) is not running then zms will
exit. Please go to http://zoneminder.readthedocs.io/en/latest/faq.html#why-can-t-i-see-streamed-images-when-i-can-see-stills-in-the-zone-window-etc for more information
. - checkStreamForErrors()] at ?view=watch line

Maximo1970
Posts: 50
Joined: Sun May 28, 2017 4:29 pm

Re: ZM 1.32.3 Libvlc source cameras not working

Post by Maximo1970 » Sat Dec 29, 2018 10:15 am

Ok, turns out to be a very simple fix for this. So it looks like the authentication method was getting confused because I wasn't sending a password.

Change the source from:

rtsp://admin@192.168.3.10:8854/live0.264 (Worked all the way to and including 1.32.2)

to:

rtsp://admin:@192.168.3.10:8854/live0.264

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests