ZM and peculiar web setup

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
gardiol
Posts: 1
Joined: Thu Dec 13, 2018 1:20 pm

ZM and peculiar web setup

Post by gardiol » Fri Dec 21, 2018 8:00 am

Hi all!
I recently discovered ZoneMinder (1.32.3) and i am trying deploy at my home. I have some 9 cameras (5 Axis IP cameras, 4 chinese V380 rtsp cameras) and i want to publish them on my public webserver.

My setup is as follow:
- home server, with ZoneMinder
- public server, outside home

On the home server i have Apache 2.4, just for Zone Minder and Nginx, which works as collector for a few redirects and other home services. Nginx also collect the apache.

When i connect from within home, i get this flow:
- connect to home server
- nginx on port 80, redirect apache 2.4 from port 8080
- apache on port 8080 host zoneminder

The home server is connected to the public server via a tunnel, since i have no public IP (not even shared, i am natted). On the public server i have Apache 2.4.

When i connect from outsite home, i get this flow:
- connect to public server
- Apache 2.4 on port 80, redirect to "tunnellized" connection on port 127.0.0.1:xxx which goes to home on port 80
- nginx from home, in port 80, redirect apache 2.4 from port 8080
- apache on port 8080 host zoneminder

I have defined, for test, two cameras in ZoneMinder. They "seems" to be working ok (how to actually check?) since i see no errors on logs. But the live screenshot it missing. Checking with Chrome inspection i can see why: the screenshot image has an URL of the kind "http://127.0.0.1/xxxxx" which is clearly very wrong. The general ZM pages works, i can use the GUI fine, it seems it's the screenshots not working?

What should i do? I could try with rewrite rules in nginx and/or apache redirect, but... Is this the right path? Is there some ZM setting i should play with?

thank you for your replies!

bbunge
Posts: 2667
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: ZM and peculiar web setup

Post by bbunge » Sun Dec 23, 2018 4:33 pm

Whatever you have on your Home Server for web pages just add /zm to the URL.

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests