Multi Server Install using NGINX for reverse proxy

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
Maximo1970
Posts: 50
Joined: Sun May 28, 2017 4:29 pm

Multi Server Install using NGINX for reverse proxy

Post by Maximo1970 » Mon Dec 17, 2018 10:19 am

Hello everyone,

I'm currently building my CCTV solution and have built a number of servers, all are VM's and running CentOS 7. As I'd like to access my setup from over the Internet I've also got NGINX running to reverse proxy. Which is where I'm after a little help.
(Let me know if further details are required.)

1, When trying to access the events I'm not able to stream video. The error would suggest that it's the wrong format. Doing a little research brings me to believe that NGINX is part of the problem.

3, When accessing my zoneminder setup over the Internet via NGINX I'm not able to view any of the live streams.

Is anyone else running something similar and able to offer me advice? I'd like to keep NGINX in the mix as it's used for other parts of my network, adding that little extra layer of security for me.

Thanks,

Garry

User avatar
knight-of-ni
Posts: 2278
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Multi Server Install using NGINX for reverse proxy

Post by knight-of-ni » Mon Dec 17, 2018 1:32 pm

There are several changes in the queue that you should be aware of:
1) newer ffmpeg (just made it to RPMFusion stable
2) newer libvlc (just pushed to RPMFusion testing)
3) new zoneminder 1.32.3 packages for el7 (will build as soon as #2 makes it to stable)

Not only do the new ffmpeg & vlc help with h264 support, but the new zm 1.23.3 packages have been split into subpackages to support both apache and nginx.

None of this addresses your issues, but you might want to wait until we get through all these changes. That way, you will have the option to completely drop Apache from the mix and go with nginx for all your servers.

On to your issues... We need to know the exact error message(s) from your browser and/or zm logs in order to troubleshoot the problem.

I will say that Chromium on Fedora does not appear to have h264 support and cannot play the mp4's recorded by ZoneMinder, but Firefox on Fedora does. This isn't suprising since redhat stays clear of h264. There is a Chromium package in RPMFusion that gets you more codecs, but I have not tried it. If you are trying to view mp4 content from an el7 client, I'd expect the same kind of issue.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

Maximo1970
Posts: 50
Joined: Sun May 28, 2017 4:29 pm

Re: Multi Server Install using NGINX for reverse proxy

Post by Maximo1970 » Tue Dec 18, 2018 11:30 am

Thanks for the reply and information on the forth coming release. Something to look forward to.

I'm using Chrome to access my setup and get the following error; "The video could not be loaded, either because the server or network failed or because the format is not supported." After a little bit of work last night I've found that if I logon to the server where the camera is associated and please the event it works fine. So it's got to be either my NGINX configuration or the way i've setup my zoneminder solution.

Could you point me in the right direction in terms of which logfile is likely to contain the most relevant information that will help debug my issue. Happy to attach all of the logfiles is that's the best approach.

Regards,

Garry

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests