Failed installation on Ubuntu 18.04

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
User avatar
Hans73
Posts: 6
Joined: Wed Jul 18, 2018 12:04 pm
Location: Germany

Failed installation on Ubuntu 18.04

Post by Hans73 » Mon Nov 26, 2018 2:36 pm

Using the guide below I have tried to install Zoneminder 1.32 on an ubuntu Server 18.04 with LAMP installed.

https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way

The Installation of Zoneminder fails with a bunch of dependenies ... Is this an known error for this version ?



Die folgenden Pakete haben unerfüllte Abhängigkeiten:
zoneminder : Hängt ab von: libavcodec57 (>= 7:3.4.4) ist aber nicht installierbar oder
libavcodec-extra57 (>= 7:3.4.4) ist aber nicht installierbar
Hängt ab von: libavformat57 (>= 7:3.4.4) ist aber nicht installierbar
Hängt ab von: libavresample3 (>= 7:3.4.4) ist aber nicht installierbar
Hängt ab von: libavutil55 (>= 7:3.4.4) ist aber nicht installierbar
Hängt ab von: libmp4v2-2 ist aber nicht installierbar
Hängt ab von: libswscale4 (>= 7:3.4.4) ist aber nicht installierbar
Hängt ab von: libvlc5 (>= 1.1.1) ist aber nicht installierbar
Hängt ab von: libx264-152 ist aber nicht installierbar
Hängt ab von: libjs-mootools (>= 1.4.5~debian1) ist aber nicht installierbar
Hängt ab von: ffmpeg ist aber nicht installierbar oder
libav-tools ist aber nicht installierbar
Hängt ab von: libdbd-mysql-perl ist aber nicht installierbar
Hängt ab von: libphp-serialization-perl ist aber nicht installierbar
Hängt ab von: libnet-sftp-foreign-perl ist aber nicht installierbar
Hängt ab von: libdevice-serialport-perl ist aber nicht installierbar
Hängt ab von: libimage-info-perl ist aber nicht installierbar
Hängt ab von: libjson-any-perl ist aber nicht installierbar
Hängt ab von: libjson-maybexs-perl ist aber nicht installierbar
Hängt ab von: libsys-mmap-perl ist aber nicht installierbar
Hängt ab von: liburi-encode-perl ist aber nicht installierbar
Hängt ab von: libclass-std-fast-perl ist aber nicht installierbar
Hängt ab von: libsoap-wsdl-perl ist aber nicht installierbar
Hängt ab von: libio-socket-multicast-perl ist aber nicht installierbar
Hängt ab von: libsys-cpu-perl ist aber nicht installierbar
Hängt ab von: libsys-meminfo-perl ist aber nicht installierbar
Hängt ab von: libdata-uuid-perl ist aber nicht installierbar
Hängt ab von: libnumber-bytes-human-perl ist aber nicht installierbar
Hängt ab von: libfile-slurp-perl ist aber nicht installierbar
Hängt ab von: php5-apcu ist aber nicht installierbar oder
php-apcu ist aber nicht installierbar
Hängt ab von: php-apc ist aber nicht installierbar oder
php-apcu-bc ist aber nicht installierbar
Empfiehlt: zoneminder-doc (>= 1.32.2-bionic1) soll aber nicht installiert werden
Empfiehlt: ffmpeg ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Even though the CLI output is in german, it obviously not finding components needed, even thought the Wiki shows a proven setup.

Sorry I don't understand that ... :?
Hans
Dont drink and root ... :lol:

User avatar
knight-of-ni
Posts: 2226
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Failed installation on Ubuntu 18.04

Post by knight-of-ni » Mon Nov 26, 2018 3:05 pm

Sounds like you need to enable the universe and/or multiverse repositories. I don't recall if you need one or both.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

User avatar
Hans73
Posts: 6
Joined: Wed Jul 18, 2018 12:04 pm
Location: Germany

Re: Failed installation on Ubuntu 18.04

Post by Hans73 » Mon Nov 26, 2018 4:08 pm

knight-of-ni wrote:
Mon Nov 26, 2018 3:05 pm
Sounds like you need to enable the universe and/or multiverse repositories. I don't recall if you need one or both.
Yes, that did the trick ...

sudo add-apt-repository universe

Thank you! :wink: :!:
Dont drink and root ... :lol:

bbunge
Posts: 2420
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Failed installation on Ubuntu 18.04

Post by bbunge » Mon Nov 26, 2018 4:58 pm

Will investigate adding a check for that repository in the install script. May be as simple as adding: add-apt--y repository universe

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests