New user, camera not showing up.

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
micah.zoltu
Posts: 2
Joined: Sat Nov 24, 2018 10:28 am

New user, camera not showing up.

Post by micah.zoltu » Sat Nov 24, 2018 10:44 am

I have a camera that I am able to view in VLC and an ONVIF viewer without problem. When I try to add the camera to a new installation (via docker) of ZoneMinder the camera shows up as Not Running.

Details about the camera from ONVIF tool:

Code: Select all

Type: RTSP
Frame Rate (fps): 30
Data Rate (Mbit/s): 0.686
Resolution: 1920x1080
Encoding: H265
Transport protocol: TCP
RTSP handshake time (s): .5
Details from VLC:

Code: Select all

Codec: MPEG-H Part2/HEVC (H.265) (hevc)
Type: Video
Video Resolution: 1920x1080
Buffer dimensions: 1920x1080
Frame rate: 30
Decoded format:
Orientation: Top left
Color primaries: ITU-R BT.709
Color transfer function: ITU-R BT.709
Color space: ITU-R BT.709 Range
The camera URL is of the form:

Code: Select all

rtsp://<user>:<pass>@<ip>:<port>/unicast/c1/s0/live
I have done my best to fill in the monitor add dialog with information that matches what ONVIF tool and VLC present, but nothing seems to make the camera show up in ZoneMinder.

ZoneMinder settings:

Code: Select all

Server: None
Storage Area: Default
Source Type: ffmpeg
Function: Monitor
Enabled: true
Maximum FPS: 30.00
Alarm Maximum FPS: 30.00
Source Path: rtsp://<user>:<pass>@<ip>:<port>/unicast/c1/s0/live
Method: TCP
Target Colorspace: 32 bit colour
Capture Width: 1920
Capture Height: 1080
I have tried looking at the logs, and I do see some errors and warnings but none of it gives me any hints as to what the problem might be, the following logs repeat over and over:

Code: Select all

2018-11-24 18:43:17	zmwatch		366	INF	Restarting capture daemon for Entry, shared data not valid	zmwatch.pl	
2018-11-24 18:43:07	zmwatch		366	INF	Restarting capture daemon for Entry, shared data not valid	zmwatch.pl	
2018-11-24 18:43:07	zmdc		308	INF	Command 'zmc -m 1' removed from pending list at 18/11/24 18:43:07	zmdc.pl	
2018-11-24 18:43:06	zmdc		308	INF	'zmc -m 1' crashed, signal 6	zmdc.pl	
2018-11-24 18:43:05	zmdc		308	INF	Starting pending process, zmc -m 1	zmdc.pl	
2018-11-24 18:43:05	zmdc		308	INF	'zmc -m 1' starting at 18/11/24 18:43:05, pid = 3531	zmdc.pl	
2018-11-24 18:43:05	zmdc		3531	INF	'zmc -m 1' started at 18/11/24 18:43:05	zmdc.pl	
2018-11-24 18:43:00	zmdc		308	INF	'zmc -m 1' crashed, signal 6	zmdc.pl	
2018-11-24 18:42:59	zmdc		3520	INF	'zmc -m 1' started at 18/11/24 18:42:59	zmdc.pl	
2018-11-24 18:42:59	zmdc		308	INF	'zmc -m 1' starting at 18/11/24 18:42:59, pid = 3520	zmdc.pl	
2018-11-24 18:42:59	zmdc		308	INF	Starting pending process, zmc -m 1	zmdc.pl	
2018-11-24 18:42:58	zmdc		308	INF	'zmc -m 1' crashed, signal 6	zmdc.pl	
2018-11-24 18:42:57	zmdc		3514	INF	'zmc -m 1' started at 18/11/24 18:42:57	zmdc.pl	
2018-11-24 18:42:57	zmdc		308	INF	'zmc -m 1' starting at 18/11/24 18:42:57, pid = 3514	zmdc.pl	
2018-11-24 18:42:57	zmdc		308	WAR	Can't find process with command of 'zmc -m 1'	zmdc.pl	
Looking at the above, is there anything that is obviously wrong with my setup attempt? Is H-265 supported out of the box with the docker image found here: https://github.com/ZoneMinder/zmdockerf ... Dockerfile ? What can I do to further troubleshoot?

bbunge
Posts: 2419
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: New user, camera not showing up.

Post by bbunge » Sat Nov 24, 2018 9:59 pm

Your resolution could be wrong. Look in VLC for display resolution. You could also be out of memory.

micah.zoltu
Posts: 2
Joined: Sat Nov 24, 2018 10:28 am

Re: New user, camera not showing up.

Post by micah.zoltu » Mon Nov 26, 2018 8:22 am

The resolution I provided to ZoneMinder matches the resolution VLC shows for the feed.

How can I tell if I am running out of memory? It is a single video feed running in Docker on a pretty beefy computer, so running out of memory seems unlikely, especially since I believe ZoneMinder works on lower end machines like Raspberry Pis.

User avatar
knight-of-ni
Posts: 2226
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: New user, camera not showing up.

Post by knight-of-ni » Mon Nov 26, 2018 12:39 pm

micah.zoltu wrote:
Mon Nov 26, 2018 8:22 am
The resolution I provided to ZoneMinder matches the resolution VLC shows for the feed.

How can I tell if I am running out of memory? It is a single video feed running in Docker on a pretty beefy computer, so running out of memory seems unlikely, especially since I believe ZoneMinder works on lower end machines like Raspberry Pis.
H265 is not officially supported yet, but it will be soon. For now, set your camera to h264. This question was just answered in our Slack channel. Feel free to join it for up to the minute information.

While you are at it, set the frame rate in your camera to 5 fps. That's more reasonable for a security system.

ZoneMinder uses your ram disk /dev/shm, which in Docker defaults to 50MB, which won't work for a single camera. You have to set this from the command line when you run the container. See the instructions at the bottom of the dockerfile you referenced. The status of /dev/shm is shown right on the web console, top right. It will tell you when you run out.
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests