Directory Events magically disappeared!

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
garbia
Posts: 6
Joined: Mon Nov 19, 2018 10:14 pm

Directory Events magically disappeared!

Post by garbia » Mon Nov 19, 2018 10:20 pm

Hello everybody
I am having this issue in my 1.32.4 installation which was stable until a couple of days ago when I went to play one of the cameras and realized that nothing was playing.

Getting a black screen with
"The video could not be loaded, either because the server or network failed or because the format is not supported"
Live monitoring works, haven't touching anything from Nov 14 when the recording were playing without problems.

Steps:
1) Restart the VM
2) Permissions
#chown -R www-data:www-data /etc/zm
#chown -R www-data:www-data /var/cache/zoneminder
3) checked the logs and found out that events wasn't there anymore!

Solved by creating the directory events.

I am using VMware and ubuntu server 18.04
Last edited by garbia on Fri Nov 23, 2018 1:50 am, edited 2 times in total.

andrew-yu
Posts: 16
Joined: Thu Sep 20, 2018 7:50 am

Re: The video could not be loaded, either because the server or network failed or because the format is not supported

Post by andrew-yu » Tue Nov 20, 2018 8:41 pm

Hi, what type of video writer do you use? I had the same issues when i configured my monitor's video writer to H264 Camera Passthrough.

garbia
Posts: 6
Joined: Mon Nov 19, 2018 10:14 pm

Re: The video could not be loaded, either because the server or network failed or because the format is not supported

Post by garbia » Wed Nov 21, 2018 12:52 am

andrew-yu wrote:
Tue Nov 20, 2018 8:41 pm
Hi, what type of video writer do you use? I had the same issues when i configured my monitor's video writer to H264 Camera Passthrough.
Thank you for your reply
I did a fresh 1.32.4 installation installation, pretty much all default, couple of foscams, rest is Ezviz
It looks like an ownership problem, if thats the case, I have no idea how that happened


This is from the log
2018-11-20 16:50:55 zmfilter_2 1611 WAR DiskSpace: Event does not exist at /var/cache/zoneminder/events/3/2018-11-19/9595:ZoneMinder::Event: Name => Event- 9595 StateId => 1 EndTime => 2018-11-19 23:25:28 Frames => 1084 StartTime => 2018-11-19 23:20:00 Id => 9595 Cause => Continuous MonitorId => 3 Height => 960 StorageId => 1 Width => 1280 Length => 328.89 DefaultVideo => 9595-video.mp4 zmfilter.pl

Pedulla
Posts: 133
Joined: Thu Nov 27, 2014 11:16 am
Location: Portland, Or

Re: The video could not be loaded, either because the server or network failed or because the format is not supported

Post by Pedulla » Wed Nov 21, 2018 2:21 am

I'll add to this issue. I'm running UB18.04 ZM1.32.2 FreeNAS event storage over NFS.
My events are recorded as H264 passthrough triggered (Nodetect) by low res stream on modetect.

The actual video files are not in the event directory. The snapshot and thumbnail are though.
It doesn't happen all the time for me so it's a hit and miss thing.

I thought it might be an issue with the Hikvision cams.

I meant to spend some more time observing the problem and trying to find out definitively if using the h264 record mode as opposed to passthrough fixes the issue. Just haven't gotten there yet.

What I've observed so far:
- Not all evetns, but hit and miss. don't know the circumstances that cause the problem
- Video file definitely missing in event dir
- LowRes trigger monitor recorded trad mjpeg just fine
- Seems to only happen on hires monitors larger than 1920x1080

garbia
Posts: 6
Joined: Mon Nov 19, 2018 10:14 pm

Re: The video could not be loaded, either because the server or network failed or because the format is not supported

Post by garbia » Fri Nov 23, 2018 1:36 am

What I am trying to understand is how the whole event dir disappeared, as strange as it sound......




root@zoneminder:/var/cache/zoneminder# dir
cache images temp
root@zoneminder:/var/cache/zoneminder# ls -l
total 24
drwxr-xr-x 2 www-data www-data 16384 Nov 19 14:18 cache
drwxr-xr-x 2 www-data www-data 4096 Oct 13 18:44 images
drwxr-xr-x 2 www-data www-data 4096 Oct 13 18:44 temp
root@zoneminder:/var/cache/zoneminder#

https://pastebin.com/V8rmiHJF

garbia
Posts: 6
Joined: Mon Nov 19, 2018 10:14 pm

Re: The video could not be loaded, either because the server or network failed or because the format is not supported

Post by garbia » Fri Nov 23, 2018 1:51 am

Pedulla wrote:
Wed Nov 21, 2018 2:21 am
I'll add to this issue. I'm running UB18.04 ZM1.32.2 FreeNAS event storage over NFS.
My events are recorded as H264 passthrough triggered (Nodetect) by low res stream on modetect.

The actual video files are not in the event directory. The snapshot and thumbnail are though.
It doesn't happen all the time for me so it's a hit and miss thing.

I thought it might be an issue with the Hikvision cams.

I meant to spend some more time observing the problem and trying to find out definitively if using the h264 record mode as opposed to passthrough fixes the issue. Just haven't gotten there yet.

What I've observed so far:
- Not all evetns, but hit and miss. don't know the circumstances that cause the problem
- Video file definitely missing in event dir
- LowRes trigger monitor recorded trad mjpeg just fine
- Seems to only happen on hires monitors larger than 1920x1080
Different problem, in my case the whole events directory is gone!

karsta62
Posts: 3
Joined: Wed Dec 01, 2010 5:25 am

Re: Directory Events magically disappeared!

Post by karsta62 » Sat Jul 20, 2019 11:01 am

I'm having this "disappearing events directory" issue with v1.32.3 on ubuntu 18.04.
It's happened three times already!?!?

The recovery is to create the directory back, but that's not a fix. All events are lost.

karsta62
Posts: 3
Joined: Wed Dec 01, 2010 5:25 am

Re: Directory Events magically disappeared!

Post by karsta62 » Sat Sep 28, 2019 12:09 pm

Right. I got the events directory protected, but just now I was cleaning up events, and suddenly all events from all monitors vanished.
I can only clean one monitor at a time so it's no accident. I saw many events from every monitor, but now they are all zero.
The "events" directory exists as well as the monitor number directories, but all empty.

This is what's in the log:

Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/10/2019-09-27/15260/15260-video.mp4
JPEGS not saved.zms is not capable of streaming jpegs from mp4 yet
Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/10/2019-09-27/15264/15264-video.mp4
JPEGS not saved.zms is not capable of streaming jpegs from mp4 yet
Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/10/2019-09-27/15264/15264-video.mp4
Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/10/2019-09-27/15260/15260-video.mp4
Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/5/2019-09-27/15256/15256-video.mp4
JPEGS not saved.zms is not capable of streaming jpegs from mp4 yet
Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/5/2019-09-28/15267/15267-video.mp4
Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/5/2019-09-27/15256/15256-video.mp4
Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/2/2019-09-27/15259/15259-video.mp4
Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/1/2019-09-28/15271/15271-video.mp4
Event 15312 Not found
Event 15318 Not found
Unable to load event 15318, not found in DB
Unable to load event 15312, not found in DB
No Frame ID specified
Event 15310 Not found
Unable to load event 15310, not found in DB
Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/9/2019-09-28/15312/15312-video.mp4
JPEGS not saved.zms is not capable of streaming jpegs from mp4 yet
Can't create frame images from video because there is no video file for this event at (/var/cache/zoneminder/events/9/2019-09-28/15348/15348-video.mp4
Event 15353 Not found
Unable to load event 15353, not found in DB


This is serious...

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest