Modect-Nodect slow to start linked recordings

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
thoraxe
Posts: 14
Joined: Sun Jun 17, 2018 2:25 pm

Modect-Nodect slow to start linked recordings

Post by thoraxe » Thu Nov 15, 2018 10:31 pm

I am using a low-res substream to capture alarms (Modect) and then linking the main stream to record the high-res (Nodect).

I am having an issue where the linked monitor recording seems to start very late. One example today where I was coming into my house and the sub alarm and recording caught most of my movement, but by the time the linked recording fired up I was basically already in the house.

My buffer on the main is 50 frames with a warmup and pre-event count of 25. My high-res is 1080P at 30FPS. I don't have an issue with drastically increasing the buffer and the pre-event count, but the docs make it seem like this could be troublesome. My system has 8G of memory and 12 threads (6core) that's mostly unused/idle. I'm not particularly concerned with burning CPU or memory to get a better high-res capture.

I was generally happy with the sub recording in terms of length and where the alarm kicked in. But I'm very unhappy with the linked recording.

Any thoughts on how to improve this?

mrbill
Posts: 15
Joined: Thu Jan 19, 2017 7:13 am

Re: Modect-Nodect slow to start linked recordings

Post by mrbill » Fri Nov 16, 2018 11:15 am

I'm no expert by any means - but perhaps the logs from around the events may help.

Pedulla
Posts: 142
Joined: Thu Nov 27, 2014 11:16 am
Location: Portland, Or

Re: Modect-Nodect slow to start linked recordings

Post by Pedulla » Sun Nov 18, 2018 8:04 am

This actually sounds like a buffer issue.
If you're hires stream is running at a higher frame rate (that's the way I run it) you will need to adjust your pre-event buffers accordingly.

5 seconds at 4fps are 12 pre-event frames.
5 seconds at 10fps are 50 pre-event frames.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests