Gapless Events - Fast Forward reverts back to 1x for each new event

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
c128
Posts: 59
Joined: Sat Sep 14, 2013 3:36 pm

Gapless Events - Fast Forward reverts back to 1x for each new event

Post by c128 » Sat Nov 10, 2018 8:50 pm

Hi,

I've been running 1.32.2 on a test server, and after a successful period of running there's now only one thing stopping me switching over my main server from 1.30.4.

When viewing "Gapless Events", if I set a Fast Forward speed on one event it always reverts back to 1x when it hits the next event - makes it quite difficult to review a range of events at a higher speed, as I often do with 1.30.4, as the speed I have set is forgotten.

Is this a settings mistake my side?

Thanks.

c128
Posts: 59
Joined: Sat Sep 14, 2013 3:36 pm

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by c128 » Thu Nov 15, 2018 11:30 pm

Anyone else seeing this, or is it just an oddity of my install?

It's quite a pain to review multiple (gapless) events when the speed drops back to 1x on each new event.

Pedulla
Posts: 132
Joined: Thu Nov 27, 2014 11:16 am
Location: Portland, Or

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by Pedulla » Sun Nov 18, 2018 8:17 am

I've seen it to, but only on h264 recordings.
The old MJPEG work as they did.

c128
Posts: 59
Joined: Sat Sep 14, 2013 3:36 pm

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by c128 » Sun Nov 18, 2018 4:37 pm

Ah, yes, that's a good point- I am making use of h.264 too.

There's also the "black flash" that you get between events, but I can live with that - the resetting of the speed is a bit of a problem when reviewing events though :(

Alec
Posts: 38
Joined: Thu Aug 17, 2017 3:55 am

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by Alec » Wed Nov 21, 2018 4:11 am

I experience this also, saving only h.264. And I agree that it would be an improvement to keep the playback speed from event to event.
DFU
v 1.32.x on Ubuntu 16.04 server using LAMP
v 1.31.x on Ubuntu 16.04 server VM using LAMP

c128
Posts: 59
Joined: Sat Sep 14, 2013 3:36 pm

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by c128 » Wed Nov 21, 2018 9:34 pm

Given that I guess this isn't expected behaviour, as it doesn't work this way for non-h.264 stored files, I've raised a bug here https://github.com/ZoneMinder/zoneminder/issues/2319.

krejler
Posts: 1
Joined: Thu Nov 29, 2018 8:04 am

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by krejler » Thu Nov 29, 2018 8:07 am

+1 for this one, its anoying that its getting reset after each new event.

c128
Posts: 59
Joined: Sat Sep 14, 2013 3:36 pm

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by c128 » Sat Dec 01, 2018 5:40 pm

Just seen that this has been fixed on Github for the next release - thanks chaps :D .

LBDG
Posts: 6
Joined: Mon Jun 23, 2014 10:17 am

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by LBDG » Sun Dec 09, 2018 3:50 pm

This fix maintaining set speed after each new event is great. Thank you

However I noticed that on my system (connor ppa stable 1.32.3) the set speed resets within an event when clicking the progress bar. I am not sure if this is the intended function but It would be beneficial if the set speed within the event remained fixed.

Thanks all contributors for this great piece of software.

c128
Posts: 59
Joined: Sat Sep 14, 2013 3:36 pm

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by c128 » Mon Dec 10, 2018 5:54 pm

Actually, I've just upgraded to 1.32.3 from the PPA, and I don't see any change in behaviour from the original defect (regardless of clicking in the progress bar) i.e. when viewing gapless events, and "upping" the rate, it still resets to 1x on the next event.

c128
Posts: 59
Joined: Sat Sep 14, 2013 3:36 pm

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by c128 » Mon Dec 10, 2018 8:40 pm

Yeah, I've just checked - post-upgrade to 1.32.3 I do have the changes in place from the commits listed in https://github.com/ZoneMinder/zoneminder/issues/2319 , but also the initial original issue...

Alec
Posts: 38
Joined: Thu Aug 17, 2017 3:55 am

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by Alec » Tue Dec 11, 2018 4:17 am

Actually, I've just upgraded to 1.32.3 from the PPA, and I don't see any change in behaviour from the original defect
Same here. Still resets to 1x on new event.

Also, for me, in the progress bar banner the zoneminder event timestamp is static with the event start time stamp. Previous beta versions showed the dynamic time of the frame being viewed in the progress bar banner. Not sure if this is related . . .?
DFU
v 1.32.x on Ubuntu 16.04 server using LAMP
v 1.31.x on Ubuntu 16.04 server VM using LAMP

User avatar
iconnor
Posts: 668
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Gapless Events - Fast Forward reverts back to 1x for each new event

Post by iconnor » Tue Dec 11, 2018 2:25 pm

1.32.3 was a slight improvement but still does not entirely fix the problem, as many of you have noted.

I have pushed some additional fixes to master which will go in the next release.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests