Running Zoneminder inside Mininet

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
Posts: 1
Joined: Mon Nov 05, 2018 7:08 am

Running Zoneminder inside Mininet

Post by limciana » Mon Nov 05, 2018 7:13 am

I'm trying to run Zoneminder inside a Mininet host, without any luck.

I can only open Zoneminder when I use my native machine's IP address, and not the mininet host's IP address. If I type in the mininet host's IP address on the address bar, it says it's unable to connect to the server. However, when I type in my native machine's IP address, I see Apache2's Default Page, which means that Apache2 is running, but not inside the mininet host. What I want is that I can run Zoneminder (which means that I should run Apache2 and see its default page as well) using Mininet's IP address.

What I did is to open Firefox through root inside Mininet host (such that when I type localhost, it actually means the IP address of the Mininet host), and then tried typing the IP addresses.

I tried changing the IP address that Apache2 is to host, but it always gives me a DNS error whenever I use the mininet host's IP address, saying that it does not exist.

I did a native installation of mininet in my machine. My machine is a Linux Mint 18 Sarah, which runs on Ubuntu 16.04. My Zoneminder is version 1.32. I followed the Easy Way Installation from the official documentation.

I am not sure if I should configure zoneminder's connection to Apache, or Apache's connection to the network, for this to work.

Any help will be appreciated. Thank you!

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests