Missing thumbnails on timeline view - day/week/month, not hour.

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
lightenup
Posts: 11
Joined: Mon Oct 22, 2018 6:36 pm

Missing thumbnails on timeline view - day/week/month, not hour.

Post by lightenup » Wed Oct 31, 2018 3:25 pm

For starters, thanks all for the great work on this project! 1.32 has been amazing!

Now for my issue...

If I open the timeline view for a given camera for the "hour" time span, I am am able to move my cursor through the time line (in red) and see thumbnails. However, If I change the time span to day, week, or month the thumbnails are not displayed when moving through the timeline. I did some digging around and it looks like ffmpeg is being called but it is missing a duration, so the image creation fails:

I monitored the ffmpeg processes and found a working thumbnail:

Code: Select all

www-data  3521  0.0  0.0   4628   856 ?        S    11:06   0:00 sh -c ffmpeg -ss 554.06 -i /var/cache/zoneminder/events/5/2018-10-31/308130/308130-video.mp4 -frames:v 1 /var/cache/zoneminder/events/5/2018-10-31/308130/05543-capture.jpg
www-data  3522  0.0  0.2 550732 37008 ?        Dl   11:06   0:00 ffmpeg -ss 554.06 -i /var/cache/zoneminder/events/5/2018-10-31/308130/308130-video.mp4 -frames:v 1 /var/cache/zoneminder/events/5/2018-10-31/308130/05543-capture.jpg
Here is a failing thumbnail creation:

Code: Select all

www-data  3525  0.0  0.0   4628   788 ?        S    11:06   0:00 sh -c ffmpeg -ss  -i /var/cache/zoneminder/events/5/2018-10-31/308130/308130-video.mp4 -frames:v 1 /var/cache/zoneminder/events/5/2018-10-31/308130/04933-capture.jpg
www-data  3526  0.0  0.1 508480 30528 ?        R    11:06   0:00 ffmpeg -ss -i /var/cache/zoneminder/events/5/2018-10-31/308130/308130-video.mp4 -frames:v 1 /var/cache/zoneminder/events/5/2018-10-31/308130/04933-capture.jpg
It should be noted that this issue cropped up when I switched my cameras to use "Video Writer = H264 camera passthrough" and disabled "Save JPEGs". Any help would be appreciated.

Thanks again!

lightenup
Posts: 11
Joined: Mon Oct 22, 2018 6:36 pm

Re: Missing thumbnails on timeline view - day/week/month, not hour.

Post by lightenup » Thu Nov 01, 2018 12:39 am

Let me ask the question another way, for those of you using using the mocord/record function with "Video Writer H264 camera passthrough" and "Save JPEGs" disabled, does your timeline work properly in the day/week/month view? For example if you move your cursor through the solid red band at the bottom of a daily timeline, do you see thumbnail images?
Capture.PNG
Capture.PNG (18.29 KiB) Viewed 540 times


The reason I want to know this, is if this feature does in fact work, I will re-do my install.

Thanks again!

blitz1986
Posts: 5
Joined: Wed Oct 31, 2018 1:01 am

Re: Missing thumbnails on timeline view - day/week/month, not hour.

Post by blitz1986 » Thu Nov 01, 2018 2:34 am

Since ZM upgraded to 1.32.2 my timeline is messed up. Settings are as yours and when I run the courser thru the highlight there is a thumbnail and click there is video but in the solid section no thumbnail and no video. I've only been using ZM a couple months and don't know my way around very well. ZM is installed on a Centos 7 VM. Have you found any solution to this problem?

Thanks.

lightenup
Posts: 11
Joined: Mon Oct 22, 2018 6:36 pm

Re: Missing thumbnails on timeline view - day/week/month, not hour.

Post by lightenup » Thu Nov 01, 2018 2:09 pm

I have not fixed this, but honestly I think we should just be using "montage review" for this style of event viewing. I have casually run Zoneminder for years starting around version 1.28, but only recently got dedicated storage and more cameras. Here is the shameful part, last night I clicked on "montage review" for the first time. I was surprised how good it was, I don't see the need for the timeline feature any more.

blitz1986
Posts: 5
Joined: Wed Oct 31, 2018 1:01 am

Re: Missing thumbnails on timeline view - day/week/month, not hour.

Post by blitz1986 » Thu Nov 01, 2018 2:37 pm

I have been using montage view and recently discovered the way you view just to see if it worked. Like my montage view it doesn't. My montage view doesn't work if I click last hour or 8 hours...all red and data. But it is recorded when I go to the server and check the files the are there and play fine. I will probably spin up a new Centos VM and start over..Maybe Ubuntu..What are you running ZM on?

lightenup
Posts: 11
Joined: Mon Oct 22, 2018 6:36 pm

Re: Missing thumbnails on timeline view - day/week/month, not hour.

Post by lightenup » Thu Nov 01, 2018 11:56 pm

I am on Ubuntu 18.04. I am also using the iconner repo: https://launchpad.net/~iconnor/+archive ... inder-1.32

kevins
Posts: 3
Joined: Sun Aug 06, 2017 8:24 pm

Re: Missing thumbnails on timeline view - day/week/month, not hour.

Post by kevins » Sun Dec 09, 2018 11:55 pm

I recently installed ubuntu 16.04 for a friend and then followed https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way to install zoneminder. Before installing zoneminder I changed to mariadb as I had in previous installs using

Code: Select all

Upgrade the LAMP installed MySQL 5.7 to Mariadb with the command:

apt-get install mariadb-server
Secure Mariadb, create root password et. al.

mysql_secure_installation
Note: The MySQL/MariaDB configuration file is located at: /etc/mysql/mysql.conf.d/mysqld.cnf To better manage the MariaDB server I recommend you move the config file and replace the default my.cnf symbolic link (this also works for MySQL 5.6).

rm /etc/mysql/my.cnf  (this removes the current symbolic link)
cp /etc/mysql/mariadb.conf.d/50-server.cnf /etc/mysql/my.cnf
To change Mariadb settings:

nano /etc/mysql/my.cnf
Ctrl+o Enter to save

CTRL+x to exit

A tool that you may want to install is mysqltuner. This is handy to see what database paramaters need to be adjusted as your ZM system builds up events.

apt-get install mysqltuner
Seeing how efficient it now is with disk space I decided to do a fresh install on my own system so again installed Ubuntu 16.04 and done the same install. Both systems are having the same issues with the timeline thumbnails not showing unless I zoom in on the timeline and then it seems to work better. When thumbnails do not show I get this in the log

Code: Select all

2018-12-09 23:52:11	web_php		11340	FAT	No Frame found for event(710) and frame id(1)	/usr/share/zoneminder/www/views/image.php	135
2018-12-09 23:52:11	web_php		11340	ERR	Capture file does not exist at /zmdrive/2/2018-12-08/710/00001-capture.jpg	/usr/share/zoneminder/www/includes/Event.php	415
2018-12-09 23:52:11	web_php		17094	ERR	Capture file does not exist at /zmdrive/1/2018-12-08/712/00001-capture.jpg	/usr/share/zoneminder/www/includes/Event.php	415
Is this just a teething problem with the change to storing video instead of images?

moorsey
Posts: 51
Joined: Sun Jan 03, 2010 8:56 am

Re: Missing thumbnails on timeline view - day/week/month, not hour.

Post by moorsey » Sun Jan 06, 2019 12:09 pm

I get this also and have been wondering if it was due to no longer saving image files, but using the new passthrough feature

I seem to get occasional thumbnails on the timeline view, which seems a bit odd. But mostly see what you do, with a ton of errors stating missing files.

Edit - just figured this out I think. When using timeline view, the thumbnails are generated on the fly, this generation isn't fast enough for scrolling your mouse left and right across a load of events, so some fail. If however, you keep going back and too on the red bar, the missing images will eventually all be present as they are generated in the background.

See image below of a before and after on an event and what was stored in that events folder

Image

So this is sort of broken, but perhaps a downside of using passthrough recording

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests