Replay controls do not work on Fedora 28

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
jmynheir
Posts: 9
Joined: Fri Oct 05, 2018 6:24 am

Replay controls do not work on Fedora 28

Post by jmynheir » Wed Oct 10, 2018 10:58 pm

First off, thank you to the developers of Zoneminder. I have 3 Fedora boxes, all on F28, I upgraded from 1.30.4 to 1.32.0, and then 1.32.1. The Replay controls in event view do not do anything. Prev Event, and Next event DO work though. Rewind, Step Back, Pause, Play, Step Ahead, Fast Forward are all non-functional. I don't see any errors in the log files about this.

benThijssen
Posts: 3
Joined: Wed Dec 20, 2017 1:56 pm

Re: Replay controls do not work on Fedora 28

Post by benThijssen » Thu Oct 11, 2018 4:20 pm

I am using Centos7, 3.10.0-862.14.4.el7.x86_64. I installed zoneminder about 1 or 1,5 year ago using the installation guide for Redhat. https://zoneminder.readthedocs.io/en/la ... edhat.html

Issuing a yum update also updated zoneminder from 1.30.4 to 1.32.0. The zm webpage reported a http error 404 not found. I reinstalled the previous apache configuration for zoneminder that was saved as zoneminder.rpmsave or something like that. That solved the 404 not found error. The next problem was that the javascript files could not be found, resulting in a poor layout and none of the javascript bussons/check-boxes, etc... were recognized nor functioning. Below some lines of the Firefox web console:

Loading failed for the <script> with source “https://zoneminder.benthijssen.nl:8443/ ... 6774276.js”.
index.php:149
Loading failed for the <script> with source “https://zoneminder.benthijssen.nl:8443/ ... 6774276.js”.
index.php:150
Loading failed for the <script> with source “https://zoneminder.benthijssen.nl:8443/ ... 6774276.js”.
index.php:152
ReferenceError: toggleCheckbox is not defined[Learn More]index.php:1:1

I was not able to solve the problem by adding an alias for "/cache" "/var/cache/zoneminder/" in the apache configuration file for zoneminder: /etc/httpd/conf.d/zoneminder.conf .I tried several aliases to no avail.

I do not think that is the right way, but I solved the problem by commenting out the ZM_DIR_CACHE constant definition in file: /usr/share/zoneminder/www/includes/config.php


//
// This section contains options substituted by the zmconfig.pl utility, do not edit these directly
//
define( 'ZM_CONFIG', '/etc/zm/zm.conf' ); // Path to config file
define( 'ZM_CONFIG_SUBDIR', '/etc/zm/conf.d' ); // Path to config subfolder
// Define, and override any given in config file
define( 'ZM_VERSION', '1.32.0' ); // Version
define( 'ZM_DIR_TEMP', '/var/lib/zoneminder/temp' );
#### define( 'ZM_DIR_CACHE', '/var/cache/zoneminder' ); <--------------------- this line
global $configvals;

Despite a lot of searching I cound not find a message somewhere pointing to the same problem I had.

yum repolist:
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.mirror1.spango.com
* epel: mirror.slu.cz
* extras: mirror.sitbv.nl
* rpmfusion-free-updates: ftp.nluug.nl
* rpmfusion-nonfree-updates: ftp.nluug.nl
* updates: mirror.sitbv.nl
repo id repo name status
!base/7/x86_64 CentOS-7 - Base 9,911
!epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 12,726
!extras/7/x86_64 CentOS-7 - Extras 432
!rpmfusion-free-updates/x86_64 RPM Fusion for EL 7 - Free - Updates 243
!rpmfusion-nonfree-updates/x86_64 RPM Fusion for EL 7 - Nonfree - Updates 50
!updates/7/x86_64 CentOS-7 - Updates 1,543
repolist: 24,905

jmynheir
Posts: 9
Joined: Fri Oct 05, 2018 6:24 am

Re: Replay controls do not work on Fedora 28

Post by jmynheir » Thu Oct 11, 2018 7:52 pm

I was able to fix this on mine by setting Video Encoder "X264 Encode" on the monitors under "Storage" It seems this new option is left disabled on upgrade. Old events will not have replay control, but new video encoded events will work.
Attachments
monitor.png
monitor.png (36.92 KiB) Viewed 2423 times

snakeice
Posts: 6
Joined: Mon Oct 15, 2018 9:14 pm

Re: Replay controls do not work on Fedora 28

Post by snakeice » Tue Oct 16, 2018 12:01 pm

Thanks going to "Monitor -> Storage-> Video Writer" this helped me going forward! :D

gkmac
Posts: 9
Joined: Wed Jun 20, 2012 6:28 pm

Re: Replay controls do not work on Fedora 28

Post by gkmac » Sun Oct 21, 2018 2:32 pm

jmynheir wrote:
Wed Oct 10, 2018 10:58 pm
The Replay controls in event view do not do anything. Prev Event, and Next event DO work though. Rewind, Step Back, Pause, Play, Step Ahead, Fast Forward are all non-functional.
I too have been hit by this bug upon upgrade to v1.32.2

Like others here I've noticed this only affects sources which save individual frames to JPEGs. Switching the x264 video writer on does make the playback control buttons functional, with the "benefit" that all the old JPEG saved events cannot be played anymore.

This solves the problem in the event replay window, but the live camera view still has non-functional buttons.
jmynheir wrote:
Wed Oct 10, 2018 10:58 pm
I don't see any errors in the log files about this.
Nothing shows in Zoneminder's own logs, but the Apache log reveals that a 500 error is caused each and every time one of the buttons is clicked (ignore the ###'s in this example). This has also been noted in a github comment.

Code: Select all

192.168.### - - [20/Oct/2018:15:29:57 +0100] "GET /index.php?view=request&request=stream&connkey=80350&command=1 HTTP/1.1" 500 1 "http://zm.###/index.php?view=event&eid=107729&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Battr%5D=MonitorId&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Bop%5D=%3D&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Bval%5D=1&sort_field=StartTime&sort_asc=1&page=1" "Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0"
192.168.### - - [20/Oct/2018:15:29:58 +0100] "GET /index.php?view=request&request=stream&connkey=80350&command=2 HTTP/1.1" 500 1 "http://zm.###/index.php?view=event&eid=107729&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Battr%5D=MonitorId&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Bop%5D=%3D&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Bval%5D=1&sort_field=StartTime&sort_asc=1&page=1" "Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0"
192.168.### - - [20/Oct/2018:15:29:58 +0100] "GET /index.php?view=request&request=stream&connkey=80350&command=1 HTTP/1.1" 500 1 "http://zm.###/index.php?view=event&eid=107729&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Battr%5D=MonitorId&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Bop%5D=%3D&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Bval%5D=1&sort_field=StartTime&sort_asc=1&page=1" "Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0"
192.168.### - - [20/Oct/2018:15:29:59 +0100] "GET /index.php?view=request&request=stream&connkey=80350&command=2 HTTP/1.1" 500 1 "http://zm.###/index.php?view=event&eid=107729&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Battr%5D=MonitorId&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Bop%5D=%3D&filter%5BQuery%5D%5Bterms%5D%5B0%5D%5Bval%5D=1&sort_field=StartTime&sort_asc=1&page=1" "Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0"
I've had to roll back to v1.30.2 for the time being (thank goodness for VMs and LVM snapshots) but may be able to try v1.32.2 again at some point if anyone has a solution.
gkmac

gkmac
Posts: 9
Joined: Wed Jun 20, 2012 6:28 pm

Re: Replay controls do not work on Fedora 28

Post by gkmac » Tue Nov 06, 2018 10:22 pm

For those not tuned in to the github issue I linked, non-functional playback controls on JPEG stored events seem to be caused by PHP not being compiled with semaphore support. A patch is there which has since been applied to master.
gkmac

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest