Inconsistent handling of "Deep" storage schema?

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
zmeggyesi
Posts: 19
Joined: Mon Mar 05, 2018 12:10 pm

Inconsistent handling of "Deep" storage schema?

Post by zmeggyesi » Thu Oct 04, 2018 6:50 am

I've been bugged by a persistent problem for a few days now, ever since I added an external drive to the Raspi running ZM: events would be created, JPGs saved, videos recorded, then a few minutes later, they would disappear from the drive without a trace, while remaining in the database.

For instance, just after running Record for a few minutes, I have this on the external drive:

Code: Select all

root@observer:/mnt/external# ll 6/18/10/04/06/36/31/ | wc -l
996
which all goes away after zmaudit runs. Since I have level 9 debugging on zmaudit, I can see in the log that it locates the appropriate directories using the globs, but then for whatever reason decides that the event ID symlink is not valid (it is), and deletes everything.

Even more strange, the issue doesn't occur if I set the storage schema to "Shallow" - auditing runs and the events survive just as intended.
Attachments
zmaudit.log.txt
STDOUT of ZM Audit process run manually
(81.54 KiB) Downloaded 32 times
zm_debug.log.17016.txt
ZM debug log at level 9
(3.81 KiB) Downloaded 31 times

User avatar
knight-of-ni
Posts: 2228
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Inconsistent handling of "Deep" storage schema?

Post by knight-of-ni » Thu Oct 04, 2018 11:55 am

Is your eternal drive formatted with a native Linux filesystem that supports symbolic links, such as ext4?
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

zmeggyesi
Posts: 19
Joined: Mon Mar 05, 2018 12:10 pm

Re: Inconsistent handling of "Deep" storage schema?

Post by zmeggyesi » Thu Oct 04, 2018 12:01 pm

Hi,

Yes, I'm using Ext4 on the external drive.

When executing ls -lah (which ll is an alias for, just to be clear), I can see the link pointing to the right directory.

User avatar
iconnor
Posts: 806
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Inconsistent handling of "Deep" storage schema?

Post by iconnor » Fri Oct 05, 2018 6:02 pm

It's probably the bug we had that deletes events.

First off upgrade to 1.32.1
Second turn off zmaudit and run it manually or via cron or whatever (because it isn't required and is a resource hog)

If that doesn't fix it, check your filters. Often will will do greater than -7days... which means anything newer instead of anything older.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests