Ubuntu 18.04.1 Dependency errors

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
adiefender
Posts: 1
Joined: Mon Oct 01, 2018 9:03 pm
Location: Colorado

Ubuntu 18.04.1 Dependency errors

Post by adiefender » Mon Oct 01, 2018 10:01 pm

Fresh install Ubuntu 18.4.1 as headless and installing LAMP: sudo tasksel install lamp-server
added PPA: add-apt-repository ppa:iconnor/zoneminder-master
ran: apt update
ran: apt install -y zoneminder

I get the following
=============================================================================================
dan@ipcam:~$ sudo apt-get update
Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://ppa.launchpad.net/iconnor/zonemi ... ter/ubuntu bionic InRelease
Get:3 http://archive.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Fetched 172 kB in 1s (161 kB/s)
Reading package lists... Done
dan@ipcam:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dan@ipcam:~$ sudo apt install -y zoneminder
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
zoneminder : Depends: libavcodec57 (>= 7:3.4.4) but it is not installable or
libavcodec-extra57 (>= 7:3.4.4) but it is not installable
Depends: libavformat57 (>= 7:3.4.4) but it is not installable
Depends: libavresample3 (>= 7:3.4.4) but it is not installable
Depends: libavutil55 (>= 7:3.4.4) but it is not installable
Depends: libmp4v2-2 but it is not installable
Depends: libswscale4 (>= 7:3.4.4) but it is not installable
Depends: libvlc5 (>= 1.1.1) but it is not installable
Depends: libx264-152 but it is not installable
Depends: libjs-mootools (>= 1.4.5~debian1) but it is not installable
Depends: ffmpeg but it is not installable or
libav-tools but it is not installable
Depends: libdbd-mysql-perl but it is not installable
Depends: libphp-serialization-perl but it is not installable
Depends: libnet-sftp-foreign-perl but it is not installable
Depends: libdevice-serialport-perl but it is not installable
Depends: libimage-info-perl but it is not installable
Depends: libjson-any-perl but it is not installable
Depends: libjson-maybexs-perl but it is not installable
Depends: libsys-mmap-perl but it is not installable
Depends: liburi-encode-perl but it is not installable
Depends: libclass-std-fast-perl but it is not installable
Depends: libsoap-wsdl-perl but it is not installable
Depends: libio-socket-multicast-perl but it is not installable
Depends: libsys-cpu-perl but it is not installable
Depends: libsys-meminfo-perl but it is not installable
Depends: libdata-uuid-perl but it is not installable
Depends: libnumber-bytes-human-perl but it is not installable
Depends: libfile-slurp-perl but it is not installable
Depends: php5-apcu but it is not installable or
php-apcu but it is not installable
Depends: php-apc but it is not installable or
php-apcu-bc but it is not installable
Recommends: zoneminder-doc (>= 1.32.0~20181001104647-bionic) but it is not going to be installed
Recommends: ffmpeg but it is not installable
E: Unable to correct problems, you have held broken packages.
=======================================================================================================
Fixed by updating "/etc/apt/sources.list" with the following

deb http://archive.ubuntu.com/ubuntu bionic main multiverse restricted universe
deb http://archive.ubuntu.com/ubuntu bionic-security main multiverse restricted universe
deb http://archive.ubuntu.com/ubuntu bionic-updates main multiverse restricted universe

Saved and then did:
apt update
apt install -y zoneminder
systemctl enable zoneminder
service zoneminder start
a2enconf zoneminder
chown -R www-data:www-data /usr/share/zoneminder/
systemctl reload apache2

I'm now able to get to http://{Hostname}/zm

bbunge
Posts: 2436
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu 18.04.1 Dependency errors

Post by bbunge » Tue Oct 02, 2018 8:38 pm


benj29
Posts: 16
Joined: Wed Oct 03, 2018 6:38 am

Re: Ubuntu 18.04.1 Dependency errors

Post by benj29 » Wed Oct 03, 2018 4:54 pm

Hi, i'm sorry but i have the same problem than adiefender using the script provided by the documentation.
How can install ZM in ubuntu 18 ?

Image

bbunge
Posts: 2436
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu 18.04.1 Dependency errors

Post by bbunge » Wed Oct 03, 2018 6:29 pm

I have run that script several times in the past few days with no errors!

Edit: I have just run the install script on a fresh minimal install of Ubuntu 18.04-1 with LAMP and received no errors.

https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way

Regardless of the type of Ubuntu install you do, you must have LAMP (including Apache, MySQL or Mariadb, and PHP). The easiest way to do this is to run the LAMP install from tasksel. And you must be logged into a terminal with root privileges (sudo su). The install script does work! You can also add the PPA manually and run all the commands manually. Yes, you can use gdebi but I do not have instructions for that.

Oh, your install needs to be up to date:

apt update
apt upgrade
reboot if necessary

bbunge
Posts: 2436
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu 18.04.1 Dependency errors

Post by bbunge » Wed Oct 03, 2018 7:46 pm

benj29 wrote:
Wed Oct 03, 2018 4:54 pm
Hi, i'm sorry but i have the same problem than adiefender using the script provided by the documentation.
How can install ZM in ubuntu 18 ?

Image
Avez-vous installé la LAMP?

benj29
Posts: 16
Joined: Wed Oct 03, 2018 6:38 am

Re: Ubuntu 18.04.1 Dependency errors

Post by benj29 » Wed Oct 03, 2018 8:12 pm

Yep !

benj29
Posts: 16
Joined: Wed Oct 03, 2018 6:38 am

Re: Ubuntu 18.04.1 Dependency errors

Post by benj29 » Wed Oct 03, 2018 9:33 pm

I start from a fresh install.

Install Ubuntu 18.04 server with no snaps server option
sudo apt-get update && sudo apt-get upgrade
wait .... wait
sudo apt install tasksel
sudo tasksel install lamp-server
sudo mysql_secure_installation
sudo ufw allow in "Apache Full"
sudo reboot

...

after i stored the script in zm-install, saving.
chmod 755 zm-install
then sudo ./zm-install (not ./zm-install because in the script, it was written doing with sudo or su).

And once again...

Image

No idea ?

bbunge
Posts: 2436
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu 18.04.1 Dependency errors

Post by bbunge » Thu Oct 04, 2018 1:49 am

no, you have to become root by doing sudo su, then run tasksel and select LAMP. when tasksel is done run the install script.

If you install with the server CD or ISO install there is an option to install LAMP. I use the net install or mini.iso to install a basic Ubuntu OS without all the unneeded server stuff. That install gives you the option to install LAMP.

If you want to run the commands in teh script manually and prepend sudo to the commands.

But it is much easier to just tun the install script as root bu using sudo su

benj29
Posts: 16
Joined: Wed Oct 03, 2018 6:38 am

Re: Ubuntu 18.04.1 Dependency errors

Post by benj29 » Thu Oct 04, 2018 5:28 am

OK i will try to launch all the command when I'm root.
Here I will install with sudo.

When I read your message, the commands what I have entered are very close to your proposition.

I'm very unsure that is the difference to do in root instead of sudo but I'll try.

Thanks. Keep u in touch.

Could you confirm me the version of Ubuntu or a link to download it? 18.04 server version.

benj29
Posts: 16
Joined: Wed Oct 03, 2018 6:38 am

Re: Ubuntu 18.04.1 Dependency errors

Post by benj29 » Thu Oct 04, 2018 6:43 pm

Once again, i follow exactly what you said (or i'm stupid :D)

- install ubuntu 18.04.1 server version
sudo su
apt-get install tasksel
tasksel
- choose lamp and wait for installation complete
apt-get update
apt-get upgrade
nano zm-install
- copy and past the script provided by this link
https://wiki.zoneminder.com/Ubuntu_Serv ... e_easy_way
chmod 755 zm-install
./zm-install

and once again same trouble... several dependancies are not satisfied.

Code: Select all

[3J[H[2J[3J[H[2J[3J[H[2JLecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
software-properties-common est déjà la version la plus récente (0.96.24.32.5).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
[3J[H[2J Stable releases of ZoneMinder 1.32

This is to provide newer official packages for older ubuntu dists.

If you would like to make a donation to directly support this ppa, you may do so by sending paypal to <email address hidden> or send digital coins to the following addresses:
BTC: 143XJVxDQ1c1HF4vixuCZAqG6LDhSBQFwU
BCH: qpk8a4938am7ex37k2yfykyglkxg6v46v5jy8qw05c
ETH: 0xA23b82d94A3589A866529DE9db05E3ba8a37fed8
ECH: 0x93FC917d1B9d3EA6c83fC5E2b48C7314B00D9407
LTC: M9QT3SUywaEcPwMwvu9rFLVmMuugQzdPWK
 More info: https://launchpad.net/~iconnor/+archive/ubuntu/zoneminder-1.32
Press [ENTER] to continue or Ctrl-c to cancel adding it.
Atteint:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Atteint:2 http://ppa.launchpad.net/iconnor/zoneminder-1.32/ubuntu bionic InRelease
Atteint:3 http://archive.ubuntu.com/ubuntu bionic-security InRelease
Atteint:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Lecture des listes de paquets…
Atteint:1 http://ppa.launchpad.net/iconnor/zoneminder-1.32/ubuntu bionic InRelease
Atteint:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Atteint:3 http://archive.ubuntu.com/ubuntu bionic-security InRelease
Atteint:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Tous les paquets sont à jour.
[3J[H[2J[3J[H[2JLecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 zoneminder : Dépend: libavcodec57 (>= 7:3.4.4) mais il n'est pas installable ou
                       libavcodec-extra57 (>= 7:3.4.4) mais il n'est pas installable
              Dépend: libavformat57 (>= 7:3.4.4) mais il n'est pas installable
              Dépend: libavresample3 (>= 7:3.4.4) mais il n'est pas installable
              Dépend: libavutil55 (>= 7:3.4.4) mais il n'est pas installable
              Dépend: libmp4v2-2 mais il n'est pas installable
              Dépend: libswscale4 (>= 7:3.4.4) mais il n'est pas installable
              Dépend: libvlc5 (>= 1.1.1) mais il n'est pas installable
              Dépend: libx264-152 mais il n'est pas installable
              Dépend: libjs-mootools (>= 1.4.5~debian1) mais il n'est pas installable
              Dépend: ffmpeg mais il n'est pas installable ou
                       libav-tools mais il n'est pas installable
              Dépend: libdbd-mysql-perl mais il n'est pas installable
              Dépend: libphp-serialization-perl mais il n'est pas installable
              Dépend: libnet-sftp-foreign-perl mais il n'est pas installable
              Dépend: libdevice-serialport-perl mais il n'est pas installable
              Dépend: libimage-info-perl mais il n'est pas installable
              Dépend: libjson-any-perl mais il n'est pas installable
              Dépend: libjson-maybexs-perl mais il n'est pas installable
              Dépend: libsys-mmap-perl mais il n'est pas installable
              Dépend: liburi-encode-perl mais il n'est pas installable
              Dépend: libclass-std-fast-perl mais il n'est pas installable
              Dépend: libsoap-wsdl-perl mais il n'est pas installable
              Dépend: libio-socket-multicast-perl mais il n'est pas installable
              Dépend: libsys-cpu-perl mais il n'est pas installable
              Dépend: libsys-meminfo-perl mais il n'est pas installable
              Dépend: libdata-uuid-perl mais il n'est pas installable
              Dépend: libnumber-bytes-human-perl mais il n'est pas installable
              Dépend: libfile-slurp-perl mais il n'est pas installable
              Dépend: php5-apcu mais il n'est pas installable ou
                       php-apcu mais il n'est pas installable
              Dépend: php-apc mais il n'est pas installable ou
                       php-apcu-bc mais il n'est pas installable
              Recommande: zoneminder-doc (>= 1.32.1-bionic2) mais ne sera pas installé
              Recommande: ffmpeg mais il n'est pas installable
The user `www-data' is already a member of `video'.
Module rewrite already enabled
[3J[H[2J[3J[H[2J

bbunge
Posts: 2436
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Ubuntu 18.04.1 Dependency errors

Post by bbunge » Sat Oct 06, 2018 4:29 pm

Just set up a new Bionic "server" minimum install from a net boot CD. Installed Mariadb, Apache2 and PHP then use the install script from the Zoneminder WIKI. Everything works! No errors or issues.

Maybe you should use a different Ubuntu repository? Or, could using a language other than English cause the problem?

c128
Posts: 63
Joined: Sat Sep 14, 2013 3:36 pm

Re: Ubuntu 18.04.1 Dependency errors

Post by c128 » Sat Oct 06, 2018 8:12 pm

The answer is in the first post (along with the problem)?

I had to do the same as the OP on a clean (and very minimal) Ubuntu 18.04 server install, although having to do this varies (I suspect) depending on what you chose to install initially. Anyway,

Code: Select all

/etc/apt/source.list
needs to be updated to includes the following:

Code: Select all

deb http://gb.archive.ubuntu.com/ubuntu/ bionic universe
deb http://gb.archive.ubuntu.com/ubuntu/ bionic-security universe
deb http://gb.archive.ubuntu.com/ubuntu/ bionic-updates universe
deb http://security.ubuntu.com/ubuntu bionic-security universe
...then an apt-get-update and the Zoneminder installation.

benj29
Posts: 16
Joined: Wed Oct 03, 2018 6:38 am

Re: Ubuntu 18.04.1 Dependency errors

Post by benj29 » Sun Oct 07, 2018 5:49 am

I will try and keep u in touch.
Maybe because I install Ubuntu in French version.
I will try with the sources.list modified directly and after I will try with English version...

benj29
Posts: 16
Joined: Wed Oct 03, 2018 6:38 am

Re: Ubuntu 18.04.1 Dependency errors

Post by benj29 » Sun Oct 07, 2018 7:50 am

Seems to be OK when i add your sources in sources.list.

The installation is in progress in Ubuntu 18 in French version.

Once again, thank you for your help :)

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests