New web interface incomplete?

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
mistral77
Posts: 14
Joined: Fri Jul 06, 2018 11:51 am

New web interface incomplete?

Post by mistral77 » Fri Sep 14, 2018 12:11 pm

Hello,
Is new web if still incomplete or is is just me?

Please look at the pictures ...
What is that "account_circle" or "network_check" or "trending_up"
Capture1.PNG
Capture1.PNG (14.42 KiB) Viewed 5724 times
Capture.PNG
Capture.PNG (25.06 KiB) Viewed 5724 times
Also , Force Alarm inside monitor page and fps count , doesn't seems to work any more !

Thank u!

adot
Posts: 8
Joined: Sat Apr 08, 2017 10:06 am

Re: New web interface incomplete?

Post by adot » Fri Sep 14, 2018 3:49 pm

same here [checked with latest Firefox and Chrome on Linux].

+ all archived Events are being deleted!

To fix it, you might just need to restart your apache webserver, as the apache conf file was changed.

A.

[The archived Events however are gone - unless you have a backup]

zraith
Posts: 5
Joined: Thu Aug 25, 2016 2:05 am

Re: New web interface incomplete?

Post by zraith » Fri Sep 14, 2018 5:44 pm

I am seeing this too. I was wondering if it was normal...

rockedge
Posts: 1154
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: New web interface incomplete?

Post by rockedge » Fri Sep 14, 2018 5:54 pm

no this is not normal. It appears to be a problem with the /www/zoneminder/cache directory which in turn is an Alias or symlink to /var/cache/zoneminder/cache

you may need to enable the new zoneminder.conf in /etc/apache2/conf-avialable and restart Apache

in the new zoneminder.conf the /var/cache/zoneminder/cache is declared and Alias defined.

moorsey
Posts: 51
Joined: Sun Jan 03, 2010 8:56 am

Re: New web interface incomplete?

Post by moorsey » Wed Sep 19, 2018 1:54 pm

This happens on a fresh Docker install also

Just loads of:

Code: Select all

Failed linking skins/classic/css/base/skin.css to skins_classic_css_base_skin-classic-1536958882.css
....with different css files

ANyone been able to fix?

zraith
Posts: 5
Joined: Thu Aug 25, 2016 2:05 am

Re: New web interface incomplete?

Post by zraith » Thu Sep 20, 2018 8:24 pm

rockedge wrote:
Fri Sep 14, 2018 5:54 pm
no this is not normal. It appears to be a problem with the /www/zoneminder/cache directory which in turn is an Alias or symlink to /var/cache/zoneminder/cache

you may need to enable the new zoneminder.conf in /etc/apache2/conf-avialable and restart Apache

in the new zoneminder.conf the /var/cache/zoneminder/cache is declared and Alias defined.
Something along these lines worked for me. I'm not too hot with Apache and messed with a few things. At some point it started working... lol

mistral77
Posts: 14
Joined: Fri Jul 06, 2018 11:51 am

Re: New web interface incomplete?

Post by mistral77 » Thu Sep 20, 2018 8:58 pm

For me,
the only issue now is , Force Alarm inside monitor page and fps count , not working!

Force Alarm does not do anything, and fps just displaying "- fps"!
My cams are all with Remote method , if it has to do with fps count!
In the main page fps per cam is working , but kbps displaying 0!
Kbps with FFMPEG method, is working!

Thank u!

rockedge
Posts: 1154
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: New web interface incomplete?

Post by rockedge » Fri Sep 21, 2018 12:28 am

I have run across this exact error also. Although on occasion in the right moment of the page refresh it will suddenly activate an event.

my fps indicator often reads 1001fps or null and most of the time I can not force an alarm through the console. And zmtrigger.pl is not running smoothly yet for me so using something like this

Code: Select all

echo "1|on+60|123|test||" | telnet localhost 6802
is not working

fradaxx
Posts: 4
Joined: Mon Apr 10, 2017 1:02 pm

Re: New web interface incomplete?

Post by fradaxx » Sat Oct 27, 2018 7:29 pm

Hi rockedge,

I have the same problem with my Zoneminder 1.32.2 installation on Ubuntu 14.04 (update frome ZM 1.30.4); all icons in the web interface of ZM are not present.

However the solution you proposed doesn't work for me.

The problem persists even enabling zoneminder.conf (perhaps already enabled) and restarting apache (or rebooting Ubuntu).

I see that directory /var/cache/zoneminder/cache is present with correct write permissions for www-data:www-data, but I see that it is always completely empty.

Can you suggest any other possible solution to this problem?

Thank you in advance.

Regards


rockedge wrote:
Fri Sep 14, 2018 5:54 pm
no this is not normal. It appears to be a problem with the /www/zoneminder/cache directory which in turn is an Alias or symlink to /var/cache/zoneminder/cache

you may need to enable the new zoneminder.conf in /etc/apache2/conf-avialable and restart Apache

in the new zoneminder.conf the /var/cache/zoneminder/cache is declared and Alias defined.

rockedge
Posts: 1154
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: New web interface incomplete?

Post by rockedge » Sat Oct 27, 2018 7:55 pm

check and see if there is a symlink /usr/share/zoneminder/www/cache with a target /var/cache/zoneminder/cache present

fradaxx
Posts: 4
Joined: Mon Apr 10, 2017 1:02 pm

Re: New web interface incomplete?

Post by fradaxx » Sun Oct 28, 2018 5:20 pm

No, the symlink wasn't present; its declaration solved the problem!

Thank you very much!

Regards
rockedge wrote:
Sat Oct 27, 2018 7:55 pm
check and see if there is a symlink /usr/share/zoneminder/www/cache with a target /var/cache/zoneminder/cache present

davew
Posts: 8
Joined: Sat Jul 04, 2020 5:33 am

Re: New web interface incomplete?

Post by davew » Sat Jul 04, 2020 5:44 am

fradaxx wrote:
Sun Oct 28, 2018 5:20 pm
No, the symlink wasn't present; its declaration solved the problem!

Thank you very much!

Regards
rockedge wrote:
Sat Oct 27, 2018 7:55 pm
check and see if there is a symlink /usr/share/zoneminder/www/cache with a target /var/cache/zoneminder/cache present
Confirm, symbolic link works. Version 1.34.16 ZM on Ubuntu 18.04 LTS running NGINX, MySQL, php7.3-fpm

Just clarify any misconceptions on how the the link should be targeted, because the previous message seemed to have it backwards....

SYMBOLIC LINK TARGET:
<SOURCE> /var/cache/zoneminder/cache/
<LINK_NAME> /usr/share/zoneminder/www/

Therefore the command that works is:

Code: Select all

sudo ln -s /var/cache/zoneminder/cache/ /usr/share/zoneminder/www/
This drops a symbolic link (a folder) right in the www root directory of ZoneMinder. Restart everything, and reload the webpage and now everything looks exactly how it should appear. All the buttons are in place and the web interface formatting appears correct.

Now to test adding cameras.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests