Dependency issue with php-apcu-bc when installing zoneminder on 16.04.5

Forum for questions and support relating to the 1.32.x releases only.
Post Reply
pennyzm
Posts: 2
Joined: Wed Oct 10, 2018 7:59 pm

Dependency issue with php-apcu-bc when installing zoneminder on 16.04.5

Post by pennyzm » Wed Oct 10, 2018 8:20 pm

Hello,

We are trying to install Zoneminder 1.32 on ubuntu 16.04.5.
Zoneminder will not install because php-apcu-bc is not installed. However, php-apcu-bc will not install.

We've followed the Zoneminder documentation:
- the ppa and the key has been added
- apache is on
- mysql is on
- we're updated to the latest on ubuntu 16.04.5

But we keep getting the message:
The following packages have unmet dependencies:
zoneminder: Depends: php-apc but it is not installable or php-apcu-bc but it is not installable
Unable to correct problems, you have held broken packages

What do we need to install php-apcu-bc and get zoneminder up and running?

Kind regards,
pennyzm

rockedge
Posts: 901
Joined: Fri Apr 04, 2014 1:46 pm
Location: Connecticut,USA
Contact:

Re: Dependency issue with php-apcu-bc when installing zoneminder on 16.04.5

Post by rockedge » Thu Oct 11, 2018 12:38 pm

what I do is look for php-apcu-bc and the php-apcu for version 16.04 and install that. Make sure the modules are then enabled in PHP and to restart Apache.

User avatar
iconnor
Posts: 566
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Dependency issue with php-apcu-bc when installing zoneminder on 16.04.5

Post by iconnor » Thu Oct 11, 2018 1:25 pm

Please add ppa:iconnor/zoneminder as well as ppa:iconnor/zoneminder-1.32

pennyzm
Posts: 2
Joined: Wed Oct 10, 2018 7:59 pm

Re: Dependency issue with php-apcu-bc when installing zoneminder on 16.04.5

Post by pennyzm » Fri Oct 12, 2018 8:22 pm

@iconnor,
Thank you for the reply.
We tried your solution and it worked.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests