Source Type "Remote" ends in 404 and 400 error

Forum for questions and support relating to the 1.31.x releases only.
Post Reply
DerGraf
Posts: 23
Joined: Fri Aug 17, 2018 7:33 pm

Source Type "Remote" ends in 404 and 400 error

Post by DerGraf » Sun Sep 02, 2018 12:11 pm

I have a crazy ffmpeg smearing issue with my Reolink 4MP camera. My 2MP Foscam works fine with ffmpeg.

After reading of similar issues, switching to "Remote" should help a lot.
"rtsp://user:pass@ip:554/h264Preview_01_main" works well on ffmpeg and in VLC (VLC without smearing).
Now i have switch to "remote" and give data as follows:

Remote Protocol: RTSP
Remote Method: RTP/RTSP
Remote Hostname: user:pass@ip
Remote Hostport: 554
Remote Hostpath: /h264Preview_01_main

It results in 404 Stream not found :evil:
I have try the Hostpath with and without starting backslash with same results. A backslash at ending of hostpath results in 404 and 400 error.

A try with my 2MP Foscam give me not a 404 error but a 400 error (Bad request)

Any ideas?

camguy
Posts: 3
Joined: Thu Sep 06, 2018 1:28 pm

Re: Source Type "Remote" ends in 404 and 400 error

Post by camguy » Thu Sep 06, 2018 1:48 pm

I am experiencing the same issue. I'm using a Reolink RLC-410, and I can get it to connect via ffmpeg, but the quality and frame rate I'm getting are terrible. I've tried connecting to it using Source Type: Remote, as you have described, but am getting the same 404 error.

I'm running Zoneminder 1.31.47 on Fedora.

Let me know if you ever figure it out!

DerGraf
Posts: 23
Joined: Fri Aug 17, 2018 7:33 pm

Re: Source Type "Remote" ends in 404 and 400 error

Post by DerGraf » Mon Sep 10, 2018 5:24 pm

I´m gone back to 1.30.4 for testing my cameras. Reolink and Foscam works fine with Remote Source. No Reolink smearing anymore. Storage changes was easy made by editing /etc/fstab. I think there are many things to do for the devs.

On the other side 1.30.4 works stable but has no audio and h264 passthrough support. The server load is slightly higher (0.9 in 1.30.4 vs. 0.7 in 1.31.45 on Intel J5005).

Reolink with 8fps 2540x1440 and Foscam with 10fps 1920x1080, both Modect.

Hope for stable 1.31 or 1.32 release this year. Last stable release comes 1 year (!!!) ago.

camguy
Posts: 3
Joined: Thu Sep 06, 2018 1:28 pm

Re: Source Type "Remote" ends in 404 and 400 error

Post by camguy » Wed Sep 12, 2018 4:40 pm

Is there an easy way to go back to 1.30.4 short of reinstalling the whole deal? I'm new to the software and 1.31.47 is the first version I've installed.

bbunge
Posts: 2269
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Source Type "Remote" ends in 404 and 400 error

Post by bbunge » Wed Sep 12, 2018 6:07 pm

You can uninstall and purge Zoneminder then drop the database. Remove the zoneminder-master PPA and set up the zoneminder PPA then install Zoneminder again. Or start with a fresh install of Ubuntu.

However, you have a very limited amount of time to do this as Zoneminder 1.32.0 has been released and the package maintainers will be updating the PPA and other repositories to 1.32.0 very soon.

Or, you can download and install the Lubuntu packaged with Zoneminder. I will not be updating that for a while and it has ZM 1.30.0.
https://wiki.zoneminder.com/Lubuntu_16. ... DVD_or_USB

camguy
Posts: 3
Joined: Thu Sep 06, 2018 1:28 pm

Re: Source Type "Remote" ends in 404 and 400 error

Post by camguy » Wed Oct 03, 2018 3:13 pm

Thank you! 1.30 seems to work much better with this camera. I am having some trouble installing that live CD to the hard drive though, whenever I try to run the installer that's on the desktop, I get the little loading icon for half a second and then nothing happens. If I try to run the installer from the command line as suggested on that wiki page:

Code: Select all

sudo sh -c 'ubiquity gtk_ui'
The command completes without an error or anything but nothing pops up and nothing happens. Ideas?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest